N54Tech.com - International Turbo Racing Discussion
(#1)
Old
emlevins emlevins is offline
New Member
 
Posts: 1
Join Date: Jun 2021
Car: 2014 BMW 335xi F30 N55
Default Thoughts and Advice please on RPM variability and mechanic's explanation - 06-22-2021, 10:30 AM

Hello - I have a Jb4 for a 2014 BMW 335xi F30 N55. No problem with it for 2 years. Had one on my 07 E90 for many years with no problem. I am a set it to map 1 and leave it guy. I am mechanically uninclined and my knowledge in this area is very limited so simple explanations or suggestions without shaming would be appreciated 😉.

I recently starting experiencing extreme rpm variability upon startup. Engine will race then almost stall, race, etc. This lasts for about a minute then it smooths out and car runs fine

Took the car to a local shop. I did not switch map from 1 to 0. He unplugged cable from obd port to check codes and got a code for the monitoring system (?). He did tuneup and found the plugs were a mess. He replaced them. Car did the same thing, and found new plugs were now fouled. He replaced them a second time. He disconnected Jb4 and reconnected things as they were as Oem. He said car runs fine.

He told me that there is power going to monitoring system but not out of the monitoring system to the Jb4. Hence, he says Jb4 is not getting power and problem is with monitoring system.

Thoughts?
Does this make sense?

Is the Normal setup for the JB4 to connect to monitoring system for power?

Does the rpm problem at setup sound like anything that would be JB4 related ( I was thinking perhaps the map setting was changed accidentally or something?). Thanks in advance for your help.

Any help would be appreciated. Thanks.



Sent from Yahoo Mail on Android
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,666
Join Date: Oct 2012
Car: 135i
Default 06-22-2021, 01:08 PM

This doesn't sound like a JB4 issue as it's not active at idle. Can you take a log of the issue so we can see it and verify the JB4 functionality? Be sure to uncheck "log heavy throttle only".



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
435gc 435gc is offline
Junior Member
 
Posts: 277
Join Date: May 2019
Car: 2015 435i xdrive gran coupe
Default 07-16-2021, 11:02 AM

Hey Steve

Not meaning to threadjack, but since op has not posted a log I thought it might help.

I am experiencing the exact same symptoms regarding rpms at cold start.

Attached is a log of the issue.

Any input would be greatly appreciated.
Attached Files
File Type: csv P10_M3_R1_210713_1444.csv (15.8 KB, 68 views)
Reply With Quote
(#4)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,666
Join Date: Oct 2012
Car: 135i
Default 07-19-2021, 11:01 AM

Initially trims (and AFR's) are in open loop likely causing the rough idle (intake leak?) Once trims go to closed loop the cars RPMS rise and then stabilize to look/run normal.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com