N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,283
Join Date: Aug 2013
Car: 2008 135i
Default 'Invalid Read' Bug in iOS Version 2.3.7 - 03-18-2019, 02:36 PM

This bug slipped all the way through beta and into the public channel, but luckily this is why I do phased rollouts.

I halted the rollout at 2% of users and have uploaded a new version which includes some FUD updates for various new engine types as well. I'm expecting this to be live in the public channel in a few days. If you want the fix now, the beta can be found here:

Join the JB4 Mobile beta - TestFlight - Apple

I could really use some help with getting feedback on these betas so situations like this can be avoided in the future.

*Update 3-19-19 6:30pm EST:
Update 2.3.8 is now processing for the App Store. You'll be able to manually update to it within the next 2-3 hours.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com

Last edited by Dmac @ BMS/DMD; 03-19-2019 at 03:30 PM..
Reply With Quote
(#2)
Old
DudeDude DudeDude is offline
New Member
 
Posts: 10
Join Date: Mar 2019
Car: 435xi
Default 03-18-2019, 03:10 PM

FYI - I was on iOS version 12.1.4 and had the “invalid read”. Ran the beta version of the app and all is working. I’ll report if I see anything strange. Thank you for the support.
Reply With Quote
(#3)
Old
Andrew1810 Andrew1810 is offline
Junior Member
 
Posts: 66
Join Date: Sep 2018
Car: M140i
Default 03-19-2019, 06:19 AM

Glad I found this thread, thought something was up with my OBD connection at first, then remembered there was an update last week. Good to hear itís already in the process of being sorted.
Reply With Quote
(#4)
Old
Oshusttoley Oshusttoley is offline
New Member
 
Posts: 25
Join Date: Mar 2013
Car: 335i
Default Same issue - 03-19-2019, 08:16 AM

Few! Thought my car took a bigger pooo! Thank goodness itís a big lol
Reply With Quote
(#5)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,283
Join Date: Aug 2013
Car: 2008 135i
Default 03-19-2019, 05:05 PM

*Update 3-19-19 6:30pm EST:
Update 2.3.8 is now processing for the App Store. You'll be able to manually update to it within the next 2-3 hours.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#6)
Old
Joohny16 Joohny16 is offline
New Member
 
Posts: 3
Join Date: Apr 2019
Car: Audi s3 8v
Default 04-02-2019, 02:23 PM

I have the version 2.3.8 and I had the code P03212 this morning
Does anyone know what it means ?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com