N54Tech.com - International Turbo Racing Discussion
(#1)
Old
JRB2 JRB2 is offline
New Member
 
Posts: 3
Join Date: Oct 2018
Car: 2014 BMW 535i Xdrive
Default 2014 BMW 535i Xdrive with PWG (F10 N55) Boost Problems Help!! - 02-21-2019, 10:34 AM

I am hoping someone has had a similar problem or one of the gurus can pipe in and give me a new direction to look for a solution. Currently the car has the MHD with JB4 tune. The vehicle has an upgraded CP, Catted Down Pipe, Intake and exhaust. I run stage 2 tune with about 95 octane. I have sent in multiple logs trying to get the vehicle a bit more dialed in however I keep getting told that it appears to have a boost leak.

I have pressurized the lines and cannot hear any leaks nor can I see any by spraying soapy water. I have also replaced the boost solenoid as I didn't have a true way of testing that in hopes it would be the issue yet still nothing.

What doesn't make sense is if I run the car around 2k rpm and keep in in that gear to red-line it boosts at approximately 15 psi and holds the entire time. Yet if I just let the car shift automatically, when the car kicks down and goes through the gears, I can see that the ECU is calling for 15 psi however it will only boost around 9-10. You can see when it shifts the boost will spike and then go back down to the 9 psi range.

Any ideas???

Last edited by JRB2; 02-21-2019 at 11:14 AM..
Reply With Quote
(#2)
Old
hardparker hardparker is offline
Junior Member
 
Posts: 57
Join Date: Nov 2017
Car: F25
Default 02-22-2019, 08:05 AM

Similar issue going on here possibly: https://www.n54tech.com/forums/showthread.php?p=624322


F25 X3 35i M Sport | Pure Stage 2 turbo + inlet | UR de-catted thingy | VRSF Race IC | FTP full thingies | BM3 PTF tuned | XDI-35 HPFP | Stage 2 LPFP | Ethanol mixed | WMI | Oil cooler | xHP | 50iX brakes
Reply With Quote
(#3)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,952
Join Date: Apr 2014
Car: E92 335XI
Default 02-24-2019, 10:01 PM

Quote:
Originally Posted by JRB2
I am hoping someone has had a similar problem or one of the gurus can pipe in and give me a new direction to look for a solution. Currently the car has the MHD with JB4 tune. The vehicle has an upgraded CP, Catted Down Pipe, Intake and exhaust. I run stage 2 tune with about 95 octane. I have sent in multiple logs trying to get the vehicle a bit more dialed in however I keep getting told that it appears to have a boost leak.

I have pressurized the lines and cannot hear any leaks nor can I see any by spraying soapy water. I have also replaced the boost solenoid as I didn't have a true way of testing that in hopes it would be the issue yet still nothing.

What doesn't make sense is if I run the car around 2k rpm and keep in in that gear to red-line it boosts at approximately 15 psi and holds the entire time. Yet if I just let the car shift automatically, when the car kicks down and goes through the gears, I can see that the ECU is calling for 15 psi however it will only boost around 9-10. You can see when it shifts the boost will spike and then go back down to the 9 psi range.

Any ideas???
Wed need a log to evaluate



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#4)
Old
E30_Crazy E30_Crazy is offline
New Member
 
Posts: 26
Join Date: Apr 2015
Car: '14 X1 35i, '87 325i MTech1
Default 03-11-2019, 01:55 PM

A wild guess, maybe your DV? After a gear shift, the DV does it's thing, then doesn't get a good seal again before the boost hits?
Reply With Quote
(#5)
Old
JRB2 JRB2 is offline
New Member
 
Posts: 3
Join Date: Oct 2018
Car: 2014 BMW 535i Xdrive
Default 03-30-2019, 12:57 AM

Since I made this post I have replaced the intercooler, upgraded to a pure stage 1 replaced the diverter with the GFB DV+. Still not hitting boost target. Not sure what can be adjusted. Any help would be appreciated!
Attached Files
File Type: csv 2019-03-29 09_04_07_Map-6.csv (9.3 KB, 57 views)
Reply With Quote
(#6)
Old
Relegate Relegate is offline
New Member
 
Posts: 9
Join Date: Mar 2019
Car: N55 135i
Default 04-23-2019, 05:36 PM

Keep us up to date. My car took a giant dump after I did the BEF and now Iím having to replace the DME. $1400 and back to stock power. Joy.
Reply With Quote
(#7)
Old
JRB2 JRB2 is offline
New Member
 
Posts: 3
Join Date: Oct 2018
Car: 2014 BMW 535i Xdrive
Default 04-23-2019, 06:50 PM

Seems to be running pretty good. Just wish I knew how to read and dial in the JB4. At this point I'm not itching to upgrade anything else but then again, not much left to do to.the car lol. That sucks about the DME. Can you take it somewhere and have them code it back to stock instead of buying a new one. Plenty of programmers out there.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com