N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Nanometer Nanometer is offline
Senior Member
 
Posts: 592
Join Date: Jan 2014
Car: 335i, 2009
Default Leaking Shocks - KW V3 - 03-21-2019, 09:00 AM

I got the KW V3 kit about 2 years ago for my 335i, and was mostly happy until about 7 months ago. The issues manifested itself in the form of unstable handling, car not settling after small bumps. And now after about 16K miles I found that I have leaking shocks in both the front and the rear. This seems like such an unusual circumstance to have two bad shocks. Was wondering if anyone else had such experiences with KW or other brands.


335i E90 2009 ///M Sport Auto
Mods: | Wagner Intercooler | MeowPipe | Meth-Trunk | JB4 | Pump_Back_End_Flash | Fuel-it! Stage 2
Drivetrain--------ForgeStar F14 Wheels 18" (245 & 275 PS4) | XHP L3 Transmission Flash | Wavetrac LSD
Suspension-------KW V3 Coil Overs| M3 RSF Bushings and Dif Bushings | H&R Sways


X5 50i 2013 ///M Sport
BMS Stage 1

Reply With Quote
(#2)
Old
Wladvertise Wladvertise is offline
New Member
 
Posts: 6
Join Date: Apr 2019
Car: 135i
Default 04-08-2019, 02:53 AM

I drive a KW Clubsport, which isnīt too far away from a v3. If they both start leaking, there must have gone something wrong while installing or while driving. Was the kit used? did you have a crash or a hard curb? I know a lot of guys in Germany that drive the KW suspensions.. and nobody hat issues like that. i would contact KW, they refurbish them for a reasonable Price.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright Đ 2007 - 2018, N54tech.com