N54Tech.com - International Turbo Racing Discussion
(#1)
Old
bl0wnb0xerbabie bl0wnb0xerbabie is offline
New Member
 
Posts: 6
Join Date: May 2017
Car: BMW 335i
Default CEL/"Engine malfunction" after JB4 Install - 05-15-2017, 09:28 PM

I have a 2010 bmw 335i. Besides the recently installed JB4, it is stock. After install, I have an intermittent CEL that comes on when I don't drive it like a grandma. Past 3.5-4k is when it will appear. It clears itself every time when I turn off the car.

The recorded CEL's are "2f6c exhaust fumeflap" and "30ff boost under target - possible boost leak"

Datalog is attached. Can anyone suggest what is wrong and how to fix?
Attached Files
File Type: csv 5-6-17 map 1.csv (56.5 KB, 283 views)
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,866
Join Date: Oct 2012
Car: 135i
Default 05-16-2017, 11:55 AM

I don't see an issue in the log, however it does look like you need to set menu 4 to option 3 with the steering wheel controls since you aren't running a flash.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
bl0wnb0xerbabie bl0wnb0xerbabie is offline
New Member
 
Posts: 6
Join Date: May 2017
Car: BMW 335i
Default 05-17-2017, 04:11 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
I don't see an issue in the log, however it does look like you need to set menu 4 to option 3 with the steering wheel controls since you aren't running a flash.
So will that fix the CEL's??
Reply With Quote
(#4)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 33,992
Join Date: Jan 2008
Default 05-18-2017, 10:45 AM

At the start of the log oil temp is 150f and the JB4 in low boost safety mode, so that is probably what Steve saw. Later in the log oil temps head up and boost is normal.

Do you have a log of 30FF coming up? I would try setting FutureUseA to 1 as a test as well.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#5)
Old
bl0wnb0xerbabie bl0wnb0xerbabie is offline
New Member
 
Posts: 6
Join Date: May 2017
Car: BMW 335i
Default 05-19-2017, 05:48 PM

Quote:
Originally Posted by Terry @ BMS
At the start of the log oil temp is 150f and the JB4 in low boost safety mode, so that is probably what Steve saw. Later in the log oil temps head up and boost is normal.

Do you have a log of 30FF coming up? I would try setting FutureUseA to 1 as a test as well.
Yea when I did those logs, the cell's didn't pop up then. So you're saying in order to see the problem, the log has to be done when the CEL comes on?

What is FutureUseA?
Reply With Quote
(#6)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 33,992
Join Date: Jan 2008
Default 05-27-2017, 04:33 PM

Ideally we'd want a log of the CEL coming up if its an intermittent issue. For now set FutureUseA = 1 also, as I said above, to see if that helps.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#7)
Old
bl0wnb0xerbabie bl0wnb0xerbabie is offline
New Member
 
Posts: 6
Join Date: May 2017
Car: BMW 335i
Default 09-06-2017, 02:42 PM

Quote:
Originally Posted by Terry @ BMS
Ideally we'd want a log of the CEL coming up if its an intermittent issue. For now set FutureUseA = 1 also, as I said above, to see if that helps.
So what is FutureUSA and how do I set this?
Reply With Quote
(#8)
Old
agenthubcap agenthubcap is offline
New Member
 
Posts: 17
Join Date: Aug 2017
Car: 2007 335i 6mt
Default 09-06-2017, 03:17 PM

Welcome to my world. I've been having almost the exact same issues.

First, you should start here to rule out the easy stuff: http://www.n54tech.com/forums/showthread.php?t=13114
Reply With Quote
(#9)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,866
Join Date: Oct 2012
Car: 135i
Default 09-06-2017, 09:55 PM

Future use A is on the user adjustment tab.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#10)
Old
E9xjake E9xjake is offline
Junior Member
 
Posts: 163
Join Date: Mar 2017
Car: 09 335xi
Default 09-06-2017, 11:59 PM

Btw that exhaust fume flap code means your car has the golf tee mod, meaning that your exhaust flap on your muffler is open at all times which is not gonna cause you any problems. But like they said, see if you can capture a log when the problem occurs.


@e9xjake 09 E90 335xi 6MT
JB4|BMS BEF|Doc Race w/PTE6266|VRSF CP w/Tial BOV|VRSF 7" IC|Fuel It! Stage 2 Bucketless|E40|
Reply With Quote
(#11)
Old
agenthubcap agenthubcap is offline
New Member
 
Posts: 17
Join Date: Aug 2017
Car: 2007 335i 6mt
Default 09-07-2017, 09:15 AM

Quote:
Originally Posted by E9xjake
Btw that exhaust fume flap code means your car has the golf tee mod, meaning that your exhaust flap on your muffler is open at all times which is not gonna cause you any problems. But like they said, see if you can capture a log when the problem occurs.
It is worth checking vacuum at the muffler to ensure there's no leaks in that line, though. That could totally be the issue.
Reply With Quote
(#12)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,866
Join Date: Oct 2012
Car: 135i
Default 09-07-2017, 09:33 PM

That is true...if the vacuum line has been removed and hadn't been plugged, that will be an issue.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#13)
Old
bl0wnb0xerbabie bl0wnb0xerbabie is offline
New Member
 
Posts: 6
Join Date: May 2017
Car: BMW 335i
Default 05-07-2020, 06:02 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
That is true...if the vacuum line has been removed and hadn't been plugged, that will be an issue.
Hay Steve - I hate to bring back this thread from the dead but long story short, my issues were never due to the JB4. I've had thousands spent on the repair of mechanical issues on the car.

To paraphrase the ongoing situation since originally posting this in 2017:
- uninstalled JB4 and continued to have CEL's when I installed the MHD
- many different theories and suggestions have been posted and taken into consideration
- dealership replaced the DME to MSD81 so not mosfet issue
- I've had no more issues with the car ever since BMW diagnosed and repaired multiple mechanical problems that probably has caused all of this grief since owning the car

I believe years ago you mentioned I could mail the JB4 to you and have it checked out. Since it looks like it was never defective, I would like to have it inspected before I sell it. I should be umarried. I would just hate to sell it to someone and have it be defective.

Please let me know if this would be okay.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com