N54Tech.com - International Turbo Racing Discussion
(#1)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default Help car stalled and wont start - 05-12-2017, 04:10 PM

Hi all,

I just recently had PS2, Stage 2 lpfp, plug/coils, alternator/battery, and waterpump installed/replaced. Map4/Map1 logs looked good on pump. E30 map2 logs had no issues. So I then filled up with e40, flashed E85 BEF and map2 logs also looked good, with avg ign <1.0. Swwithced to map 5 did sme runs, then switched back to map2 to get some logs to post on here. On one run, at 6-7k rpm, i had misfires on a few cylinders and limp mode. Cleared the codes, and everything seemed to be fine. Later that day, did a map 2 run (Attached) and all seemed ok. Went for another, then my car stalled, a bunch of errors popped up including the battery icon (log attached). Luckily, was able to coast to a side street and have my car towed to the place that did all my installs. Threw the following codes initially.

32D5 No Description Found
32D7 No Description Found
32D6 No Description Found
3886 No Description Found
3879 No Description Found
0000 No Description Found
0000 No Description Found
2C01 No Description Found
3792 No Description Found
CDB0 No Description Found
378F No Description Found
00F1 No Description Found
1010 No Description Found


I then cleared and car would turn over, but then immediately die. Then I had code 2c01. Is this my hpfp? Could it be anything else? Any input would be greatly appreciated!

For reference, my previous logs (from the past couple weeks are in this thread: http://www.n54tech.com/forums/showthread.php?t=46682)
Attached Files
File Type: csv 2017-05-11 10_26_13 misfire?.csv (6.9 KB, 135 views)
File Type: csv 2017-05-11 13_56_07 map2 before stall.csv (11.0 KB, 135 views)
File Type: csv 2017-05-11 13_58_47 stall..csv (7.3 KB, 141 views)


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 05-12-2017, 10:34 PM

Map 2 looked fine, how much fuel did you have in the tank? Your HPFP pressures dropped so either you had an empty tank, or some sort of fuel supply issue.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 05-13-2017, 08:57 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Map 2 looked fine, how much fuel did you have in the tank? Your HPFP pressures dropped so either you had an empty tank, or some sort of fuel supply issue.


Actually have more than 1/2 tank of gas. So really would have to just check everything from lpfp, hpfp, to injectors? I wasn't having long cranks prior to this.


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#4)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 05-13-2017, 12:12 PM

We can't monitor the LPFP on the N55, so you'll need to check. However if your float is stuck, that may be your issue and why it is showing 1/2 tank of fuel. Make sure nothing is blocking the movement of the float.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#5)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 05-19-2017, 01:17 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
We can't monitor the LPFP on the N55, so you'll need to check. However if your float is stuck, that may be your issue and why it is showing 1/2 tank of fuel. Make sure nothing is blocking the movement of the float.

Thx for the response, Steve. Had my car towed to the shop, it actually started up. Later, it was driving fine. Apparently there were some throttle setting and PWG settings that were incorrect. I recently flashed xHP Stage 3 so maybe that had something to do with it? Reset all adaptations, including throttle, with INPA and car has been driving fine.

I updated to the newest JB4 beta flash. I'm now running ~e45 (E50 according to the virtual sensor). Map 2 looked fine. Attached are a couple map5 runs and a map 7 log. Does everything look good? If so, where do I go from here to begin dialing in map 6 ? Thanks!
Attached Files
File Type: csv 2017-05-19 12_18_41 ().csv (10.8 KB, 115 views)
File Type: csv 2017-05-19 12_22_47 ().csv (9.8 KB, 129 views)
File Type: csv 2017-05-19 12_28_46 ().csv (11.4 KB, 120 views)


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#6)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 05-19-2017, 04:44 PM

another map7 log
Attached Files
File Type: csv 2017-05-19 15_43_56 ().csv (11.2 KB, 129 views)


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#7)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 05-21-2017, 11:07 PM

Log looks fine but PWM is completely maxed out. Boost leak maybe?

I'd also increase your DB settings to 65 and lower your FF to 100.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#8)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 06-02-2017, 06:34 PM

So, I do have a boost leak at the hot-side charge pipe. Waiting on ER / VRSF aftermarket options to become available.

Today, I was driving the car, did a short 3rd gear pull. Stopped at a light, accelerated gently, then did WOT in 3rd again. Car stalled again (this mainly electrical system-related codes and a shadow 2BDE hpfp code)! Car wouldn't turn over, initially. Then did a adaptations reset (Menu 1,7), let the car sit a bit, and was able to get the car to start and drove it home without issue.

I have no idea why this is happening. Per the logs, looks like a fueling issue again, but I never have any issues with long cranks. Can the hpfp be crashing intermittently? Also, I just filled up with gas (~E45), so I can't be physically low on fuel. Any input would again be appreciated.

Only thing I can think of is the xHP flash not playing well with the JB4 BEF (no option to select manual trans vs MHD standalone flash), as that was the only change really that I had prior to these events starting. Otherwise, I did have my alternator and battery replaced recently, as well. 38A4 is IBS malfunction code, but dunno if that can cause the whole car to stall? Alternator is bad? Any help would be appreciated


Codes:
32D5 No Description Found
32D7 No Description Found
32D6 No Description Found
3879 No Description Found
32D9 No Description Found
0000 No Description Found
0000 No Description Found
3792 No Description Found
3847 No Description Found
CDB0 No Description Found
38A4 No Description Found


2017-06-02 16_19_57:

3879 No Description Found
38A4 No Description Found
Attached Files
File Type: csv 2017-06-02 16_12_59 short pull.csv (7.9 KB, 133 views)
File Type: csv 2017-06-02 16_17_03 from dig.csv (9.1 KB, 134 views)
File Type: csv 2017-06-02 16_19_21 - stalled.csv (6.4 KB, 121 views)


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC

Last edited by fisc0h; 06-03-2017 at 12:22 AM..
Reply With Quote
(#9)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 06-03-2017, 04:20 PM

So, I flashed my TCU back to stock and reset all adaptations (including throttle). Still getting some electrical shadow codes, but as I understand this is normal, while the car is adapting? Took some logs and I think things looks OK, apart from my known boost leak (Map 2 & Map 7).

Anyone have any idea of what could be the cause of this? Could a bad IBS cause this?
Attached Files
File Type: csv 2017-06-03 10_16_57 ().csv (11.0 KB, 129 views)
File Type: csv 2017-06-03 10_19_10 ().csv (10.5 KB, 110 views)
File Type: csv 2017-06-03 10_21_20 ().csv (11.3 KB, 106 views)


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#10)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 06-04-2017, 08:46 PM

You have a known boost leak? If so, I wouldn't recommend doing pulls, especially on map 2 and 7.

No point in proceeding until that is fixed.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#11)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 07-16-2017, 04:35 PM

Hi Steve/All,

So, after repositioning and tightening my t-clamp on the hotside TIC pipe, I believe I addressed the boost leak I had. I was planning on having a dealership diagnosis my car, with the multiple stalls I've had. So I uninstalled MHD and was just running JB4 piggyback. I did several runs and after several days, I was unable to replicate any HPFP or electrical codes that I've been having. Car felt like it was running great. So, I re-installed MHD, drove it spiritedly, and then my car stalled again! Uninstalled MHD and car drove fine for 2-3 weeks. I prophylactically changed/coded a new EKP, thinking that somehow it might have overheated and could have been damaged. Car drove fine again. Then, got a random SES light with no codes, per JB4 mobile app. I later checked with MHD and had a shadow HPFP code(had this prior to changing EKP as well. Also, I checked with ISTA-D and it didn't have any fuel pump related codes). A couple weeks later, got half-engine light, but car drove fine. Then 5 min later, it completely stalled again. Since then, had my HPFP replaced. Car has been driving fine, but I'm still terrified of my car stalling again!

I was hoping you would be able to look at my logs and provide some input as to why this keeps happening. I spent a lot money and time installing PS2, LPFP, and now I can't even drive my car reliably, let alone as hard as I used to with e40+stock turbo. Any help would be greatly appreciated!

I've attached logs of pulls right before the stall and the when the car stalled, both of these with MHD pump BEF. I've also attached a recent JB4-only log, after my hpfp has been replaced.



Codes I got after 3rd stall
32D5 No Description Found
32D7 No Description Found
32D6 No Description Found
CDB0 No Description Found
3792 No Description Found
0000 No Description Found
0000 No Description Found
3847 No Description Found
2BE9 No Description Found
2C01 No Description Found
378F No Description Found
00F1 No Description Found
2232 No Description Found


Codes after 4th stall
2C6F No Description Found
281A No Description Found
2C58 No Description Found
2BEB No Description Found
281B No Description Found
0000 No Description Found
0000 No Description Found
2C70 No Description Found
277A No Description Found
2C01 No Description Found


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#12)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,614
Join Date: Jan 2008
Default 07-16-2017, 04:57 PM

I don't see any reason for it to stall out in the log. Keep removing mods until the car runs normally and if it still doesn't run right fully stock then its delaership time!


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#13)
Old
sw1183's Avatar
sw1183 sw1183 is offline
New Member
 
Posts: 19
Join Date: Jun 2014
Car: 11' 335xi e90
Default 08-16-2017, 03:27 PM

Quote:
Originally Posted by fisc0h
Hi Steve/All,

So, after repositioning and tightening my t-clamp on the hotside TIC pipe, I believe I addressed the boost leak I had. I was planning on having a dealership diagnosis my car, with the multiple stalls I've had. So I uninstalled MHD and was just running JB4 piggyback. I did several runs and after several days, I was unable to replicate any HPFP or electrical codes that I've been having. Car felt like it was running great. So, I re-installed MHD, drove it spiritedly, and then my car stalled again! Uninstalled MHD and car drove fine for 2-3 weeks. I prophylactically changed/coded a new EKP, thinking that somehow it might have overheated and could have been damaged. Car drove fine again. Then, got a random SES light with no codes, per JB4 mobile app. I later checked with MHD and had a shadow HPFP code(had this prior to changing EKP as well. Also, I checked with ISTA-D and it didn't have any fuel pump related codes). A couple weeks later, got half-engine light, but car drove fine. Then 5 min later, it completely stalled again. Since then, had my HPFP replaced. Car has been driving fine, but I'm still terrified of my car stalling again!

I was hoping you would be able to look at my logs and provide some input as to why this keeps happening. I spent a lot money and time installing PS2, LPFP, and now I can't even drive my car reliably, let alone as hard as I used to with e40+stock turbo. Any help would be greatly appreciated!

I've attached logs of pulls right before the stall and the when the car stalled, both of these with MHD pump BEF. I've also attached a recent JB4-only log, after my hpfp has been replaced.



Codes I got after 3rd stall
32D5 No Description Found
32D7 No Description Found
32D6 No Description Found
CDB0 No Description Found
3792 No Description Found
0000 No Description Found
0000 No Description Found
3847 No Description Found
2BE9 No Description Found
2C01 No Description Found
378F No Description Found
00F1 No Description Found
2232 No Description Found


Codes after 4th stall
2C6F No Description Found
281A No Description Found
2C58 No Description Found
2BEB No Description Found
281B No Description Found
0000 No Description Found
0000 No Description Found
2C70 No Description Found
277A No Description Found
2C01 No Description Found

Any updates on your issues??


2011 N55 E90 335xi

Pure Turbos Stage 2 | Pure High Flow Turbo Inlet | GFB DV+ | JB4 + FF Wires | Cobb BEF E85PI | Fuel-It! Stage 2 LPFP (e65) | Fuel-It! TBI Platinum | VRSF DP | VRSF CP | VRSF 7" FMIC | BMS CAI | BMS OCC | ER F30 TIC | N20 TMap | Alpina Trans Flash
Reply With Quote
(#14)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 08-17-2017, 11:35 PM

Quote:
Originally Posted by sw1183
Any updates on your issues??
Hi,

Yes, replaced my HPFP and so far, so good! Seems like that was the main issue.

This has been a completely frustrating and annoying issue. Dealing with the uncertainty of if/when my car would stall was pretty nerve racking. I did get a random half-engine light with some shadow hpfp codes one time; however my car didn't stall. I pulled over, checked codes, reset adaptations and reset codes and everything was fine. I actually re-flashed MHD and have been running the pump flash without issue. Actually filled up with E30-E40 recently and ran it pretty hard a few times and car seems to be running well. I'll have to post some logs once I can get some decent runs in.


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#15)
Old
Ryan1series Ryan1series is offline
Junior Member
 
Posts: 37
Join Date: Jan 2020
Car: 135i
Default 02-28-2020, 02:46 PM

Update on this have simple problems
Reply With Quote
(#16)
Old
fisc0h fisc0h is offline
Junior Member
 
Posts: 74
Join Date: Aug 2013
Car: 335i xdrve/m-sport
Default 02-29-2020, 08:08 AM

Quote:
Originally Posted by Ryan1series
Update on this have simple problems
Everything has been fine, since replacing my HPFP. Seems like that was intermittently failing, even though I didnít have the classic symptoms of that happening (long cranks, etc)

Hope this helps


2011 335i x-drive MSport: MHD PUMP_BEF + JB4 ISO 5.16 / Pure Stage 2 / Stage 2 LPFP (bucketless) / N20 TMAP / BMS Intake / ER CP / VRSF ** / VRSF 7" FMIC
Reply With Quote
(#17)
Old
Ryan1series Ryan1series is offline
Junior Member
 
Posts: 37
Join Date: Jan 2020
Car: 135i
Default 03-01-2020, 11:29 AM

Okay, thanks bro!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com