N54Tech.com - International Turbo Racing Discussion
(#1)
Old
bandook bandook is offline
Junior Member
 
Posts: 31
Join Date: Aug 2020
Car: 2013 335i
Default Avg_Ign resets when I restart the car - 10-22-2020, 07:24 PM

Is it normal for it to have to relearn every time I start the car? I just noticed this. I've been seeing how much e85 I can safely run and so I'll go do some runs and it will steadily drop from 5 down to 3.5 or lower. Seen it down to 2. Then next day I start the car and it's back up at 5.

This was a used board and I had to fix one of the traces on the circuit board that was blown out so I'm wondering if maybe one of the chips that retains the memory is messed up? My other settings seem to stay. If I end the day at 3, shouldn't it be at 3 when I restart the next day?
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,578
Join Date: Jan 2008
Default 10-23-2020, 09:19 AM

JB4 log so I can see the firmware version and details? It should only reset when changing maps.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
bandook bandook is offline
Junior Member
 
Posts: 31
Join Date: Aug 2020
Car: 2013 335i
Default 10-25-2020, 11:00 AM

Here's one on the 24th where I drove for awhile after putting e35 in. It was feeling really good towards the end. Ign got down to 3 and stayed there for multiple runs. May have went lower but i only did about 5-6 pulls. Then I took a log of today and first pull its reset to 5. I need to lower the e85 till i get some more fueling, but it's done this reset thing for awhile. Car always feels good after I drive for awhile then next day it's like it starts learning all over. BTW, these pulls aren't the cleanest i was hoping that it shows enough for just what ign is doing.

2013 pwg 335i
catle$s dp and chargepipe and stage 2 lpfp
new coils and plugs gapped to .020
Attached Files
File Type: csv P12_M5_R1_201024_151013.csv (8.6 KB, 9 views)
File Type: csv P12_M5_R1_201025_122219.csv (8.2 KB, 9 views)
Reply With Quote
(#4)
Old
bandook bandook is offline
Junior Member
 
Posts: 31
Join Date: Aug 2020
Car: 2013 335i
Default 10-31-2020, 10:10 AM

I think I've captured the issue. So I flashed e85 bef. Running 35%, I've tested the local E85 and it's e85. I also reflashed the latest firmware on the chance that some blocks didn't get written properly. This bef feels better than ever. And my adv ign quickly dropped from 4.5 to 1.9. But my app froze, which it's done multiple times. The gauges stop responding but it says it's still connected. Just figured it's an android bug. I disconnect/reconnect and my avg Ign is right back to 4.5. only reason I noticed it was because I only today stuck avg Ign in a gauge.

Here are two logs. One clean pull and then a cruising log right after the app had to be reconnected. These logs are minutes from each other.

Is something flakey with the board? My power and ground are solid.

Edit: I cut off the spade connectors from the obd wire and soldered them together. Figured it's a possibility it's a bad connection but does that explain the ign resetting?
Attached Files
File Type: csv P12_M5_R1_201031_124700.csv (7.4 KB, 7 views)
File Type: csv P12_M5_R1_201031_125812.csv (22.4 KB, 8 views)

Last edited by bandook; 10-31-2020 at 10:46 AM..
Reply With Quote
(#5)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,578
Join Date: Jan 2008
Default 10-31-2020, 03:04 PM

Maybe the JB4 itself is resetting before iavg is saved. Tried options bit7 for slower speed CANbus? I also just posted an update in the app under BETA v15_t2 firmware with another change that may help. So load that too to test out.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#6)
Old
bandook bandook is offline
Junior Member
 
Posts: 31
Join Date: Aug 2020
Car: 2013 335i
Default 11-05-2020, 05:44 PM

Quote:
Originally Posted by Terry @ BMS
Maybe the JB4 itself is resetting before iavg is saved. Tried options bit7 for slower speed CANbus? I also just posted an update in the app under BETA v15_t2 firmware with another change that may help. So load that too to test out.
Terry the new firmware worked, thanks! Aign now stays after a restart. However I'm having a different issue. I just bought and installed your wmi kit. Can you look at my log and tell me why Meth isn't logging? I am able to prime it with the app and have default settings set right in wmi tab, I believe. Looking at my iats it seems like its spraying? Orange wire #3 Blue #16. Anything I'm missing?
Attached Files
File Type: csv P12_M3_R1_201105_191130.csv (8.8 KB, 7 views)
Reply With Quote
(#7)
Old
bandook bandook is offline
Junior Member
 
Posts: 31
Join Date: Aug 2020
Car: 2013 335i
Default 11-05-2020, 06:56 PM



Reply With Quote
(#8)
Old
bandook bandook is offline
Junior Member
 
Posts: 31
Join Date: Aug 2020
Car: 2013 335i
Default 11-06-2020, 01:55 PM

Talked to BMS and I'm just going to buy a replacement board. I'll update if it all works out.

Edit: actually avgIgn is still resetting. At least on Map 5 it is. It wasn't doing it on map 3 when I was testing the WMI kit. Hopefully the new board will fix these issues. Also wondering if it's causing the overboost issues.

Last edited by bandook; 11-07-2020 at 03:54 PM..
Reply With Quote
(#9)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,578
Join Date: Jan 2008
Default 11-07-2020, 06:52 PM

If it's an old V1 board worth upgrade. If it's already a V2 board just need the 2580 chip for it to replace it's memory.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#10)
Old
bandook bandook is offline
Junior Member
 
Posts: 31
Join Date: Aug 2020
Car: 2013 335i
Default 11-07-2020, 09:56 PM

Quote:
Originally Posted by Terry @ BMS
If it's an old V1 board worth upgrade. If it's already a V2 board just need the 2580 chip for it to replace it's memory.

Yeah it's a V1 board. What makes it worth the upgrade besides hopefully fixing my issues? Please tell me it's 100 more hp

Edit: woke up this morning and had one of those "ah ha!" moments. I wired the pump to activate using a relay. Just figured it was a better way to do it. So the fsb is not seeing pump current. I didn't even think about how the wmi system sees meth flow until now. Duh.

Also confirmed that the avgIgn still resets on map 3 as well as 5.

Last edited by bandook; 11-08-2020 at 12:16 PM..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com