N54Tech.com - International Turbo Racing Discussion
(#1)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Smile New car, JB4 installed, log check please - 07-03-2016, 09:45 PM

Hello everyone. I have just bought my 2008 E82 135i auto. It has a GTX3582 installed and running JB4. I have tried to do as much research as possible before posting, but would like a seasoned expert to have a look at my log and give as much advice and opinions as possible. It is a daily driver and runs pump 98.
Attached Files
File Type: csv map 2 3rd gear.csv (8.5 KB, 132 views)
Reply With Quote
(#2)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-04-2016, 05:56 PM

Does anybody have an opinion on my log?
Reply With Quote
(#3)
Old
harkes harkes is offline
Registered Users
 
Posts: 781
Join Date: May 2014
Car: M135i
Default 07-04-2016, 06:05 PM

Anything in particular you are concerned about?
Reply With Quote
(#4)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-04-2016, 06:30 PM

It feels strong. Just looking for an experienced opinion. I have seen compared to others that the boost comes in stronger and is a little peaky in the mid range but don't think this is a concern. It is quite sensitive under light throttle though. Not as progressive as I would like it to be. Timing off boost looks a little gentle compared to other people.
Reply With Quote
(#5)
Old
harkes harkes is offline
Registered Users
 
Posts: 781
Join Date: May 2014
Car: M135i
Default 07-04-2016, 10:03 PM

I have a F-series N55 so I can only relate to that. Given that it is not the original turbo it will probably build boost a little slower.
Your ign timing looks a little strange but there are no sudden timing drops so octane wise you look good. Pay attention to your HPFP - you would want to stay above 10.

So yes, I think your look ok with this log.
Reply With Quote
(#6)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-04-2016, 10:30 PM

Thanks for the feedback, is there anything I should do to put the HPFP in to safe numbers?
Reply With Quote
(#7)
Old
Jayock's Avatar
Jayock Jayock is offline
Enginerd
 
Posts: 430
Join Date: Sep 2009
Car: 2009 135i
Default 07-06-2016, 01:36 PM

Your trims are maxed out, and your HPFP is getting close to its limit. You have very high FF and are under target, but this could be the FUD settings. Also, you are running a little rich top end, but rich is better than lean..

Ok, this one is tough, as we really have no idea why this previous owner set things the way they are. We really need a full list of mods. Any supplemental fueling (Meth, TBI, PI?). Is the LPFP stock or upgraded? What other mods?

First of all: write down all values from the user adjustment settings, so we can revert them.

I'd suggest that you:
Upgrade to the newest JB4 ST firmware.
Upgrade to the newest appropriate MHD flash.

Next:
1. Enable 6cyl logging, set 6cyl mode to 4 if early 2008 build, or 5 if late 2008 build. If one doesn't work, we can just try the other.
2. Set Future Use D = 0 (we may need to reset this to your current value).
3. Raise Fuel Open Loop (FOL) to 80 (this should help your HPFP some).
4. Raise boost safety to 18-18.5 (map 2 will target 17 on new firmware)

Then give us another log.


--2009 BMW 135i--2016 Nissan Titan XD (Turbo Cummins ISV)--2016 VW Tiguan 2.0Tsi --1988 Beechcraft Bonanza--Suzuki GSX-R 1000--Honda CBR-600RR--

JB4 G5 ISO | MHD | E85 | Fuel-It S3 LPFP / PI | MFactory S3+ Clutch / SMFW / LSD / Mounts | Diff Lock | UUC Tranny Mounts | DwnPipes / Exhaust / FMIC | Chargepipe / Tial | KW V3s | HR Sways | HPA full M3 Suspension | BMS DCI / Oil Cooler Valve / Cowl Filters / 4bar / 2Step / OCC | RB PCV | Stri Gauges | Pole Position 225/265 | Installing: DR 6466ST
Reply With Quote
(#8)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-06-2016, 04:44 PM

Thanks for the detailed and helpful response. From what I was told there is a GTX3582 turbo, custom manifold and exhaust. custom intercooler. Warlbro 255 pump with new HPFP. stock spark plugs but I do have a set of 5992's in the boot. I have an ODB2 cable coming in the mail. I did do a JB4 firmware update yesterday afternoon.

I have become aware that there is a small exhaust leak from the manifold. That would be causing a slightly low boost value. So that is on the short list of things to fix. I was waiting on gaskets to come, which I now have. Current user settings attached.
Attached Images
 
Reply With Quote
(#9)
Old
Jayock's Avatar
Jayock Jayock is offline
Enginerd
 
Posts: 430
Join Date: Sep 2009
Car: 2009 135i
Default 07-06-2016, 04:54 PM

A leak in the exhaust manifold? Or intake manifold?

On the exhaust manifold, unless it was big might create more lag, but you should have plenty of exhaust gas to run the turbo to full boost unless it is a gaping ugly hole.

Intake manifold, perhaps could cause this issue.

I'd give a good look at your boost and vacuum system to see if there are any obvious issues while you are in there.


--2009 BMW 135i--2016 Nissan Titan XD (Turbo Cummins ISV)--2016 VW Tiguan 2.0Tsi --1988 Beechcraft Bonanza--Suzuki GSX-R 1000--Honda CBR-600RR--

JB4 G5 ISO | MHD | E85 | Fuel-It S3 LPFP / PI | MFactory S3+ Clutch / SMFW / LSD / Mounts | Diff Lock | UUC Tranny Mounts | DwnPipes / Exhaust / FMIC | Chargepipe / Tial | KW V3s | HR Sways | HPA full M3 Suspension | BMS DCI / Oil Cooler Valve / Cowl Filters / 4bar / 2Step / OCC | RB PCV | Stri Gauges | Pole Position 225/265 | Installing: DR 6466ST
Reply With Quote
(#10)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-06-2016, 05:34 PM

Exhaust manifold. not massive, but I can hear it. Especially at cold start. I have had a sticky-beak while the car was running, everything appears to be fine. I looked for loose/broken/split hoses and oil leaks etc. Attached is the second screenshot of user settings. Like I said in the PM to you Jayock, the logging is set to 15, I think this is a typo and should be 5. I will check my build date in a few minutes.
Attached Images
 
Reply With Quote
(#11)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-06-2016, 05:58 PM

Build date is 09/08
Reply With Quote
(#12)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,859
Join Date: Jan 2008
Default 07-06-2016, 06:51 PM

Looks like you've got some advice on the settings end. I'd also update to the latest single turbo JB4 firmware.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#13)
Old
Jayock's Avatar
Jayock Jayock is offline
Enginerd
 
Posts: 430
Join Date: Sep 2009
Car: 2009 135i
Default 07-06-2016, 08:16 PM

Quote:
Originally Posted by IssueZ901
Build date is 09/08
Start with 6cyl=5

The 15 is usually an artifact from a very old firmware when someone didn't set defaults for the new features as directed in the release notes.


--2009 BMW 135i--2016 Nissan Titan XD (Turbo Cummins ISV)--2016 VW Tiguan 2.0Tsi --1988 Beechcraft Bonanza--Suzuki GSX-R 1000--Honda CBR-600RR--

JB4 G5 ISO | MHD | E85 | Fuel-It S3 LPFP / PI | MFactory S3+ Clutch / SMFW / LSD / Mounts | Diff Lock | UUC Tranny Mounts | DwnPipes / Exhaust / FMIC | Chargepipe / Tial | KW V3s | HR Sways | HPA full M3 Suspension | BMS DCI / Oil Cooler Valve / Cowl Filters / 4bar / 2Step / OCC | RB PCV | Stri Gauges | Pole Position 225/265 | Installing: DR 6466ST
Reply With Quote
(#14)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-06-2016, 09:00 PM

So I flashed on the latest firmware JB4 and changed those parameters you mentioned (FOL, boost safety and logging mode). I could not seem to change Future Use D though, it would send me to another page that had a heap of toggle buttons on it.

After I did that, I got this log. Looks like it got a little lean in the top end and overdid the target boost.
Attached Files
File Type: csv 2016-07-07 12_34_30.csv (9.4 KB, 104 views)
Reply With Quote
(#15)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-07-2016, 08:50 PM

After the last run in map 2 I was a little nervous about the AFR's so I had a look at map 6. Boost is way under target but at least the AFR's are safe.
Attached Files
File Type: csv 2016-07-08 10_28_01.csv (23.5 KB, 111 views)
Reply With Quote
(#16)
Old
Jayock's Avatar
Jayock Jayock is offline
Enginerd
 
Posts: 430
Join Date: Sep 2009
Car: 2009 135i
Default 07-07-2016, 09:06 PM

Nice. Sorry, been mobile all day, can respond to posts, but harder to look at logs. I'll try super hard tomorrow but I'm pretty slammed then too.


--2009 BMW 135i--2016 Nissan Titan XD (Turbo Cummins ISV)--2016 VW Tiguan 2.0Tsi --1988 Beechcraft Bonanza--Suzuki GSX-R 1000--Honda CBR-600RR--

JB4 G5 ISO | MHD | E85 | Fuel-It S3 LPFP / PI | MFactory S3+ Clutch / SMFW / LSD / Mounts | Diff Lock | UUC Tranny Mounts | DwnPipes / Exhaust / FMIC | Chargepipe / Tial | KW V3s | HR Sways | HPA full M3 Suspension | BMS DCI / Oil Cooler Valve / Cowl Filters / 4bar / 2Step / OCC | RB PCV | Stri Gauges | Pole Position 225/265 | Installing: DR 6466ST
Reply With Quote
(#17)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-07-2016, 10:23 PM

All good, sorry if I was coming across a bit pushy, just giving as much info as I can. Thanks :-)
Reply With Quote
(#18)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,477
Join Date: Oct 2012
Car: 135i
Default 07-08-2016, 08:50 AM

For map 6, FF will have to be adjusted up.

On map 1 your trims were maxed out, this was why you went lean.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#19)
Old
Jayock's Avatar
Jayock Jayock is offline
Enginerd
 
Posts: 430
Join Date: Sep 2009
Car: 2009 135i
Default 07-08-2016, 11:57 AM

Stick on map 6 since it is working right now.

On Future Use D, record/screen shot your settings, then turn all of them OFF, this will be the equivalent of '0' for that field. You JB4 isn't learning FF because of those settings.

Then set your FF / Wastegate adaption to the default of '80'. Also, raise your map 6 FOL to 70 (as I don't think the 40 in there now will provide enough fuel when boost goes higher). Then give us another log.

Next, lets get the most current ST BEF loaded as soon as your cable gets in. Your trims are high at higher boost, and the scalars in the BEF need to be adjusted properly. Hopefully the new one fits more closely.


--2009 BMW 135i--2016 Nissan Titan XD (Turbo Cummins ISV)--2016 VW Tiguan 2.0Tsi --1988 Beechcraft Bonanza--Suzuki GSX-R 1000--Honda CBR-600RR--

JB4 G5 ISO | MHD | E85 | Fuel-It S3 LPFP / PI | MFactory S3+ Clutch / SMFW / LSD / Mounts | Diff Lock | UUC Tranny Mounts | DwnPipes / Exhaust / FMIC | Chargepipe / Tial | KW V3s | HR Sways | HPA full M3 Suspension | BMS DCI / Oil Cooler Valve / Cowl Filters / 4bar / 2Step / OCC | RB PCV | Stri Gauges | Pole Position 225/265 | Installing: DR 6466ST

Last edited by Jayock; 07-08-2016 at 07:46 PM..
Reply With Quote
(#20)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-08-2016, 07:43 PM

Super, Thanks Jayock and Steve. I will make the adjustments over the weekend and send up another log Monday or Tuesday. CAN cable is due to arrive on Friday.
Reply With Quote
(#21)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-11-2016, 01:37 AM

I have turned future use D off, Wastegate adaption is 80 and FOL is 70. I this is only the 2nd time I have used full throttle full rpm, I don't know how long it takes to learn. AFR's still look good, I have noticed though that there is a meth reading. I have meth kit installed but don't have it filled. I should turn this off right? New log attached.
Attached Files
File Type: csv 2016-07-11 17_43_47.csv (19.5 KB, 109 views)
Reply With Quote
(#22)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-21-2016, 08:46 PM

I have flashed the latest backend map VIA MHD. This is the post-flash-info.

I had to drop the missus off at the airport today so I had the chance to do some pulls on the way to work. I switched to map 5 then did 3 x first to third gears before doing this log. I have noticed that there appears to be meth values. I have a system installed but have no meth in the reservoir. Is this going to be an issue? I may put some meth in for when I do some drags here but not for daily driving. Am I complicating things too much?
Name:  Screenshot_2016-07-21-20-41-13.jpg
Views: 209
Size:  57.8 KBName:  Screenshot_2016-07-21-20-41-17.jpg
Views: 220
Size:  69.5 KB
Attached Files
File Type: csv 2016-07-22 12_34_54.csv (34.8 KB, 112 views)
Reply With Quote
(#23)
Old
Jayock's Avatar
Jayock Jayock is offline
Enginerd
 
Posts: 430
Join Date: Sep 2009
Car: 2009 135i
Default 07-22-2016, 06:18 AM

All in all it looks pretty good now to me.

Your boost to target looks MUCH better now. LPFP, and AFR look good. Your HPFP is hanging in there, but its getting close to maxed out. We can play with FOL a little if needed to help out there. Watch for the HPFP dropping to or below 9 while WOT. You get right to 10 in this log, which is OK. Just keep an eye on it if you increase boost. Timing isn't great, more on that below.

The meth is reading is very low, which is fine. Its not enough to trigger meth additive on the meth add maps/settings. That reading is fine. You should either keep the tank full, or disconnect/disable the system if you are going to be running it for a long time empty. Pumps don't generally like to be run while dry. You could probably disable pretty easily by setting the MethPSI way high (like 40 PSI), so it never triggers it. But I haven't tried that to confirm.

You are getting some timing drops that indicate you might be octane starved. I assume its 98 octane RON, which puts you at about 94 octane R+M/2. You might want to consider running the meth system, with either Meth or Denatured Alcohol (available at home depot, next to the paint thinner). Of course mixed with distilled water. Start with 2:1 mix (66% meth or denatured, 33% water).

You will want more octane before pushing any more boost. And with a single turbo, you have lots of room for more boost should you want it.


--2009 BMW 135i--2016 Nissan Titan XD (Turbo Cummins ISV)--2016 VW Tiguan 2.0Tsi --1988 Beechcraft Bonanza--Suzuki GSX-R 1000--Honda CBR-600RR--

JB4 G5 ISO | MHD | E85 | Fuel-It S3 LPFP / PI | MFactory S3+ Clutch / SMFW / LSD / Mounts | Diff Lock | UUC Tranny Mounts | DwnPipes / Exhaust / FMIC | Chargepipe / Tial | KW V3s | HR Sways | HPA full M3 Suspension | BMS DCI / Oil Cooler Valve / Cowl Filters / 4bar / 2Step / OCC | RB PCV | Stri Gauges | Pole Position 225/265 | Installing: DR 6466ST
Reply With Quote
(#24)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,477
Join Date: Oct 2012
Car: 135i
Default 07-22-2016, 06:49 AM

When meth isn't activated there will be background "noise", pay no attention to it.

Why are you running map 5?



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#25)
Old
IssueZ901's Avatar
IssueZ901 IssueZ901 is offline
Junior Member
 
Posts: 64
Join Date: Jul 2016
Car: 2008 135i M Sport
Default 07-22-2016, 07:17 AM

Thanks Jayock. Yes I am running pump 98. We don't have a home Depot here but have a similar place, I will check it out. The previous owner run Meth e85 mix and 21psi I think. Made 607hp. He said it had a custom backend map but was a little rough with the pump fuel. We don't have e85 here. I am in the middle of the desert.
Hi again Steve. You ask why using map 5? Should I be using map 2 instead?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com