N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default HELP! JB4 + BEF running too rich - 11-04-2018, 10:27 PM

Just installed BEF with MHD and my CEL keeps popping up. When I read the code it says fuel mixture is too rich. Not sure on how to fix. I also set the burble aggressiveness to max when flashing if that is worth noting. Current mods are VRSF FMIC and CP, Injen CAI, Stock **. Not running any e85. Logs included below.
Attached Files
File Type: csv Running rich logs 11:4:18.csv (9.4 KB, 147 views)
Reply With Quote
(#2)
Old
WeekendWarriorz WeekendWarriorz is offline
Junior Member
 
Posts: 54
Join Date: Jul 2018
Car: 2012 135i N55 DCT
Default 11-04-2018, 10:45 PM

Did you flash the right bef? You're EWG I believe


2012 BMW 135i DCT, Late E series. VRSF meowless, ARM chargepipe, VRSF 7.5in race FMIC, Fuel it! Stage 2 LPFP- Sold
Reply With Quote
(#3)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-04-2018, 10:49 PM

Quote:
Originally Posted by WeekendWarriorz
Did you flash the right bef? You're EWG I believe
Yes i flashed EWG pump flash.
Reply With Quote
(#4)
Old
WeekendWarriorz WeekendWarriorz is offline
Junior Member
 
Posts: 54
Join Date: Jul 2018
Car: 2012 135i N55 DCT
Default 11-04-2018, 10:53 PM

Quote:
Originally Posted by Boostd435
Yes i flashed EWG pump flash.
Did you select "bit6 - Vehicle is equipped with a back end flash map" in the FUD settings?


2012 BMW 135i DCT, Late E series. VRSF meowless, ARM chargepipe, VRSF 7.5in race FMIC, Fuel it! Stage 2 LPFP- Sold
Reply With Quote
(#5)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-04-2018, 10:57 PM

Quote:
Originally Posted by WeekendWarriorz
Did you select "bit6 - Vehicle is equipped with a back end flash map" in the FUD settings?
no, what is FUD
Reply With Quote
(#6)
Old
WeekendWarriorz WeekendWarriorz is offline
Junior Member
 
Posts: 54
Join Date: Jul 2018
Car: 2012 135i N55 DCT
Default 11-04-2018, 11:01 PM

Quote:
Originally Posted by Boostd435
no, what is FUD
Alright that's your issue, Click on the Future use D bit in either the Jb4 mobile app or in the user adjustments page on your computer, then select "bit6 - Vehicle is equipped with a back end flash map", after than reset your ff/wastegate adaptation to 60


2012 BMW 135i DCT, Late E series. VRSF meowless, ARM chargepipe, VRSF 7.5in race FMIC, Fuel it! Stage 2 LPFP- Sold
Reply With Quote
(#7)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-04-2018, 11:07 PM

Quote:
Originally Posted by WeekendWarriorz
Alright that's your issue, Click on the Future use D bit in either the Jb4 mobile app or in the user adjustments page on your computer, then select "bit6 - Vehicle is equipped with a back end flash map", after than reset your ff/wastegate adaptation to 60
thanks my guy, will check tmrw to see if its running fine
Reply With Quote
(#8)
Old
WeekendWarriorz WeekendWarriorz is offline
Junior Member
 
Posts: 54
Join Date: Jul 2018
Car: 2012 135i N55 DCT
Default 11-04-2018, 11:12 PM

Quote:
Originally Posted by Boostd435
thanks my guy, will check tmrw to see if its running fine
That should fix your issue, take a 3rd or 4th gear log from 2500rpm to 6500rpm and turn off traction/DSC if you can (don't crash), make sure you change your ff/wastegate adaptation. Post a log and someone or myself can read it for you


2012 BMW 135i DCT, Late E series. VRSF meowless, ARM chargepipe, VRSF 7.5in race FMIC, Fuel it! Stage 2 LPFP- Sold
Reply With Quote
(#9)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,859
Join Date: Jan 2008
Default 11-04-2018, 11:37 PM

AFR isn't rich. What's the exact fault code?

You'll need the EWG connector installed to take advantage of the higher boost targets on the BEF.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#10)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-04-2018, 11:55 PM

Quote:
Originally Posted by Terry @ BMS
AFR isn't rich. What's the exact fault code?

You'll need the EWG connector installed to take advantage of the higher boost targets on the BEF.
Code is 118002 mixture ecu: mixture too rich
Reply With Quote
(#11)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-05-2018, 11:32 PM

Quote:
Originally Posted by WeekendWarriorz
That should fix your issue, take a 3rd or 4th gear log from 2500rpm to 6500rpm and turn off traction/DSC if you can (don't crash), make sure you change your ff/wastegate adaptation. Post a log and someone or myself can read it for you
log
Attached Files
File Type: csv 2018-11-05 08_15_15.csv (8.9 KB, 135 views)
Reply With Quote
(#12)
Old
WeekendWarriorz WeekendWarriorz is offline
Junior Member
 
Posts: 54
Join Date: Jul 2018
Car: 2012 135i N55 DCT
Default 11-05-2018, 11:44 PM

Quote:
Originally Posted by Boostd435
log
That log looks much better, do you have the EWG connector?


2012 BMW 135i DCT, Late E series. VRSF meowless, ARM chargepipe, VRSF 7.5in race FMIC, Fuel it! Stage 2 LPFP- Sold
Reply With Quote
(#13)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-06-2018, 03:36 PM

Quote:
Originally Posted by WeekendWarriorz
That log looks much better, do you have the EWG connector?
Just ordered the EWG connector should be coming in within the next couple days. Car is still throwing the CEL and getting same code despite adjusting the parameters. Hoping the connector will solve this issue. Maybe clean the maf sensor?
Reply With Quote
(#14)
Old
WeekendWarriorz WeekendWarriorz is offline
Junior Member
 
Posts: 54
Join Date: Jul 2018
Car: 2012 135i N55 DCT
Default 11-06-2018, 03:38 PM

Quote:
Originally Posted by Boostd435
Just ordered the EWG connector should be coming in within the next couple days. Car is still throwing the CEL and getting same code despite adjusting the parameters. Hoping the connector will solve this issue. Maybe clean the maf sensor?
I believe you need the connectors to run a bef. Since the boost targets are higher in every map. Put in the connectors then retry. Make sure you unplug the battery when touching the jb4/wires.


2012 BMW 135i DCT, Late E series. VRSF meowless, ARM chargepipe, VRSF 7.5in race FMIC, Fuel it! Stage 2 LPFP- Sold
Reply With Quote
(#15)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-12-2018, 01:30 PM

Quote:
Originally Posted by WeekendWarriorz
I believe you need the connectors to run a bef. Since the boost targets are higher in every map. Put in the connectors then retry. Make sure you unplug the battery when touching the jb4/wires.
I have installed Ewg connectors, still getting CEL. Same code (mixture too rich). here is a log:
Attached Files
File Type: csv 2018-11-12 11_56_18.csv (8.7 KB, 118 views)
Reply With Quote
(#16)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,859
Join Date: Jan 2008
Default 11-12-2018, 03:26 PM

Looks like just a fault that needs to be turned off or adjusted in the BEF to match the E85 mixture. What fuel mix?


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#17)
Old
Boostd435 Boostd435 is offline
New Member
 
Posts: 9
Join Date: Nov 2018
Car: 2015 435i
Default 11-12-2018, 08:44 PM

Quote:
Originally Posted by Terry @ BMS
Looks like just a fault that needs to be turned off or adjusted in the BEF to match the E85 mixture. What fuel mix?
Running pump flash on 91. no e85 in the tank (not so abundant where im from).
Reply With Quote
(#18)
Old
JLBimmer's Avatar
JLBimmer JLBimmer is offline
Junior Member
 
Posts: 72
Join Date: Jun 2019
Car: 2016 435ix GC
Default I am having the same issue - 08-23-2019, 10:37 AM

What happened and what was the resolution?


JL Bimmer
2016 435ix Gran Coupe
HRP Cold Air Intake, Charge Pipe, Turbo Up Pipe, Turbo Intake Pipe, BMS Intercooler, Axle Back Exhaust, JB4
H&R Springs, Sways, Strut Tower bar, 19"x10 Rotiforms, Too much carbon goodness
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com