N54Tech.com - International Turbo Racing Discussion
(#1)
Old
yamaharecker yamaharecker is offline
New Member
 
Posts: 2
Join Date: Jan 2013
Car: e92 335i
Default Coolant Leak - 11-10-2014, 09:34 AM

I Posted this is the other forum but I wanted your guys take on this.
What do you guys think this is? My car has 72k and it leaks about 1/4- 1/2 gallon every 2 days. It's puddles on the right side of the block right underneath the water pump. The hose with all the dried coolant on it is the front turbo intake hose right underneath the headgasket area. I dont think I have a blown head gasket (Oil is not milky, No oil in expansion tank). Are there any coolant hoses in that area you think could be leaking? Im going to do the waterpump, tstat but what hoses should I be looking at? Thanks in Advance
Attached Images
   
Reply With Quote
(#2)
Old
vitan's Avatar
vitan vitan is offline
Junior Member
 
Posts: 94
Join Date: Oct 2014
Car: e92 N54 335i
Default 11-10-2014, 09:40 AM

Quote:
Originally Posted by yamaharecker
I Posted this is the other forum but I wanted your guys take on this.
What do you guys think this is? My car has 72k and it leaks about 1/4- 1/2 gallon every 2 days. It's puddles on the right side of the block right underneath the water pump. The hose with all the dried coolant on it is the front turbo intake hose right underneath the headgasket area. I dont think I have a blown head gasket (Oil is not milky, No oil in expansion tank). Are there any coolant hoses in that area you think could be leaking? Im going to do the waterpump, tstat but what hoses should I be looking at? Thanks in Advance
I had same issue in 62k. Water pump was leaking, in place between its plastic and metal part...
Attached Images
 

Last edited by vitan; 11-10-2014 at 10:14 AM..
Reply With Quote
(#3)
Old
yamaharecker yamaharecker is offline
New Member
 
Posts: 2
Join Date: Jan 2013
Car: e92 335i
Default 11-10-2014, 02:26 PM

Only thing is the Waterpump is below the intake tube. Can coolant spray above it and pool in that area? There is a turbo coolant line running across that area that is of some interest as well.

Quote:
Originally Posted by vitan
I had same issue in 62k. Water pump was leaking, in place between its plastic and metal part...
Reply With Quote
(#4)
Old
prelude2perfect's Avatar
prelude2perfect prelude2perfect is offline
Junior Member
 
Posts: 448
Join Date: Sep 2010
Car: '07 335i
Default 11-12-2014, 11:59 AM

Quote:
Originally Posted by vitan
I had same issue in 62k. Water pump was leaking, in place between its plastic and metal part...
Had the same issue on mine at about 85k. Leaking right between metal and plastic. Tried jbweld and waterweld with little success, ending up replacing it along with tstat.

For the OP, you're around the time where waterpumps fail on these cars anyway so I would just replace that and the tstat and check everything else while you have it apart.


'07 E90 MT Sports Package l FBO l RB Next Gen Plus l JB4 G5 with DPT E85 BEF l N20 MAP Sensor l MMP Inlets l RB Outlets l Custom Exhaust l NLS & 2-Step l MFactory 3.46 LSD l 335is Clutch with MFactory SMFW l Walbro 450 l Direct Port Meth Injection

Best 1/4 ET: 11.4
Best 1.4 Trap: 127.7
Reply With Quote
(#5)
Old
vitan's Avatar
vitan vitan is offline
Junior Member
 
Posts: 94
Join Date: Oct 2014
Car: e92 N54 335i
Default 11-12-2014, 01:18 PM

+1, exactly the same...
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com