N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Meisseli Meisseli is offline
New Member
 
Posts: 4
Join Date: Oct 2018
Car: BMW 135i 2008 N54 With Upgraded IC, ***, CP and BOV
Default 135i N54 JB4 and Ethanol - 10-10-2018, 10:52 PM

Hey Everyone!

I'm a newcomer to BMWs and at the same time to tuned petrol engines. so I got a lot of questions that i have tried to get answers to from here but so far have failed to do so in many of them.

So firstly, Bought the BMW used with approx 150k km on the dial. Car was already equipped with the IC, ** and CP upgrades and had a ECU tune in it. it had some Wastegate rattle on it and since spending all that money on it (27K here in Finland), I'm still a bit short on cash to do anything big with them so i installed a JB4 to cancel out the rattle for now. Set up the JB4 with Map 2 and started driving again. all well and the power was a bit better also But i get this pesky 30ff error when accelerating on mild throttles for a long time, when on WOT everything is ok. Is there something to change in settings to cancel this out?

Secondly, since driving the car for about 10k km I really want try the E85 mixes and did the first at 9,5l e85 and rest 98e5 (dont know the US equivalent), changed to map 5 and upped the boost safety to 20psi, now the jb4 mobile app E85 dial reads 78-85 and sometimes when accelerating hard the jb4 switches to map 4 and last safety trigger is boost over safety. What can i do to make the drive more "reliable" and consistent?

Thirdly, what do i have to do to possibly make the capable to use 100% e85 all the time? worth the trouble at gas prices 98e5 1,7/l and e85 1,05/l

It is a Really fun and crazy car to drive coming from previous three models of MB E200CDI, and the pulls are really worth the price even though driving in finland is a bit pricey.

Thanks to everyone willing to help me with my "introduction to the "real" world of driving"

cheers -Meisseli.
Reply With Quote
(#2)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Junior Member
 
Posts: 269
Join Date: Jun 2017
Car: 07 E90 335i
Default 10-11-2018, 12:59 AM

Basics:

https://www.n54tech.com/forums/showthread.php?t=10605
Firmware up to date: Post #2
start with settings at Default: Post #3
Logs usually done in 3rd of 4th gear traction off, WOT 2k to Redline
Post your Log


07 E90 AT 335I 130k
JB4 G5 - Race BEF
DCI
VRSF CP - TS RP BOV-Orange Spring
VRSF V2 D-P's
7" FMIC
Stage 2 Bucket
Reply With Quote
(#3)
Old
Meisseli Meisseli is offline
New Member
 
Posts: 4
Join Date: Oct 2018
Car: BMW 135i 2008 N54 With Upgraded IC, ***, CP and BOV
Default 10-11-2018, 02:00 AM

Hi Haynpunch!

1) I've read the Basic and updated the firmware to the newest one and this 30ff code still returns when I try to give it a mild (about 50% pedal) and long acceleration (over 3secs steady increase of pedal). I can try this at default settings also and post back.

Is It enough to just change everything to default from mobile app and save the config to Jb4? Do I have to change something from the steering wheel controls?

2) I Will do this when trying the default settings, but can I leave the future use D as 98 to still use the anti rattle algorithm? Or does it have all the way default? Do you know why the e85 dial on Jb4 app shows me numbers from 78 to 85 although I only used about 20-25% e85?

3) I Will post logs from all three different scenarios hopefully today if I can make time to do the pulls.

Just to clarify, all pulls will be done on map 5 or?

Thanks in advance to you and everyone else contributing to my problems!

-meisseli
Reply With Quote
(#4)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Junior Member
 
Posts: 269
Join Date: Jun 2017
Car: 07 E90 335i
Default 10-11-2018, 05:05 AM

Post Logs and Codes if any
Most times to start you start with map 1 then work your way up.
I would leave all settings to default. Rattle is inevitable if your wastegates are done or improperly adjusted.


07 E90 AT 335I 130k
JB4 G5 - Race BEF
DCI
VRSF CP - TS RP BOV-Orange Spring
VRSF V2 D-P's
7" FMIC
Stage 2 Bucket
Reply With Quote
(#5)
Old
Meisseli Meisseli is offline
New Member
 
Posts: 4
Join Date: Oct 2018
Car: BMW 135i 2008 N54 With Upgraded IC, ***, CP and BOV
Default 10-11-2018, 10:47 PM

Hi!

Managed to take one quick log of a pull, but due to wet conditions it might not be a good one. Log was taken with map 5 and settings that was using are shown on a picture attached.

If somebody could take a Look and tell if there is something wrong with these results, that would be great!

Thanks again!

-meisseli
Attached Images
 
Attached Files
File Type: csv 2018-10-11 16_22_07.csv (15.5 KB, 13 views)
Reply With Quote
(#6)
Old
BMW135xi's Avatar
BMW135xi BMW135xi is offline
Junior Member
 
Posts: 223
Join Date: Jul 2016
Car: BMW 135I
Default 10-12-2018, 05:59 PM

Default Wastegate POS-0- ???? why 0 ? And Fuel Open loop -0-???
Reply With Quote
(#7)
Old
Meisseli Meisseli is offline
New Member
 
Posts: 4
Join Date: Oct 2018
Car: BMW 135i 2008 N54 With Upgraded IC, ***, CP and BOV
Default 10-15-2018, 04:29 AM

Quote:
Originally Posted by BMW135xi
Default Wastegate POS-0- ???? why 0 ? And Fuel Open loop -0-???
These are the settings that the previous owner had with the jb4 so I just left them as is and also saved a all default settings config. but with the settings that the previous owner had on the rattle is gone. although because i dont know exactly what affects what the car has a bit too long turbo lag from about 1,5k to 3k rpm.

i'm here to ask for any advice you can give to make it better so please do not hesitate to tell me what should i change and to which value.

Can anybody tell me why the E85 Dial on the JB4 mobile app keeps changing so much? sometimes it reads 65 and after a few drives it can be anything from 75 to 90? (everything is happening within the same tank.)
Reply With Quote
(#8)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Junior Member
 
Posts: 269
Join Date: Jun 2017
Car: 07 E90 335i
Default 10-16-2018, 12:01 AM

Quote:
Originally Posted by Meisseli
Can anybody tell me why the E85 Dial on the JB4 mobile app keeps changing so much? sometimes it reads 65 and after a few drives it can be anything from 75 to 90? (everything is happening within the same tank.)
https://www.n54tech.com/forums/showthread.php?t=10605
As suggested earlier start with "all" settings at default found in post #3

E85 reading is virtual unless you have a true e85 sensor


07 E90 AT 335I 130k
JB4 G5 - Race BEF
DCI
VRSF CP - TS RP BOV-Orange Spring
VRSF V2 D-P's
7" FMIC
Stage 2 Bucket
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com