JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
335i101 335i101 is offline
New Member
 
Posts: 8
Join Date: Jul 2011
Car: 07' 335 Cpe
Default Anybody know what this connect is for? - 07-02-2022, 10:09 AM

I received my JB4 and am installing it in a LX600, I have run into 2 issues.

1). The rear plug doesn’t “click” in. One of them does and the other is snug enough to stay, but I like to hear the click.

2). I have an extra wiring harness that I don’t see referenced in the instructions…


Thanks in advance.
Attached Images
 
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 34,322
Join Date: Jan 2008
Default 07-04-2022, 01:56 PM

I think we helped you via email and determined you were shipped an LS500 system by mistake.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
335i101 335i101 is offline
New Member
 
Posts: 8
Join Date: Jul 2011
Car: 07' 335 Cpe
Default 07-04-2022, 06:16 PM

Quote:
Originally Posted by Terry @ BMS
I think we helped you via email and determined you were shipped an LS500 system by mistake.
That you did, thank you for your continued excellence with customer support. 👍🏼
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2022, JB4tech.com