N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Loeschge Loeschge is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335i N55
Angry After Repairworks from BMW JB4 does not work anymore - 09-21-2019, 02:42 AM

Hi all,

I had to give my 335i N55 E91 to BMW for a recall. They had to change the main power cable at the power distributor. For that work they had of course to disconnect the battery. JB4 was on map 0 for that works. When I got back my car after one day, it did not start properly and the engine stopped always after seconds. Beside the standard codes for boost it says something like rail sensor short circuit. I can't connect with the JB4 via mobile or laptop anymore. Did they ruin the JB4 Chip? How is that possible? When I disconnect the JB 4 only the JB4 Box, the engine is running good again. Only the Code still stays. I will disconnect the whole cables today and see if the code is disappearing but I don't know how to connect with JB. Is there a way of resetting the box on the hardware?
Reply With Quote
(#2)
Old
Loeschge Loeschge is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335i N55
Default 09-24-2019, 11:21 AM

Yesterday I disconnected everything from the engine an only a error for the pressure and temp sensor occured. I will change it an connect the JB 4 again...
Reply With Quote
(#3)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,746
Join Date: Jan 2008
Default 09-28-2019, 12:10 PM

E chassis N55? Loose CANbus wires in ECU box?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#4)
Old
Loeschge Loeschge is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335i N55
Default 09-29-2019, 09:51 PM

Yes, E91 06/2010. The wires looked ok for me. But I have disconnected the JB 4 and have now chenged the air pressure sensor without succes. Same Code. Now I will check the cables. If I get to run the engine wothout JB4, I will connect it again but I have not so much hope...
Reply With Quote
(#5)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,743
Join Date: Apr 2014
Car: E92 335XI
Default 09-30-2019, 08:27 AM

Quote:
Originally Posted by Loeschge
Yes, E91 06/2010. The wires looked ok for me. But I have disconnected the JB 4 and have now chenged the air pressure sensor without succes. Same Code. Now I will check the cables. If I get to run the engine wothout JB4, I will connect it again but I have not so much hope...
Keep us posted



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#6)
Old
Loeschge Loeschge is offline
New Member
 
Posts: 6
Join Date: Jun 2019
Car: 335i N55
Thumbs down 10-06-2019, 03:54 AM

So I did replace the two pressure-temp sensors without success. I did also demount the auxiliary parts to the right of the engine to check the cables. Nothing found. So now I will give it back to BMW -> they have to find it! I am interested about the cost discussions and responsibilities....
After fixing this I will surly also need a new JB 4
Reply With Quote
(#7)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,743
Join Date: Apr 2014
Car: E92 335XI
Default 10-07-2019, 08:00 AM

Quote:
Originally Posted by Loeschge
So I did replace the two pressure-temp sensors without success. I did also demount the auxiliary parts to the right of the engine to check the cables. Nothing found. So now I will give it back to BMW -> they have to find it! I am interested about the cost discussions and responsibilities....
After fixing this I will surly also need a new JB 4
Fingers crossed they can find the issue...



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com