N54Tech.com - International Turbo Racing Discussion
(#1)
Old
spammer's Avatar
spammer spammer is offline
Junior Member
 
Posts: 193
Join Date: Jun 2017
Car: 435i
Default Did i brick my tcu? XHP F series flash - 04-10-2019, 12:45 PM

So i connected it up followed all the instructions under chapter 3. I'm using the Burgers DCan Cable a nexus 7 android 6.02.

I started the process it brought up the 3 bars to flash then failed. Transmission is in limp mode.

I got it to reconnect and tried to reset the tcu, it said it worked, then i tried to clear codes, it said it can't read codes.

I tried to flash it with stage 1,2 and 3 and each time it says my car is not compitable even though it is. I tried all the troubleshooting in the FAQ and emailed XHP.

As it stands now the car starts but the transmission shifter LED is off and it won't select a gear.

I also tried to flash back to factory but its giving me the 'car is not supported' thing.

I hooked my JB4 back up to read the codes, and below is a screenshot of those codes.

Anyone have an experience like this? Any tips would help I emailed xhp but they haven't gotten back to me yet (it just happened) Thanks.



can you put full coverage on a rebuilt title


Performance: 2014 435i : F33 (convertible) : 8AT : BMS Intake : VSRF Charge Pipe - Down Pipe & FMIC : JB4 Stage 2 : FF Wires : EWG Wires : 40% E85 : XHP Stage 3: E85 BEF

Dragy: "Spammer" 12.72@111.70 | 0-60 4.71
Reply With Quote
(#2)
Old
spammer's Avatar
spammer spammer is offline
Junior Member
 
Posts: 193
Join Date: Jun 2017
Car: 435i
Default 04-10-2019, 01:58 PM

It must be this burgers cable it. It was finicky when I MHD flash (couldn't move the tablet at all or it would disc) now i its saying cable is not connected either MHD or XHP.

IF i really hold it in tight i can get a reading from XHP satin the TCU is in boot mode, but i can't read or clear codes.


Performance: 2014 435i : F33 (convertible) : 8AT : BMS Intake : VSRF Charge Pipe - Down Pipe & FMIC : JB4 Stage 2 : FF Wires : EWG Wires : 40% E85 : XHP Stage 3: E85 BEF

Dragy: "Spammer" 12.72@111.70 | 0-60 4.71

Last edited by spammer; 04-10-2019 at 02:14 PM..
Reply With Quote
(#3)
Old
Bimmer_Boost's Avatar
Bimmer_Boost Bimmer_Boost is offline
Legend
 
Posts: 1,239
Join Date: Oct 2014
Car: 2011 e92 335i
Default 04-10-2019, 03:25 PM

I had an issue with MHD when I first tried to flash it. It failed mid flash and I had to go into their recovery mode once I got a new cable. I would get a new cable first.


2011 E92 335i Auto
12.0 @ 125MPH JB4
11.7 @ 120MPH E30 MHD / 0-60 3.66
Sold

2014 E84 X1 35i 12.85 @ 107MPH / 0-60 4.72 / 293 AWHP 305 AWTQ When stock
VRSF Chargepipe | BMS Intake | JB4 ISO | N20 TMAP | VRSF 7" Intercooler | ER Turbo Outlet |
Reply With Quote
(#4)
Old
spammer's Avatar
spammer spammer is offline
Junior Member
 
Posts: 193
Join Date: Jun 2017
Car: 435i
Default 04-10-2019, 04:19 PM

Quote:
Originally Posted by Bimmer_Boost
I had an issue with MHD when I first tried to flash it. It failed mid flash and I had to go into their recovery mode once I got a new cable. I would get a new cable first.
Indeed - this gives me hope. I don't see any results for 'bricked' xhp flash, i just ordered a bimmergeeks cable - now the waiting games begins.


Performance: 2014 435i : F33 (convertible) : 8AT : BMS Intake : VSRF Charge Pipe - Down Pipe & FMIC : JB4 Stage 2 : FF Wires : EWG Wires : 40% E85 : XHP Stage 3: E85 BEF

Dragy: "Spammer" 12.72@111.70 | 0-60 4.71
Reply With Quote
(#5)
Old
spammer's Avatar
spammer spammer is offline
Junior Member
 
Posts: 193
Join Date: Jun 2017
Car: 435i
Default 04-11-2019, 04:48 AM

So XHP hit me back said to execute the emergeancy flash under the MISC menu and start over : i hope it works. i may try with this B cable or just wait for the new cable to come ill report back later.


Performance: 2014 435i : F33 (convertible) : 8AT : BMS Intake : VSRF Charge Pipe - Down Pipe & FMIC : JB4 Stage 2 : FF Wires : EWG Wires : 40% E85 : XHP Stage 3: E85 BEF

Dragy: "Spammer" 12.72@111.70 | 0-60 4.71
Reply With Quote
(#6)
Old
T_H_O_M_A_S T_H_O_M_A_S is offline
Junior Member
 
Posts: 142
Join Date: Oct 2017
Car: M135ix
Default 04-11-2019, 08:22 AM

it will work , i knocked the cable out of its obd socket once while flashing , got the same messages as you , did the emergency flash , all is back to normal


M135i PWG , FBO , PS2 , LPFP st2 , HDP5evo , wedge MHD mapping , XHP AT8
Reply With Quote
(#7)
Old
spammer's Avatar
spammer spammer is offline
Junior Member
 
Posts: 193
Join Date: Jun 2017
Car: 435i
Default 04-11-2019, 09:36 AM

Quote:
Originally Posted by T_H_O_M_A_S
it will work , i knocked the cable out of its obd socket once while flashing , got the same messages as you , did the emergency flash , all is back to normal
Thanks for the reply THOMAS! Makes me feel alot better while i wait for a new cable. I hate just letting my car sit there all messed up. This helps lol.


Performance: 2014 435i : F33 (convertible) : 8AT : BMS Intake : VSRF Charge Pipe - Down Pipe & FMIC : JB4 Stage 2 : FF Wires : EWG Wires : 40% E85 : XHP Stage 3: E85 BEF

Dragy: "Spammer" 12.72@111.70 | 0-60 4.71
Reply With Quote
(#8)
Old
M-terkait's Avatar
M-terkait M-terkait is offline
M-Terkait
 
Posts: 284
Join Date: Dec 2013
Car: F30 335i
Default 04-11-2019, 01:12 PM

Quote:
Originally Posted by spammer
So XHP hit me back said to execute the emergeancy flash under the MISC menu and start over : i hope it works. i may try with this B cable or just wait for the new cable to come ill report back later.
happened to me actually, cuz my car had 0 battery, anyway its related to some issue i have on my car too lazy to look for it. anyway the emergency flash under MISC which was hidden for some reason. should fix it.



N55 - Doc race 6266.
Reply With Quote
(#9)
Old
Bimmer_Boost's Avatar
Bimmer_Boost Bimmer_Boost is offline
Legend
 
Posts: 1,239
Join Date: Oct 2014
Car: 2011 e92 335i
Default 04-11-2019, 01:15 PM

Actually come to think about it this happened when I was flashing XHP not MHD. My cable worked for MHD so I didn't think it was bad. I borrowed another from a friend and was able to complete the emergency flash. I replaced the cable and haven't had any issues since.


2011 E92 335i Auto
12.0 @ 125MPH JB4
11.7 @ 120MPH E30 MHD / 0-60 3.66
Sold

2014 E84 X1 35i 12.85 @ 107MPH / 0-60 4.72 / 293 AWHP 305 AWTQ When stock
VRSF Chargepipe | BMS Intake | JB4 ISO | N20 TMAP | VRSF 7" Intercooler | ER Turbo Outlet |
Reply With Quote
(#10)
Old
spammer's Avatar
spammer spammer is offline
Junior Member
 
Posts: 193
Join Date: Jun 2017
Car: 435i
Default 04-11-2019, 01:24 PM

Good to know i'm not the only one who did this.

Burgers are even sending me out a new cable w/o sending the old one back so thats nice of them and bimmergeeks just shipped theirs so ill have options. thanks again!


Performance: 2014 435i : F33 (convertible) : 8AT : BMS Intake : VSRF Charge Pipe - Down Pipe & FMIC : JB4 Stage 2 : FF Wires : EWG Wires : 40% E85 : XHP Stage 3: E85 BEF

Dragy: "Spammer" 12.72@111.70 | 0-60 4.71
Reply With Quote
(#11)
Old
spammer's Avatar
spammer spammer is offline
Junior Member
 
Posts: 193
Join Date: Jun 2017
Car: 435i
Default 04-17-2019, 08:20 AM



Thanks everyone for the piece of mind! Bimmergeeks cable fit snug as hell and it all worked like a charm. Emergency flash > xhp flash > Stage 3 flash! We're good!


Performance: 2014 435i : F33 (convertible) : 8AT : BMS Intake : VSRF Charge Pipe - Down Pipe & FMIC : JB4 Stage 2 : FF Wires : EWG Wires : 40% E85 : XHP Stage 3: E85 BEF

Dragy: "Spammer" 12.72@111.70 | 0-60 4.71
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com