N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Timyoy0 Timyoy0 is offline
Junior Member
 
Posts: 59
Join Date: Dec 2016
Car: 335i n55, e39 525i
Default Speedtech Tuning -- Boost Control - 05-08-2019, 06:42 AM

Hey all.

I've been working with @jturboawd over the past few months on tuning this speedtech EFR 7670 on my PWG N55 E90. It's been pretty difficult to track down these boost issues and constant dips/overboosts. I've been working through the Duty Bias and PID tuning to get it to target something like 18 PSI, but no luck. I attached the most recent log of 100 to see how this looks, you can see it hits around target at 3200 during spool, then it dips down before overboosting and continuing.

That is a 3rd gear pull, if I start the pull off at 4k+ RPM then it almost always overboosts to 22-23 PSI, so I can't do a 40-50 roll for an example.

The same issue with a 2nd gear pull from a dead stop, It will begin to overboost and run lean.

I am hoping to gain more insight from this fourm, although it seems not many people are able to correct this issue and ditch the JB4, I've been using it for 3 years so I would hate to get rid of it, but as summer is approaching and I want to order a PI kit, I need to figure this out.

Current mods:
E35~, Walbro 450, VRSF Intercooler, BMS intake, CP, ******* **, muffler delete, MHD BEF. Not sure if I'm missing anything else, but it is a "FBO"
Attached Files
File Type: csv 2019-05-03 15_48_25_Gear-3_Map-6.csv (7.4 KB, 45 views)
Reply With Quote
(#2)
Old
Timyoy0 Timyoy0 is offline
Junior Member
 
Posts: 59
Join Date: Dec 2016
Car: 335i n55, e39 525i
Default 05-08-2019, 11:15 AM

Can I get this moved to the support and log section please?
Reply With Quote
(#3)
Old
M-terkait's Avatar
M-terkait M-terkait is offline
M-Terkait
 
Posts: 289
Join Date: Dec 2013
Car: F30 335i
Default 05-08-2019, 01:19 PM

are you sure about the wastegate setting? try lowering it.
or maybe your wastegate arm is too tight.



N55 - Doc race 6266.
Reply With Quote
(#4)
Old
Timyoy0 Timyoy0 is offline
Junior Member
 
Posts: 59
Join Date: Dec 2016
Car: 335i n55, e39 525i
Default 05-08-2019, 01:41 PM

Quote:
Originally Posted by M-terkait
are you sure about the wastegate setting? try lowering it.
or maybe your wastegate arm is too tight.
Do you mean the WGDC/FF? I have it currently disabled because the overboosts is causing it to drop, so it's been overboosting then being way below target to redline
Reply With Quote
(#5)
Old
M-terkait's Avatar
M-terkait M-terkait is offline
M-Terkait
 
Posts: 289
Join Date: Dec 2013
Car: F30 335i
Default 05-08-2019, 02:01 PM

Quote:
Originally Posted by Timyoy0
Do you mean the WGDC/FF? I have it currently disabled because the overboosts is causing it to drop, so it's been overboosting then being way below target to redline
try to lower the default WG position in jb4. it should lower the tip of reaching the boost. and post some logs.



N55 - Doc race 6266.
Reply With Quote
(#6)
Old
Timyoy0 Timyoy0 is offline
Junior Member
 
Posts: 59
Join Date: Dec 2016
Car: 335i n55, e39 525i
Default 05-09-2019, 01:39 PM

Quote:
Originally Posted by M-terkait
try to lower the default WG position in jb4. it should lower the tip of reaching the boost. and post some logs.
Dropped it from 60-30 I believe. I played by dropping it to 40 and tweaked it but overall I didn't notice much difference. I dropped PID 18 from 20 and I tweaked duty bias a little bit but still no luck with the boost control.
Attached Files
File Type: csv 2019-05-09 15_42_55_Gear-3_Map-6.csv (9.1 KB, 37 views)
Reply With Quote
(#7)
Old
Weehe Weehe is offline
Senior Member
 
Posts: 666
Join Date: Jun 2014
Car: E90 335i
Default 05-10-2019, 08:08 AM

Sorry to say I can't see any way you will fix this with JB4/BEF. I fine tuned my BEF/duty bias setting for PS2 and have to go WOT 2500-3200rpms otherwise I get massive overboost every time. You can mess with wastegate settings to tame overboost but it will probably slow spool. Idk if tune only would be any better.
Reply With Quote
(#8)
Old
Timyoy0 Timyoy0 is offline
Junior Member
 
Posts: 59
Join Date: Dec 2016
Car: 335i n55, e39 525i
Default 05-10-2019, 08:17 AM

Quote:
Originally Posted by Weehe
Sorry to say I can't see any way you will fix this with JB4/BEF. I fine tuned my BEF/duty bias setting for PS2 and have to go WOT 2500-3200rpms otherwise I get massive overboost every time. You can mess with wastegate settings to tame overboost but it will probably slow spool. Idk if tune only would be any better.
I noticed that. The overboosts isn't massive if it's A WOT 3K.. BUT ONCE IT'S 4K+ Im seeing 23-24 psi with a 18 Target.

I only know of one person using speedtech with boost control. He had VANOS edits which I tried but no luck
Reply With Quote
(#9)
Old
M-terkait's Avatar
M-terkait M-terkait is offline
M-Terkait
 
Posts: 289
Join Date: Dec 2013
Car: F30 335i
Default 05-11-2019, 01:23 AM

Quote:
Originally Posted by Timyoy0
I noticed that. The overboosts isn't massive if it's A WOT 3K.. BUT ONCE IT'S 4K+ Im seeing 23-24 psi with a 18 Target.

I only know of one person using speedtech with boost control. He had VANOS edits which I tried but no luck
I Had the same problem when I used to run pure stage 2 with jb4, with flash only it was great no issues. but then no meth



N55 - Doc race 6266.
Reply With Quote
(#10)
Old
Timyoy0 Timyoy0 is offline
Junior Member
 
Posts: 59
Join Date: Dec 2016
Car: 335i n55, e39 525i
Default 05-14-2019, 01:01 PM

Running out of ideas... I just received my PI I ordered, so little torn if I should go custom tune and drop the JB4 all together. Its a shame.
Reply With Quote
(#11)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 30,307
Join Date: Jan 2008
Default 05-20-2019, 03:22 PM

WGDC isn't moving so wasting your time trying to resolve with PID related settings. It's VANOS table related.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#12)
Old
Weehe Weehe is offline
Senior Member
 
Posts: 666
Join Date: Jun 2014
Car: E90 335i
Default 05-21-2019, 09:08 AM

Would love to know the theory on vanos causing overboost. I understand it can improve spool up, but not sure how it can cause overboost.
Reply With Quote
(#13)
Old
Timyoy0 Timyoy0 is offline
Junior Member
 
Posts: 59
Join Date: Dec 2016
Car: 335i n55, e39 525i
Default 05-21-2019, 10:41 AM

Quote:
Originally Posted by Terry @ BMS
WGDC isn't moving so wasting your time trying to resolve with PID related settings. It's VANOS table related.
I saw a write up on this forum... is there any other documentation to solving this issue? I can try to edit the VANOS tables but not 100% certain what to look for.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com