N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Immoralus's Avatar
Immoralus Immoralus is offline
Junior Member
 
Posts: 87
Join Date: Jun 2015
Car: 2008 335xi
Default 2ABC and 3100- Car Shutting off while driving. - 10-19-2016, 03:43 AM

So yesterday I go to leave work and get a half engine, I check it and thought it said 2abd (a common tmap code I get) and a 3100 code. So no biggie I go to 1-2 in jb4 to clear it and my car shuts off. Oddly enough the car is reading me the codes still, even though I used the jb4 command to delete them.

So I manage to clear them, I jump on the highway boom cel for the same issue now my car sputters and then goes limp causing me to have to hit the shoulder. I try to delete it again and the car turns off again. I manage to limp her home with the check engine light in map 0.

So I thought, let me get my laptop and clear them only to realize that the same thing would happen. I'm at wits end here... I checked my 4bar tmap and that looked fine... any ideas?


08 335xi- JB4/Trebila,RB Inlets, VRSF CP ,FMIC, ** ,BMS DCI,e50 and Fuel-it Stage 2. 11.8 @ 118
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 10-19-2016, 06:18 PM

Verify N20 TMAP is set to 4 and that the connection is good at the sensor. If you're still getting them, go back to the stock sensor to verify it's not something else.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
Immoralus's Avatar
Immoralus Immoralus is offline
Junior Member
 
Posts: 87
Join Date: Jun 2015
Car: 2008 335xi
Default 10-19-2016, 07:43 PM

Thanks Steve , I'll give it a try. After researching this is a seemingly common issue with no definitive answer. Makes me worry...


08 335xi- JB4/Trebila,RB Inlets, VRSF CP ,FMIC, ** ,BMS DCI,e50 and Fuel-it Stage 2. 11.8 @ 118
Reply With Quote
(#4)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 10-19-2016, 10:02 PM

Whoops...I said to set the TMAP to "4", meant to say set your 4.0 TMAP to 2.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#5)
Old
Rob.K Rob.K is offline
Junior Member
 
Posts: 45
Join Date: Feb 2011
Car: 08 135i 6MT
Default 10-20-2016, 01:36 PM

I've had the same issue, was a loose wire going into the TMAP from taking out and installing several times.


Current - 2008 135i 6MT | XR9567
Sold - 2007 335xi AT | 12.1@117
Reply With Quote
(#6)
Old
Immoralus's Avatar
Immoralus Immoralus is offline
Junior Member
 
Posts: 87
Join Date: Jun 2015
Car: 2008 335xi
Default 10-21-2016, 09:39 AM

Cool so I've inspected all the wires.. still the same issue. Took off jb4 again same issue. Should I contact Terry to see if should purchase another tmap? I'm about to part this baby out lol. Jk jk


08 335xi- JB4/Trebila,RB Inlets, VRSF CP ,FMIC, ** ,BMS DCI,e50 and Fuel-it Stage 2. 11.8 @ 118
Reply With Quote
(#7)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,441
Join Date: Oct 2012
Car: 135i
Default 10-21-2016, 08:03 PM

Try swapping your stock TMAP back in and see if that resolves the issue.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#8)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is online now
Tuner
 
Posts: 29,711
Join Date: Jan 2008
Default 10-21-2016, 08:37 PM

Could be a faulty TMAP but more likely a BEF setting that needs to be changed for the 2ABD.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#9)
Old
Immoralus's Avatar
Immoralus Immoralus is offline
Junior Member
 
Posts: 87
Join Date: Jun 2015
Car: 2008 335xi
Default 10-23-2016, 05:37 AM

So yesterday I flashed the car back to stock, took off the jb4 and flashed the MHD e40 ots map and the car ran like new. This morning I go to start the car and the same code was apparent (2abc/3100) and car was revving high and carrying on. It's weird how it would work fine and then take a dump.

I seem to have misplaced my stock tmap in my move so I guess I'll have to get a new 4 bar.


08 335xi- JB4/Trebila,RB Inlets, VRSF CP ,FMIC, ** ,BMS DCI,e50 and Fuel-it Stage 2. 11.8 @ 118
Reply With Quote
(#10)
Old
Immoralus's Avatar
Immoralus Immoralus is offline
Junior Member
 
Posts: 87
Join Date: Jun 2015
Car: 2008 335xi
Default 11-10-2016, 05:10 AM

Just to give an update, Terry sent me a new 4bar Tmap with harness and the code hasn't been back.


08 335xi- JB4/Trebila,RB Inlets, VRSF CP ,FMIC, ** ,BMS DCI,e50 and Fuel-it Stage 2. 11.8 @ 118
Reply With Quote
(#11)
Old
BostonBeemah's Avatar
BostonBeemah BostonBeemah is offline
Senior Member
 
Posts: 831
Join Date: Sep 2011
Car: AW 135i
Default 11-10-2016, 09:45 AM

Quote:
Originally Posted by Immoralus
Just to give an update, Terry sent me a new 4bar Tmap with harness and the code hasn't been back.
I also got a new 4bar from Terry but not a harness. Code has come back twice in a 2 week period just at initial startup but I cleared and restarted the car without it coming back. Not sure if its the cold or whats going on here but I am just glad I can drive the car now..


2010 AW/BLK 135i VM 6465 Single Turbo, JB4 + MHD, VRSF CP & Tial, Big Tom, Fuel-It PI + Stage 3 + Return + Ethanol Sensor, BMW PE, MFactory LSD & Axles, Spec 3+ & MFactory SMFW, RB External PCV
Best stock turbo 12.5 @ 19.46 spinning all the way down
RIP 2008 AW/BL 135i
Reply With Quote
(#12)
Old
Immoralus's Avatar
Immoralus Immoralus is offline
Junior Member
 
Posts: 87
Join Date: Jun 2015
Car: 2008 335xi
Default 11-10-2016, 11:17 PM

I Bekieve it is the harness then.


08 335xi- JB4/Trebila,RB Inlets, VRSF CP ,FMIC, ** ,BMS DCI,e50 and Fuel-it Stage 2. 11.8 @ 118
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com