JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
N5(4x4) N5(4x4) is offline
New Member
 
Posts: 8
Join Date: Jan 2020
Car: 2008 335xi
Default Car throws codes unless Jb4 Bluetooth is connected. - 01-07-2022, 04:40 PM

Car is a 2008 e92 335xi.

I have an issue where the car will throw codes 2CFB
and 2B09 every startup and the idle will surge and car is undriveable. If I connect to JB4 Bluetooth mobile before starting car, the car wonít throw codes, and runs perfectly fine. Any help would be appreciated.
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 01-10-2022, 11:43 AM

What are the descriptions for the codes? That seems rather odd.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
N5(4x4) N5(4x4) is offline
New Member
 
Posts: 8
Join Date: Jan 2020
Car: 2008 335xi
Default 01-10-2022, 01:16 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
What are the descriptions for the codes? That seems rather odd.

The descriptions are as follows:

2CFB Throttle adaptation value
2D09 drosselklappe

It is very odd. I havenít found any other examples of it happening online in hours of searching. There are however examples of these codes being thrown, and Iíve tried the suggested steps in those threads.

I replaced and coded new battery which it needed anyway. New intelligent battery sensor. Replaced voltage regulator. I have plugged in and unplugged the throttle body connector several times. Taken off the throttle body. Cleaned throttle body. Put a new gasket from charge pipe to throttle body. Reset adaptations. Codes still show up on every startup, unless I connect to jb4 before starting the car. Then it runs perfectly.
Reply With Quote
(#4)
Old
N5(4x4) N5(4x4) is offline
New Member
 
Posts: 8
Join Date: Jan 2020
Car: 2008 335xi
Default 01-24-2022, 07:55 PM

So I bit the bullet and replaced the the throttle body itself. Started right up without having to link to jb4 Bluetooth. Seems to have fixed everything. Weird but I’ll take it! Hope this helps someone else. ��
Reply With Quote
(#5)
Old
N5(4x4) N5(4x4) is offline
New Member
 
Posts: 8
Join Date: Jan 2020
Car: 2008 335xi
Default 01-24-2022, 10:15 PM

Quote:
Originally Posted by N5(4x4)
So I bit the bullet and replaced the the throttle body itself. Started right up without having to link to jb4 Bluetooth. Seems to have fixed everything. Weird but Iíll take it! Hope this helps someone else. ��
Well I spoke too soon. After the car sat for a couple hours it had surging idle and threw the throttle body codes again. So new throttle body didnít fix it.
Reply With Quote
(#6)
Old
Cannon @ BMS Cannon @ BMS is offline
Senior Member
 
Posts: 573
Join Date: Sep 2021
Car: Evo VIII
Default 01-25-2022, 11:41 AM

Please upload a log with the occurring problem. Thanks!


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#7)
Old
N5(4x4) N5(4x4) is offline
New Member
 
Posts: 8
Join Date: Jan 2020
Car: 2008 335xi
Default 01-25-2022, 01:44 PM

Quote:
Originally Posted by Cannon @ BMS
Please upload a log with the occurring problem. Thanks!
Ok thanks. I logged when it was surging idle. And I logged after clearing codes, and connecting the jb4 Bluetooth. It combined it into one log I believe.
Attached Files
File Type: csv P32_M6_R2_220125_1200.csv (81.0 KB, 52 views)
Reply With Quote
(#8)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 01-25-2022, 03:45 PM

Not really sure what that issue is. Have you specifically reset throttle adaptions? That's not really something JB4 related but I'd also recommend updating your firmware and putting all the JB4 values back to the default settings.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#9)
Old
N5(4x4) N5(4x4) is offline
New Member
 
Posts: 8
Join Date: Jan 2020
Car: 2008 335xi
Default 01-26-2022, 03:32 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Not really sure what that issue is. Have you specifically reset throttle adaptions? That's not really something JB4 related but I'd also recommend updating your firmware and putting all the JB4 values back to the default settings.
Thanks for the reply! I have reset the throttle adaptions manually several times. I just updated the firmware, although it was the firmware I was running before. To be certain I shouldnít install the beta firmware? Also how do I put the jb4 values to default? Any link would be appreciated. I searched around but Iím not seeing any values other thatís the original post from 2010.
Reply With Quote
(#10)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,116
Join Date: Oct 2012
Car: 135i
Default 01-31-2022, 02:43 PM

No problem running beta software but it doesn't sound like it will resolve your issue. This sounds like it may be more hardware related.

The default values can be found here...

E Series N54 JB4 - N54Tech.com - International Turbo Racing Discussion



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2022, JB4tech.com