N54Tech.com - International Turbo Racing Discussion
(#1)
Old
turbotouring turbotouring is offline
New Member
 
Posts: 1
Join Date: Oct 2021
Car: E61 535xiT 6MT, E39 530i 5MT
Default Loud Screech at High RPM Under Load - 10-22-2021, 08:26 PM

Hi All,

Hoping I might be able to gain some insight here about a noise from my 2008 535xi wagon. When accelerating, there is a super loud screech that seems to be coming from the engine bay. Really sounds like tires breaking loose (itís that loud), but a stock xi isnít spinning the front tires (and the noise occurs in 4th gear at highway speeds as well). Starts after 5k rpm.

I installed a new belt + tensioner + pulleys earlier this year, but the noise was unchanged. I occasionally get a bit of a rattle from one of the accessories (likely the alternator) on cold-start, but it goes away within a minute. The screech doesnít sound like belt squeal though, and only happens under load.

Iím thinking it might be the PCV system, or maybe an exhaust leak. The car had new turbos 30k miles ago, but maybe something wasnít reassembled correctly? Seems too loud to be the PCV, but others may know better.

Hereís a video of the car revving in neutral, followed by the screeching noise during acceleration:
2008 535xiT6 squeal (under load) - YouTube

Thanks!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com