N54Tech.com - International Turbo Racing Discussion
(#1251)
Old
nguyenvn nguyenvn is offline
Junior Member
 
Posts: 159
Join Date: Mar 2013
Car: 2007 335i E92
Default 07-25-2014, 06:34 AM

Quote:
Originally Posted by dmacpro91



Is it every time you first try to connect or when you open the app after it was in the background?

Ok it seems to be an issue if the app has been backgrounded. I don't reboot my phone often so after using the jb4, it stays backgrounded until the next time you use it. Is there a way to address the issue or do users need to actually close the app each time?


|2007 E92 SGM 335i|
Cobbv3 BMS DCI & OCC VRSF *** & FMIC E85 Custom Backend & Alpina TCU flash ER CP RB PCV+Cap
Walbro 255 Rohana RC5 19s Nittos 555 245/275 Cyba Scoops LUX V3 M3 Cowl ST Coils LCI Tails

Reply With Quote
(#1252)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,278
Join Date: Aug 2013
Car: 2008 135i
Default 07-25-2014, 10:26 AM

Quote:
Originally Posted by _ink
Yo Dmac,

Any reason why you've only done landscape to rotate one way (left)?

Makes it a little annoying for all us RHD customers out there with the charging port.
I may add support for opposite landscape support in the next build.

Quote:
Originally Posted by nguyenvn
Ok it seems to be an issue if the app has been backgrounded. I don't reboot my phone often so after using the jb4, it stays backgrounded until the next time you use it. Is there a way to address the issue or do users need to actually close the app each time?
Thanks, I just needed to know what to look for. If I can replicate the issue on my end then I can fix the problem


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#1253)
Old
Element's Avatar
Element Element is offline
Senior Member
 
Posts: 582
Join Date: Jun 2013
Car: BMW 135i N54
Default 07-25-2014, 04:14 PM

Looks like one of the updates some time back may have broken comoatiblity with my 1st gen Nexus 7 wifi. At first I thought it was the Kit*** 4.4.4 update from a few weeks back, with the tab not requesting access to OTG when plugging the cable in. It also fails when opening the app and clicking connect (gives a serial connection error)

I factory reset the tablet to see if that would help with no result, then downloaded and flashed an older 4.2.2 Android image from Google with the same result as above. My Galaxy S5 on the other hand still works just fine.


2016 F22 M240i | 8ZF
Reply With Quote
(#1254)
Old
Dark helmet Dark helmet is offline
Junior Member
 
Posts: 47
Join Date: Jul 2014
Car: 2009 BMW 135i
Default 07-25-2014, 09:32 PM

What's the current lead time on new orders?
Will it work on my iPad mini?

Last edited by Dark helmet; 07-26-2014 at 12:04 AM..
Reply With Quote
(#1255)
Old
frankj frankj is offline
New Member
 
Posts: 2
Join Date: Jul 2014
Car: 2012 Mini Roadster S
Default 07-27-2014, 06:42 AM

Does this work for the N18 (mini Roadsters S) motor? From my understanding there is not a JB4 for the n18. I currently have the JB+. Will the app still work with my set up?
Reply With Quote
(#1256)
Old
black535xi's Avatar
black535xi black535xi is offline
Junior Member
 
Posts: 453
Join Date: Aug 2013
Car: 535xi
Default 07-27-2014, 11:15 AM

one thing ive noticed that would be really sweet, is if we could change the Y scale in the graph settings. ive almost completely replaced the laptop app for reviewing logs, but sometimes it is nice to drop that down to like 20-25

and just so you know, i am IN LOVE with this mobile app, and your customer support


2010 535xi
ALL black, murdered out FBO jb4+flash
Fuel It! stage 2 LPFP on the way

12.400@112.16/1.731 60'
4205lbs
Reply With Quote
(#1257)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,278
Join Date: Aug 2013
Car: 2008 135i
Default 07-27-2014, 03:02 PM

Quote:
Originally Posted by Element
Looks like one of the updates some time back may have broken comoatiblity with my 1st gen Nexus 7 wifi. At first I thought it was the Kit*** 4.4.4 update from a few weeks back, with the tab not requesting access to OTG when plugging the cable in. It also fails when opening the app and clicking connect (gives a serial connection error)

I factory reset the tablet to see if that would help with no result, then downloaded and flashed an older 4.2.2 Android image from Google with the same result as above. My Galaxy S5 on the other hand still works just fine.
I'm leaning towards a problem with your nexus 7 then if it still works on your Galaxy S5. Everything still working fine on my end. The only connection complaint I've had recently was a person who had an OTG cable go bad.

Also, I didn't change any of the OTG connection code.

Quote:
Originally Posted by Dark helmet
What's the current lead time on new orders?
Will it work on my iPad mini?
Wait time is still around 2 months. Yes it will work with iPad mini.

Quote:
Originally Posted by frankj
Does this work for the N18 (mini Roadsters S) motor? From my understanding there is not a JB4 for the n18. I currently have the JB+. Will the app still work with my set up?
No idea. Does the JB+ even have a computer interface?

Quote:
Originally Posted by black535xi
one thing ive noticed that would be really sweet, is if we could change the Y scale in the graph settings. ive almost completely replaced the laptop app for reviewing logs, but sometimes it is nice to drop that down to like 20-25

and just so you know, i am IN LOVE with this mobile app, and your customer support
I'll look into it eventually. It should be simple enough to add that to the settings page.

Glad you're enjoying the app!!


For everyone else asking for 60-130 timers, I simply don't have time to work on new features (and test them) until I get caught up with my Bluetooth orders. After that, I will work on new features like this. For now, I am only working on bug fixes.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#1258)
Old
musc's Avatar
musc musc is offline
 
Posts: 770
Join Date: Jan 2008
Car: 335is DCT
Default 07-27-2014, 03:06 PM

Quote:
Originally Posted by frankj
Does this work for the N18 (mini Roadsters S) motor? From my understanding there is not a JB4 for the n18. I currently have the JB+. Will the app still work with my set up?
No it wont work for this. There is no computer interface for the JB+. It just plugs into the TMAP.


335is DCT
Reply With Quote
(#1259)
Old
kampfschachtel kampfschachtel is offline
New Member
 
Posts: 3
Join Date: Apr 2013
Car: BMW 1M
Default 07-27-2014, 04:53 PM

update problem with MacAirbook and IOS app: have problems with uploading the file. I am connected, logging is possible but when I want to update firmware only folders are selectable e.g. folder JB4 firmware (where I collect all firmware files) but I cannot chose the hex file itself or any other file, all is grey and not selectable.
Anybody an idea whats wrong and how this could be fixed....

@dcmacpro91: Thank you for your efforts, IOS and Iphone/Ipad support is what was missed most on that genius JB4, IOS cable ordered.
Reply With Quote
(#1260)
Old
frankj frankj is offline
New Member
 
Posts: 2
Join Date: Jul 2014
Car: 2012 Mini Roadster S
Default 07-27-2014, 07:13 PM

Quote:
Originally Posted by dmacpro91


No idea. Does the JB+ even have a computer interface?



It does not have an interface. I only ask if it will work because I saw your youtube video http://youtu.be/ISkqVQZeu6A and the N18 motor was listed. Since the JB+ does not have an interface I didn't know if there was another way to hook it up.

-Frank
Reply With Quote
(#1261)
Old
harkes harkes is offline
Registered Users
 
Posts: 781
Join Date: May 2014
Car: M135i
Default The Great Fire-Wall - 07-28-2014, 02:06 AM

Hi

I am very keen on this Android interface but since I live in China I cannot DL/pay via Google Play. Can I do a money transfer to you and have a .apk file emailed?

- Niels
Reply With Quote
(#1262)
Old
mike082802 mike082802 is offline
Junior Member
 
Posts: 255
Join Date: Apr 2014
Car: vw passat
Default 07-28-2014, 04:26 AM

just noticed when i updated my firmware that i under settings there is no longer the option for N54 g5 iso with flash, i am on android platform. it was there 2 or 3 weeks ago, i know there were a few upgrades in the last few weeks. i only have the option to select n54 for engine type. thanks
Reply With Quote
(#1263)
Old
TDDaryl's Avatar
TDDaryl TDDaryl is offline
Junior Member
 
Posts: 81
Join Date: Jul 2014
Car: 2008 335xi
Default 07-28-2014, 06:00 PM

Galaxy S5
4.4.2(Android)
N54 E92 coupe
A027
Problem experienced: All of a sudden I get a serial port not available error. I've reinstalled 3 times and deleted all folders and it connects then quickly gets booted off then when I try and re connect, I get the serial port not available error.
Reply With Quote
(#1264)
Old
09E90utah's Avatar
09E90utah 09E90utah is offline
Junior Member
 
Posts: 42
Join Date: May 2012
Car: 2009 e90 xDrive 6MT
Default 07-28-2014, 06:22 PM

Quote:
Originally Posted by TDDaryl
Galaxy S5
4.4.2(Android)
N54 E92 coupe
A027
Problem experienced: All of a sudden I get a serial port not available error. I've reinstalled 3 times and deleted all folders and it connects then quickly gets booted off then when I try and re connect, I get the serial port not available error.
My guess is that its your cable. Mine did that once and I moved it around and it worked.
Reply With Quote
(#1265)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,278
Join Date: Aug 2013
Car: 2008 135i
Default 07-29-2014, 11:41 AM

Quote:
Originally Posted by kampfschachtel
update problem with MacAirbook and IOS app: have problems with uploading the file. I am connected, logging is possible but when I want to update firmware only folders are selectable e.g. folder JB4 firmware (where I collect all firmware files) but I cannot chose the hex file itself or any other file, all is grey and not selectable.
Anybody an idea whats wrong and how this could be fixed....

@dcmacpro91: Thank you for your efforts, IOS and Iphone/Ipad support is what was missed most on that genius JB4, IOS cable ordered.
It sounds like the .HEX file is actually a .HEX.txt file. OS X jacks up this file extension sometimes. Just right click (control click) on the file in question, select get info, and make sure the extension only says .hex.

Quote:
Originally Posted by frankj
It does not have an interface. I only ask if it will work because I saw your youtube video http://youtu.be/ISkqVQZeu6A and the N18 motor was listed. Since the JB+ does not have an interface I didn't know if there was another way to hook it up.

-Frank
That was an option under the JB4 interface for a while so I just left it. Looks like it won't work for JB+ tunes.

Quote:
Originally Posted by harkes
Hi

I am very keen on this Android interface but since I live in China I cannot DL/pay via Google Play. Can I do a money transfer to you and have a .apk file emailed?

- Niels
Sadly no, my app requires Google Play for more than just the install. It also requires it for the license validation.

Quote:
Originally Posted by mike082802
just noticed when i updated my firmware that i under settings there is no longer the option for N54 g5 iso with flash, i am on android platform. it was there 2 or 3 weeks ago, i know there were a few upgrades in the last few weeks. i only have the option to select n54 for engine type. thanks
No need for it anymore. Everything has been consolidated into just the engine type. Just select N54 E Series if that is your engine.

Quote:
Originally Posted by TDDaryl
Galaxy S5
4.4.2(Android)
N54 E92 coupe
A027
Problem experienced: All of a sudden I get a serial port not available error. I've reinstalled 3 times and deleted all folders and it connects then quickly gets booted off then when I try and re connect, I get the serial port not available error.
Virtually every time someone has this issue, it ends up being the cable. Some people have to try 2-5 different cables before they find one that works with their particular device.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#1266)
Old
montgom626 montgom626 is offline
Junior Member
 
Posts: 96
Join Date: Mar 2014
Car: 2013 BMW 335i xDrive
Default 07-29-2014, 12:53 PM

Quote:
Originally Posted by black535xi

and just so you know, i am IN LOVE with this mobile app, and your customer support
Mega Ditto!!!!
Reply With Quote
(#1267)
Old
Cloud9Blue Cloud9Blue is offline
Senior Member
 
Posts: 898
Join Date: Dec 2010
Car: 09 E92 335i
Default 07-30-2014, 12:41 PM

Any chance we can implement timing charts for all six cylinders. Maybe like this? I guess similar chart can be made for AFR or any dual/multi band data.


09 BMW E92 335i: EFR 7670 / Motiv / AP Racing / Wavetrac / TC Kline [Full Modlist]
07 BMW R1200S: Shine Yellow / Akrapovic / Ohlins
Reply With Quote
(#1268)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,278
Join Date: Aug 2013
Car: 2008 135i
Default 08-01-2014, 04:26 PM

Quote:
Originally Posted by Cloud9Blue
Any chance we can implement timing charts for all six cylinders. Maybe like this? I guess similar chart can be made for AFR or any dual/multi band data.
Perhaps in the future.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#1269)
Old
n55jitsu n55jitsu is offline
New Member
 
Posts: 9
Join Date: Jun 2014
Car: 14 M235i
Default 08-01-2014, 05:07 PM

I was originally on the waiting list for the iPhone version, but ended up getting a Note 3 and this app works flawlessly! I'm using an OTG cable I picked up from Amazon for $6 :P
Reply With Quote
(#1270)
Old
andydna15 andydna15 is offline
Junior Member
 
Posts: 139
Join Date: Mar 2012
Car: 335i
Default 08-02-2014, 03:05 PM

I'm having issues with the jb4 app on iOS. After sending an email of my logs it stays on the email page, I'm not able to get back to the jb4 gauge screen.Is there something I'm doing wrong? To get the app working I need to reset my iphone. Thnx
Reply With Quote
(#1271)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,278
Join Date: Aug 2013
Car: 2008 135i
Default 08-02-2014, 03:09 PM

Quote:
Originally Posted by n55jitsu
I was originally on the waiting list for the iPhone version, but ended up getting a Note 3 and this app works flawlessly! I'm using an OTG cable I picked up from Amazon for $6 :P


Quote:
Originally Posted by andydna15
I'm having issues with the jb4 app on iOS. After sending an email of my logs it stays on the email page, I'm not able to get back to the jb4 gauge screen.Is there something I'm doing wrong? To get the app working I need to reset my iphone. Thnx
That is a bug with emailing multiple logs. Just don't email multiple logs until I make the next iOS build. Emailing single logs works fine. You shouldn't need to restart your phone. Just double tap the home button to bring up the multitasking menu and swipe the JB4 app away, then just open it up again.

I'll make a note of this in my known bugs list on the first post.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#1272)
Old
andydna15 andydna15 is offline
Junior Member
 
Posts: 139
Join Date: Mar 2012
Car: 335i
Default 08-02-2014, 03:14 PM

Quote:
Originally Posted by dmacpro91




That is a bug with emailing multiple logs. Just don't email multiple logs until I make the next iOS build. Emailing single logs works fine. You shouldn't need to restart your phone. Just double tap the home button to bring up the multitasking menu and swipe the JB4 app away, then just open it up again.

I'll make a note of this in my known bugs list on the first post.
I just read the first page. thanx for your help. Oh and this app is the best !!!
Reply With Quote
(#1273)
Old
montgom626 montgom626 is offline
Junior Member
 
Posts: 96
Join Date: Mar 2014
Car: 2013 BMW 335i xDrive
Default how to do 0-60 mph - 08-03-2014, 03:09 PM

Can I do 0-60 mph with my mobile app?
I cannot figure it out.
Reply With Quote
(#1274)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,278
Join Date: Aug 2013
Car: 2008 135i
Default 08-03-2014, 03:31 PM

Quote:
Originally Posted by montgom626
Can I do 0-60 mph with my mobile app?
I cannot figure it out.
Calibrate your G Force meter
Come to a complete stop (GPS Speed should read 0)
Brake boost
Launch hard
Go past 70-80 to make sure the reading will go through.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#1275)
Old
GRLPWR's Avatar
GRLPWR GRLPWR is offline
New Member
 
Posts: 6
Join Date: Aug 2010
Car: '07 335i
Default 08-04-2014, 03:44 PM

I just came across this thread. This is awesome! I haven't read through all of the posts, but could you tell me what, if any, limitations this has vs the program currently used on a laptop? I have a Sprint/Samsung S4 mini, 4.4.2vs. I also still have a G4 board. Is this compatible?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com