JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
Beefy Beefy is offline
New Member
 
Posts: 3
Join Date: Nov 2021
Car: BMW 535i X-Drive
Default N54 Sudden Loss of Oil Pressure and Knocking - 11-10-2021, 08:29 AM

Hey guys,

I have been looking around quite a bit for some answers to my problem but have been getting pulled in so many directions, I figured I would join this forum and explain my issue just in case someone else has experienced the same thing.

As the title says, I have experienced a sudden drop in oil pressure according to the i-drive in my Bimmer which is a 2009 BMW 535i with X-Drive.

I am not sure if it is unbelievable bad luck, or the guy who sold it to me intentionally screwed me, but the day after I bought it from him, the car left me stuck on the side of the road with low oil pressure and a terrible knocking sound.



To bring you up to speed with my situation, I bought this car from a guy the day before this video. Test drove it, gave it a few short bursts in the city, fell in love with it as it felt great to drive. Everything seemed to be in great shape. No engine codes at the time. The guy said he had it checked over with a BMW tech and said everything was perfect. Gave him my money, drove home.

Next day, I wanted to show my parents my sick new ride. Started it up first thing in the morning and it was a little bit cold, maybe around 3 degrees celcius. As soon as it fired up, the idle was bouncey and the i-drive gave me the "reduced power" screen. I thought what the hell, and shut it off and then restarted it. That screen went away, and the car ran good again.

After about 5 minutes of driving, I thought I would see how fast I could get her up to. Got up to 200 KM/H pretty quickly, and then ran over a small but noticeable bump in the road, and then suddenly the i-drive throws the "Engine Malfunction" screen at me, and the car goes into limp mode. I slow right down, and then all of a sudden the engine starts knocking like shown in the video. I pull off to the side and let the dread sink in.

I once again shut it off and restart it thinking this might clear it up, but it didn't. I wanted to hear it again to verify if it was a consistent "knock" like I have heard before when I blew the engine in my Lumina many years ago.



As you can tell, it's not completely consistent, so I don't believe it to be a lower rod knock, but I am open to anyone's input.

I pulled over, and called a tow truck, and had it delivered to my parents' garage about 20 minutes away from my house. Now I am doing as much research as I possibly can to figure out what this could be.

Of course, the guy I bought it from denies knowing of anything wrong with the car and refuses to help me in any way, so that is a lost cause.

So, with the help of you super knowledgeable and awesome N54 owners, does anyone have any suggestions on what might be causing this?

POST EDIT: I should also share the codes I have read after parking it in my dad's garage.
1. P0015
2. P13B4
3. P1328
Reply With Quote
(#2)
Old
Beefy Beefy is offline
New Member
 
Posts: 3
Join Date: Nov 2021
Car: BMW 535i X-Drive
Default 11-15-2021, 12:11 AM

Okay, so after putting the car up on jacks in the garage, I have come to find this actually is rod knock. Pretty obvious now as it is very consistent. I dropped the oil only to find it was blacker than black, and after removing the oil filter, small copper shavings came out with it. Damn I wish this thing had a dipstick... I would have seem how bad the oil looked and never bought it. But here we are. Looks like I am in for a couple weeks of learning how to swap an engine and get this thing back on the road.
Reply With Quote
(#3)
Old
dfbpurcell dfbpurcell is offline
New Member
 
Posts: 3
Join Date: Jul 2020
Car: PRE LCI E90 335i N54 FBO JB4 MHD
Default 11-23-2021, 04:50 AM

sell it to ghassan automotive as a damaged core, and always do a thorough check as people love to neglect maintenance on these things


E90 335i N54 - FBO, JB4, MHD
Reply With Quote
(#4)
Old
maddog_n54 maddog_n54 is offline
New Member
 
Posts: 25
Join Date: Sep 2021
Car: 335i e92
Default 11-24-2021, 05:27 PM

dang, sorry to hear about this what a bummer. You can always send your oil in and get a used oil analysis just to make sure. I once had an oil change and could have sword I saw copper flakes, but oil analysis came back fine. Check out black stone labs, its fairly inexpensive and will tell you a lot.

One time I was driving and my oil coolant line busted, I too had a knock similar to yours due to low oil pressure. Had it towed home, replaced my oil coolant lines and replaced fluid. Knock went away. Not sure what was knocking exactly, but it sounded just like your video.

Good Luck!

Edit: If I am not mistaken all those codes that you got appear to be timing related, could be as a result of low oil pressure as a lot of components rely on oil pressure to function.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2022, JB4tech.com