N54Tech.com - International Turbo Racing Discussion
(#3976)
Old
katsooba's Avatar
katsooba katsooba is offline
Junior Member
 
Posts: 183
Join Date: Feb 2013
Car: 135i N55 DCT
Default 01-16-2017, 10:57 AM

hey DMAC!
that did the trick
seems to switch tabs rather nicely
just one questions, is it supposed to do it in a kind of a sweepy motion left to right?
some say even a bit laggy when switching screens but i know that is not the case, not so smooth transitions.

but good enough for me! back to the car the tablet goes!


135i N55 / KW V3 / CP-E charge pipe / CP-E 5" ** / CP-E 7" FMIC / JB4 S2 / MHD / K&N inbox / Custom made 3.25" catback / Tons of other mods
Reply With Quote
(#3977)
Old
chadillac2000's Avatar
chadillac2000 chadillac2000 is offline
Senior Member
 
Posts: 605
Join Date: Jul 2011
Car: 2008 535i
Default 01-16-2017, 10:58 AM

Quote:
Originally Posted by harkes
Repost once you know how the F-series is put together
I retract my previous statements and apologies to all! For some reason thought I was in the E-Series JB4 thread.


Visit Chadillac2000's 2008 135i Road Warrior Daily Driver Single Turbo Build Thread HERE

ACF PTE 6062 BB Top Mount ST Kit, Fuel-It! Stage 3 LPFP, Phoenix Racing Port Injection Manifold + RACE FMIC, JB4 + BMS ST E85 PI BEF
Reply With Quote
(#3978)
Old
poteroa poteroa is offline
New Member
 
Posts: 8
Join Date: Mar 2016
Car: 335i e93
Default rev1 kit - 01-18-2017, 08:53 AM

I got an old rev1 kit last week from ebay that has not been used for years, well thats what the seller told me.. He took the whole thing out when He sold the car long ago, and its been just lying around.

Been reading a lot of posts here, and seems it might have the "old firmware version" in it as I can not connect to it at all. I have the android app version, but even one guy from same BMW club could not connect to it with iPhone.

Does someone have the firmware update to that? (mini BLE I think, Have not opened it yet).

I know its a little awkward to use, like remove/install when using the app, but I really would like to get this working, as I paid for it.

I have been spending hours now to figure this out, and seems this is the only explanation why it does not connect..

Can anyone PM me the update file?
Reply With Quote
(#3979)
Old
Ridergas Ridergas is offline
New Member
 
Posts: 14
Join Date: Jul 2016
Car: BMW M135i F21
Default 01-18-2017, 09:07 AM

Android 6.0.1
Interface version A118
connection type Bluetooth rev3
Engine type N55 Fséries PWG
Phone Samsung Galaxy S6
Update 8b.hex ( version 9.hex the gear display don't work)
On the gear ratio display when I drive, it stops at 6 while I have 8 gears and in gear reverse it displays 7
Reply With Quote
(#3980)
Old
maX5 maX5 is offline
Junior Member
 
Posts: 35
Join Date: Dec 2010
Car: E90 335
Default 01-21-2017, 11:42 PM

Is there a way to control the exhaust valves to open/close via the bluetooth app ?
Reply With Quote
(#3981)
Old
poteroa poteroa is offline
New Member
 
Posts: 8
Join Date: Mar 2016
Car: 335i e93
Default Ethanol sensor support - 01-24-2017, 01:40 AM

Android 4.4.3
Interface version A122
connection type OTG
Engine type N54
Phone Samsung Galaxy S2 Plus
Update 32_5 G5 ISO

Is the app compatible showing ethanol content without bluetooth interface, with OTG?

I want to use common 13577394 Continental sensor to get ethanol content directly to Andoid app JB4 Mobile, (50-150Hz signal converted to 0-5v to pin 15 of JB4), correct?

Does the app support it directly, or is the bluetooth required add-on?
Reply With Quote
(#3982)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,285
Join Date: Aug 2013
Car: 2008 135i
Default 01-24-2017, 08:34 PM

Quote:
Originally Posted by poteroa
I got an old rev1 kit last week from ebay that has not been used for years, well thats what the seller told me.. He took the whole thing out when He sold the car long ago, and its been just lying around.

Been reading a lot of posts here, and seems it might have the "old firmware version" in it as I can not connect to it at all. I have the android app version, but even one guy from same BMW club could not connect to it with iPhone.

Does someone have the firmware update to that? (mini BLE I think, Have not opened it yet).

I know its a little awkward to use, like remove/install when using the app, but I really would like to get this working, as I paid for it.

I have been spending hours now to figure this out, and seems this is the only explanation why it does not connect..

Can anyone PM me the update file?
Rev 1 kits are no longer supported due to outdated hardware, software, and some issues we had out of them. I offered a replacement program a year or so ago for original owners. There is a link to the firmware somewhere in this thread.

Quote:
Originally Posted by Ridergas
Android 6.0.1
Interface version A118
connection type Bluetooth rev3
Engine type N55 Fséries PWG
Phone Samsung Galaxy S6
Update 8b.hex ( version 9.hex the gear display don't work)
On the gear ratio display when I drive, it stops at 6 while I have 8 gears and in gear reverse it displays 7
Not an app issue. If you have FUA set to 51, that messes with gear output to speed up the CAN bus. Tested it manually, and the app will allow gears all the way up to 10 if the JB4 outputs it.

Quote:
Originally Posted by maX5
Is there a way to control the exhaust valves to open/close via the bluetooth app ?
Not at this time as that is a JB4 firmware limitation.

Quote:
Originally Posted by poteroa
Android 4.4.3
Interface version A122
connection type OTG
Engine type N54
Phone Samsung Galaxy S2 Plus
Update 32_5 G5 ISO

Is the app compatible showing ethanol content without bluetooth interface, with OTG?

I want to use common 13577394 Continental sensor to get ethanol content directly to Andoid app JB4 Mobile, (50-150Hz signal converted to 0-5v to pin 15 of JB4), correct?

Does the app support it directly, or is the bluetooth required add-on?
Yes it will display E Content through OTG or BT in JB4 Mobile as long as you have a sensor and analyzer installed properly (including wiring it to the JB4). You will need our analyzer from here: http://www.fuel-it.biz/bluetooth-ethanol-analyzer/


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#3983)
Old
poteroa poteroa is offline
New Member
 
Posts: 8
Join Date: Mar 2016
Car: 335i e93
Default 01-24-2017, 10:09 PM

Quote:
Originally Posted by Dmac @ BMS/DMD
Rev 1 kits are no longer supported due to outdated hardware, software, and some issues we had out of them. I offered a replacement program a year or so ago for original owners. There is a link to the firmware somewhere in this thread.
So it means that rev 1 kit does not work even with updated firmware anymore?

Quote:
Originally Posted by Yes it will display E Content through OTG or BT in JB4 Mobile as long as you have a sensor and analyzer installed properly (including wiring it to the JB4). You will need our analyzer from here: [URL="http://www.fuel-it.biz/bluetooth-ethanol-analyzer/"
http://www.fuel-it.biz/bluetooth-ethanol-analyzer/[/URL]
Thank you, so all it needs is that analyzer that converts the signal to 0-5v which displays the content with 0v = 0% 5v = 100% content.
Reply With Quote
(#3984)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,285
Join Date: Aug 2013
Car: 2008 135i
Default 01-29-2017, 12:31 AM

Quote:
Originally Posted by poteroa
So it means that rev 1 kit does not work even with updated firmware anymore?



Thank you, so all it needs is that analyzer that converts the signal to 0-5v which displays the content with 0v = 0% 5v = 100% content.
It should technically work.

Quote:
Originally Posted by poteroa
So it means that rev 1 kit does not work even with updated firmware anymore?



Thank you, so all it needs is that analyzer that converts the signal to 0-5v which displays the content with 0v = 0% 5v = 100% content.
Correct.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#3985)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,285
Join Date: Aug 2013
Car: 2008 135i
Default 01-29-2017, 12:34 AM

Looks like I've finally found a fix for the Android bug where the gauges would stop working. Testing has been positive over the past few days so expect a public release in the next couple days. This bug was an absolute PAIN to track down and is related to the crappy way Android handles backgrounded applications when the activity is killed, but not the process.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#3986)
Old
Herc Herc is offline
Junior Member
 
Posts: 209
Join Date: Nov 2016
Car: F20 125i
Default 01-29-2017, 01:35 AM

Hello!
Recently I installed the beta on a Huawei 6 android

Much better BT connectivity. Before to connect, I may needed 2 or more attempts.

Gauges for temps on the N20 still not functional. Is rather strange because when first installed it i could see one of them. Got an update and they stop working. I could seen them with another famous obd program and had verified for true or false values from the so called secret menu. JB4 was bought before Christmas am guessing all are up to date.

I have not install the EWG positaps yet because i havent understand if the engine should be turn on running and proceed with the positaps update.

Great work so far!
Reply With Quote
(#3987)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,285
Join Date: Aug 2013
Car: 2008 135i
Default 01-29-2017, 01:40 AM

Quote:
Originally Posted by Herc
Hello!
Recently I installed the beta on a Huawei 6 android

Much better BT connectivity. Before to connect, I may needed 2 or more attempts.

Gauges for temps on the N20 still not functional. Is rather strange because when first installed it i could see one of them. Got an update and they stop working. I could seen them with another famous obd program and had verified for true or false values from the so called secret menu. JB4 was bought before Christmas am guessing all are up to date.

I have not install the EWG positaps yet because i havent understand if the engine should be turn on running and proceed with the positaps update.

Great work so far!
Not all engine types support all the temp outputs *through the JB4* at this time. You'll need to check if your engine type and firmware support the various temp outputs. For more help regarding that, please email Jon (jon@burgertuning.com).


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#3988)
Old
Herc Herc is offline
Junior Member
 
Posts: 209
Join Date: Nov 2016
Car: F20 125i
Default 01-29-2017, 04:28 AM

Will do in about week. Got rear ended by a cab driver and the car is going tomorrow to an authorize shop for repair and various services so had it uninstall.
Reply With Quote
(#3989)
Old
poteroa poteroa is offline
New Member
 
Posts: 8
Join Date: Mar 2016
Car: 335i e93
Default 01-30-2017, 08:25 AM

Quote:
Originally Posted by Dmac @ BMS/DMD
Rev 1 kits are no longer supported due to outdated hardware, software, and some issues we had out of them. I offered a replacement program a year or so ago for original owners. There is a link to the firmware somewhere in this thread.
Sorry to bother you with this question about the old kit, but I can not find that firmware anywhere.. I am still struggling with this old rev1 kit. Can you please help.
Reply With Quote
(#3990)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,285
Join Date: Aug 2013
Car: 2008 135i
Default 02-02-2017, 11:21 AM

Quote:
Originally Posted by poteroa
Sorry to bother you with this question about the old kit, but I can not find that firmware anywhere.. I am still struggling with this old rev1 kit. Can you please help.
You can give this a try. https://dl.dropboxusercontent.com/u/...T_20140409.bin

Not 100% sure that is the correct firmware though as I haven't seen the project for those units since they were discontinued/replaced a few years ago.

Firmware update info for that unit can be viewed here: https://github.com/RedBearLab/BLEMin...wareUpdate.pdf


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#3991)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,285
Join Date: Aug 2013
Car: 2008 135i
Default 02-02-2017, 11:30 AM

New Android beta is up with a test fix for the "stuck interface/gauges" bug.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#3992)
Old
poteroa poteroa is offline
New Member
 
Posts: 8
Join Date: Mar 2016
Car: 335i e93
Thumbs up 02-02-2017, 09:58 PM

Quote:
Originally Posted by Dmac @ BMS/DMD
You can give this a try. https://dl.dropboxusercontent.com/u/...T_20140409.bin

Not 100% sure that is the correct firmware though as I haven't seen the project for those units since they were discontinued/replaced a few years ago.

Firmware update info for that unit can be viewed here: https://github.com/RedBearLab/BLEMin...wareUpdate.pdf
Thank you!!! I give it a try.

Quote:
New Android beta is up with a test fix for the "stuck interface/gauges" bug.
Excellent, A122 Beta did not have the 0-60, so is it back in this new beta version?
Reply With Quote
(#3993)
Old
enrita's Avatar
enrita enrita is offline
Junior Member
 
Posts: 291
Join Date: Sep 2008
Car: 335i
Default 02-03-2017, 06:31 AM

How do u change com port in the jb4 android app? I have a new android and says com port not available


07 335i AT - MOTIV 750 - MHD BMS E85 Flash - BMS PI - JB4G5 - Okada Coils - NGK 5992 Plugs - Helix IC - Snow Stg. 3 - Stett CP - Custom midpipes with 100 HJS Cats - Bastuck Quad - PSS10 - QUAIFE LSD - BMS OCC - Forge DVs - AR OC - ALCON BBK - M3 Chassi - Dinan CP - Velocity M rear Toe arms - Advan RZ-DF - LUX H8 - Level 10 AT upgrade
Reply With Quote
(#3994)
Old
poteroa poteroa is offline
New Member
 
Posts: 8
Join Date: Mar 2016
Car: 335i e93
Default 02-03-2017, 10:50 AM

Quote:
Originally Posted by enrita
How do u change com port in the jb4 android app? I have a new android and says com port not available
There is no way to change it, it means that application can not see the cable you connected to with your phone.

1. Check with the OTG cable that you can see flash drive in it (recognizes it)
- If it does, OTG cable is working.
- If it doesn´t, your phone / OS does not support "USB HOST MODE" or the cable is bad.

2. If flash drive is recognized, you need a driver support for ftdi chip, you can get it from play store, its free. just search for ftdi driver.

Hope you get it working..
Reply With Quote
(#3995)
Old
Anthony235's Avatar
Anthony235 Anthony235 is offline
Junior Member
 
Posts: 278
Join Date: Mar 2016
Car: m235i
Default 02-04-2017, 07:18 AM

Is the save config and load config buttons only working in the beta version?

Cause I just loaded the app again from the App Store and the load config button is missing. iOS iPhone 6s.
Reply With Quote
(#3996)
Old
puppywhirl puppywhirl is offline
New Member
 
Posts: 7
Join Date: Feb 2017
Car: M235xi
Default 02-05-2017, 04:42 PM

Device: iPhone 6
OS: 10.1.2 iOS
Engine type: N55 F Series
App build: ios 6828
Kit Revision: REV3
JB4 Firmware Version: ewg 9
Problem experienced: JB4 will update firmware and change maps, MAP is the only thing that will display in live gages. Sometimes gear and iAT will display but its never correct.
Reply With Quote
(#3997)
Old
puppywhirl puppywhirl is offline
New Member
 
Posts: 7
Join Date: Feb 2017
Car: M235xi
Default 02-05-2017, 09:58 PM

Quote:
Originally Posted by puppywhirl
Device: iPhone 6
OS: 10.1.2 iOS
Engine type: N55 F Series
App build: ios 6828
Kit Revision: REV3
JB4 Firmware Version: ewg 9
Problem experienced: JB4 will update firmware and change maps, MAP is the only thing that will display in live gages. Sometimes gear and iAT will display but its never correct.
I FIGURED IT OUT!

It was my P3 Vent Gauge. I was using it for oil temp really...Does JB4 do oil temp? Maybe I can mount a small tablet or something.
Reply With Quote
(#3998)
Old
Anthony235's Avatar
Anthony235 Anthony235 is offline
Junior Member
 
Posts: 278
Join Date: Mar 2016
Car: m235i
Default 02-06-2017, 09:43 AM

Quote:
Originally Posted by puppywhirl
I FIGURED IT OUT!

It was my P3 Vent Gauge. I was using it for oil temp really...Does JB4 do oil temp? Maybe I can mount a small tablet or something.
Jb4 does oil temp with the BT connect.
Reply With Quote
(#3999)
Old
Anthony235's Avatar
Anthony235 Anthony235 is offline
Junior Member
 
Posts: 278
Join Date: Mar 2016
Car: m235i
Default 02-07-2017, 09:15 AM

Quote:
Originally Posted by Anthony235
Is the save config and load config buttons only working in the beta version?

Cause I just loaded the app again from the App Store and the load config button is missing. iOS iPhone 6s.
Anyone?
Reply With Quote
(#4000)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,285
Join Date: Aug 2013
Car: 2008 135i
Default 02-11-2017, 11:24 AM

Quote:
Originally Posted by poteroa
Thank you!!! I give it a try.



Excellent, A122 Beta did not have the 0-60, so is it back in this new beta version?
Not yet. My testing with it hasn't been satisfactory yet.

Quote:
Originally Posted by Anthony235
Is the save config and load config buttons only working in the beta version?

Cause I just loaded the app again from the App Store and the load config button is missing. iOS iPhone 6s.
Seems like an issue with the graphics in the release IPA. I'll get a new build uploaded tonight.

Again, for a *much* faster response email me: support@jb4connectkit.com


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 7 (0 members and 7 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com