JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
DouglasHammond DouglasHammond is offline
New Member
 
Posts: 13
Join Date: Sep 2021
Car: G70
Default Car sputtering and P0302 all of the sudden - 05-20-2022, 02:41 PM

Hey All,

All of the sudden my car started sputtering sporadically under WOT and boost. Nothing changed in 15K miles... The sputtering eventually lead to the car acting like it lost a cylinder (or more). Massive lost of power and sounded like a Subaru. Also threw a CEL (P0302).

Mods are: secondary down pipes, Mid-pipe, axle-back, BMS 450whp kit w/ EWG and Fuel connector wires. Running 93 oct.

Usually I run Map2, but I've gone back to Map1 for safety reasons and did some logging. I've attached my logs for review, but it appears maybe the car is going lean all of the sudden... no idea why.

Thank in advance for any help you can provide.
Attached Files
File Type: csv P21_M1_R4_220520_1627.csv (60.1 KB, 12 views)

Last edited by DouglasHammond; 05-20-2022 at 06:47 PM..
Reply With Quote
(#2)
Old
DouglasHammond DouglasHammond is offline
New Member
 
Posts: 13
Join Date: Sep 2021
Car: G70
Default 05-20-2022, 03:46 PM

Couple more logs. This 3rd gear pull may be a better point of reference than the initial log (though the car wasn't noticeably sputtering here).
Attached Files
File Type: csv 3rdGear_1.csv (9.5 KB, 8 views)
File Type: csv 2ndGear_1.csv (9.2 KB, 11 views)
Reply With Quote
(#3)
Old
DouglasHammond DouglasHammond is offline
New Member
 
Posts: 13
Join Date: Sep 2021
Car: G70
Default 05-20-2022, 05:42 PM

Lastly, Map0 3rd gear pull
Attached Files
File Type: csv P21_M0_R1_220520_2013.csv (9.6 KB, 9 views)
Reply With Quote
(#4)
Old
Baluchitherium4 Baluchitherium4 is offline
Junior Member
 
Posts: 36
Join Date: Jun 2021
Car: 2021 Kia Stinger GT2
Default 05-21-2022, 11:54 AM

I believe that code is for a misfire. First thing I would check would be the plugs.
Reply With Quote
(#5)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 34,246
Join Date: Jan 2008
Default 05-21-2022, 12:28 PM

P0302 is misfire cylinder 2. Plug, coil, or fuel injector. You could move plug and coil to another cylinder to see if misfire follows to troubleshoot them.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#6)
Old
DouglasHammond DouglasHammond is offline
New Member
 
Posts: 13
Join Date: Sep 2021
Car: G70
Default 05-21-2022, 03:54 PM

Thanks guys. That was going to be my next troubleshooting step, to check the plugs, particularly start with cylinder two. Figured I would check though in case there was something that looked off that I wasn’t seeing in the logs or if there was a common issue you might know about. The plugs only have about 10,000 miles on them in the car doesn’t have much more.
Reply With Quote
(#7)
Old
DouglasHammond DouglasHammond is offline
New Member
 
Posts: 13
Join Date: Sep 2021
Car: G70
Default 05-21-2022, 07:42 PM

Definitely cylinder 2 spark plug. I don't see anything concerning on the plug itself other than than the tip burnt off (broke off maybe)Ö I don't see a bunch of pitting or anything weird to indicate knock. Thoughts?
Attached Images
     
Reply With Quote
(#8)
Old
Chanluder's Avatar
Chanluder Chanluder is offline
Junior Member
 
Posts: 76
Join Date: Apr 2021
Car: Stinger
Default 05-21-2022, 08:56 PM

That gap is huge.
Reply With Quote
(#9)
Old
DouglasHammond DouglasHammond is offline
New Member
 
Posts: 13
Join Date: Sep 2021
Car: G70
Default 05-24-2022, 07:08 AM

Pulled the manifold last night and replaced all six plugs. Found another plug that had a massive gap on it. Took the car out this morning and gave it a good rip, feels so much better! The problem appears to be 100% resolved. I took a third gear pull log to share for a second set of eyes, but looks clean to me.

Two random questions, unrelated to the initial issue.
1) Are the factory valves cast and not forged? I looked through the intake manifold and they did not have a smooth surface from what I could see. Iíve attached a pic for reference.
2) Does my boost look right for map2, 17psi max, tapering to 13psi by redline.

Thanks!
Attached Images
 
Attached Files
File Type: csv P21_M2_R1_220524_0905.csv (9.4 KB, 10 views)

Last edited by DouglasHammond; 05-24-2022 at 07:13 AM..
Reply With Quote
(#10)
Old
R6tricks R6tricks is offline
New Member
 
Posts: 27
Join Date: Apr 2021
Car: 2020 Kia Stinger GT2
Default 05-24-2022, 08:11 AM

Hey there, when you were having issues was the car shaking pretty violently while you tried to go?..i feel like i have the same thing going...if i give it 50% throttle it starts sputtering. if i let off right away its fine..if i keep on it the car goes bad. i replaced all 6 plugs..one had missing electrode/huge gap. but the problem is still there for me. just trying to figure out if i still have a bad plug or a bigger problem, thanks!


2020 AWDGT2, JB4, BMS Intakes, ARK Secondary DP, MBRP Exhaust, BMS Catch Can
Reply With Quote
(#11)
Old
DouglasHammond DouglasHammond is offline
New Member
 
Posts: 13
Join Date: Sep 2021
Car: G70
Default 05-24-2022, 11:07 AM

Quote:
Originally Posted by R6tricks
Hey there, when you were having issues was the car shaking pretty violently while you tried to go?..i feel like i have the same thing going...if i give it 50% throttle it starts sputtering. if i let off right away its fine..if i keep on it the car goes bad. i replaced all 6 plugs..one had missing electrode/huge gap. but the problem is still there for me. just trying to figure out if i still have a bad plug or a bigger problem, thanks!
Hey Buddy. For me, the car ran fine 95% of the time. It was really only in high throttle/high boost situations that it was breaking up. The exhaust started sounding like it was sputtering / popping while shifting 2nd to 3rd, and then there was a lot of hesitation/mild shaking when breaking up. 2 of the 6 plugs for me ended up missing electrodes (or burnt down possibly). BIG GAPS! Both middle cylinders on driver and passenger sides.

I took the time to carefully re-gap to exactly .022 on every plug and things seem great now.

For what it's worth, you and I have very similar mods.... sucks to have to pull the intake manifold again though if you don't have to. Could be a good place to start though if you know you don't have a bad boost leak, no CELs, or something else going on though.
Reply With Quote
(#12)
Old
R6tricks R6tricks is offline
New Member
 
Posts: 27
Join Date: Apr 2021
Car: 2020 Kia Stinger GT2
Default 05-24-2022, 11:33 AM

hey thanks for the info!

seems like a might be in a little worse spot than you...i mean i can go down the highway fine..100mph is fine as long as i dont try to get there quick. when its not in drive i can rev the hell out of it without issue..problem is when about 6lbs of boost comes on it goes wonky

im going to try and change the plugs yet again just to be sure i didnt mess it up or crack a plug. the only time i get a CEL is if when it starts sputtering i keep on it.

thankfully ive become pretty good getting #3 out without taking the top off lol. the coil is the worst part of that.

probably be the last thing i do before putting it back to stock and taking it the dealer and acting dumb lol...thanks again!


2020 AWDGT2, JB4, BMS Intakes, ARK Secondary DP, MBRP Exhaust, BMS Catch Can
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2022, JB4tech.com