N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Smile Someone please help me, N54 misfire - 05-25-2020, 02:55 AM

Whatís up everyone, Iím hoping someone can help me with these logs I have attached here to figure out whatís up with my car. When I hit boost it starts to misfire... I put 2 gallons of E85 in today and also just upgraded my FMIC to a 7.5 and my car started to act weird. I tried to figure it out with a friend of mine also but we couldnít really see whatís wrong because we donít know whatís acceptable and whatís not. Thank you for the help guys really appreciate it!
Also I only misfire under high boost.
Also on JB4 itís cutting boost Bc of AFRís to lean.
Attached Files
File Type: csv 20200529_015808_runs(1).csv (34.1 KB, 57 views)

Last edited by Ifreezebmx562; 05-29-2020 at 02:40 AM..
Reply With Quote
(#2)
Old
Geo335's Avatar
Geo335 Geo335 is offline
Junior Member
 
Posts: 54
Join Date: Mar 2020
Car: 2007 335i
Default 05-26-2020, 03:13 AM

Logs should be WOT 2k rpm to redline, 3rd gear, traction completely off.


2007 e90 335 - BMS DCI - JB4 - feline less - AFE scoops -VRSF CP - HKS BOV - VTT PCV - BMS Cowl Filters - Muffler Delete - PUMP BEF - e30
Reply With Quote
(#3)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-26-2020, 03:23 AM

Quote:
Originally Posted by Geo335
Logs should be WOT 2k rpm to redline, 3rd gear, traction completely off.
This is the closest thing I got.
Reply With Quote
(#4)
Old
THE BEAST THE BEAST is offline
Legend
 
Posts: 1,455
Join Date: Apr 2016
Car: 2008 E93
Default 05-26-2020, 02:58 PM

Quote:
Originally Posted by Ifreezebmx562
This is the closest thing I got.
What cyl misfires ? Bank 1 ?
What plugs are you running ?
What coils ?
How old ?
Reply With Quote
(#5)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-26-2020, 05:44 PM

Quote:
Originally Posted by THE BEAST
What cyl misfires ? Bank 1 ?
What plugs are you running ?
What coils ?
How old ?
I currently swapped back to my Bosh plugs. From FCP Euro
The coils are Delphi
And they are both under a year old.
The coils have been used constantly but the plugs were used for about 6 months.
Iím getting a AFR drop only under boost. Itís dropping down to 10.7 on a log I saw today which is means JB4 is just cutting everything. But it doesnít make sense why it only cuts cylinder 3.
I also have brand new index 12ís that Iíve been running a week before the problem.
Reply With Quote
(#6)
Old
THE BEAST THE BEAST is offline
Legend
 
Posts: 1,455
Join Date: Apr 2016
Car: 2008 E93
Default 05-26-2020, 05:58 PM

Quote:
Originally Posted by Ifreezebmx562
I currently swapped back to my Bosh plugs. From FCP Euro
The coils are Delphi
And they are both under a year old.
The coils have been used constantly but the plugs were used for about 6 months.
Iím getting a AFR drop only under boost. Itís dropping down to 10.7 on a log I saw today which is means JB4 is just cutting everything. But it doesnít make sense why it only cuts cylinder 3.
I also have brand new index 12ís that Iíve been running a week before the problem.
Jb4 shouldnt cut anything at those AFRs.
Where did you get the index 12s from ?
Im going to guess (since no good logs), that would be your issue.
Reply With Quote
(#7)
Old
Rushan's Avatar
Rushan Rushan is offline
Legend
 
Posts: 1,238
Join Date: May 2014
Car: 335i E92 2009
Default 05-26-2020, 06:33 PM

Quote:
Originally Posted by Ifreezebmx562
I currently swapped back to my Bosh plugs. From FCP Euro
The coils are Delphi
And they are both under a year old.
The coils have been used constantly but the plugs were used for about 6 months.
Iím getting a AFR drop only under boost. Itís dropping down to 10.7 on a log I saw today which is means JB4 is just cutting everything. But it doesnít make sense why it only cuts cylinder 3.
I also have brand new index 12ís that Iíve been running a week before the problem.
Just to confirm that you coded the new injectors?


09 E92 335i - Hot-Climate Middle East package, M Sports suspension, 19" Rims, 6AT fully built internals, bushings, raybestos clutches and sonnax with xHP stage 3, Differential lockdown, New RB Turbo CHRA, JB4 - Map 3 70 adder with N20 TMAP - MHD BMS Race Flash with Tuned Duty Bais and PID - BMS Oil Cooler Valve - RB PCV - K&N DCI - AFE Air Scoops - 98 Super Fuel - WAGNER FMIC - 3" down's, RB Inlets- BMS charge pipe With Tial BOV - BMS Meth Kit with FSB, 30/70 Water/Meth on CM12 nozzle
Reply With Quote
(#8)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-26-2020, 08:09 PM

Quote:
Originally Posted by Rushan
Just to confirm that you coded the new injectors?
Yes! I coded with protool.
Reply With Quote
(#9)
Old
THE BEAST THE BEAST is offline
Legend
 
Posts: 1,455
Join Date: Apr 2016
Car: 2008 E93
Default 05-26-2020, 08:14 PM

Purchased from ?? (Injectors)
Reply With Quote
(#10)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-26-2020, 08:16 PM

Quote:
Originally Posted by THE BEAST
Purchased from ?? (Injectors)
Fcp euro
Reply With Quote
(#11)
Old
THE BEAST THE BEAST is offline
Legend
 
Posts: 1,455
Join Date: Apr 2016
Car: 2008 E93
Default 05-26-2020, 08:19 PM

Quote:
Originally Posted by Ifreezebmx562
Fcp euro
Pull the one that misfires and see if it smells of gas
Or swap it with another bank and see if it follows.

Last edited by THE BEAST; 05-26-2020 at 08:28 PM..
Reply With Quote
(#12)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-26-2020, 08:45 PM

Quote:
Originally Posted by THE BEAST
Pull the one that misfires and see if it smells of gas
Or swap it with another bank and see if it follows.
Did you have the same problem?
Reply With Quote
(#13)
Old
THE BEAST THE BEAST is offline
Legend
 
Posts: 1,455
Join Date: Apr 2016
Car: 2008 E93
Default 05-26-2020, 08:48 PM

Quote:
Originally Posted by Ifreezebmx562
Did you have the same problem?
No, but running rich and misfiring leads me to believe injector
Reply With Quote
(#14)
Old
albertc albertc is offline
Junior Member
 
Posts: 190
Join Date: Nov 2011
Car: 2007 335i
Default 05-26-2020, 11:16 PM

Cams position sensor could be bad as well


JB4 flash with JB4, 4.0 bar sensor, DocR 6870, Race InterC, FuelIT stage 3 (525), Helix OverDrv 3x, Phoenix Intake with PI (750cc) with BMS controller, PrRW coil pack kit, WaveTrc Diff. E85
Reply With Quote
(#15)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-29-2020, 02:41 AM

Quote:
Originally Posted by THE BEAST
No, but running rich and misfiring leads me to believe injector
swapped injector from cylinder 3 to 2
same problem.
Reply With Quote
(#16)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-29-2020, 02:41 AM

Quote:
Originally Posted by albertc
Cams position sensor could be bad as well
thats one thing i have not changed... but would that cause a single cylinder misfire constantly?
Reply With Quote
(#17)
Old
Ifreezebmx562 Ifreezebmx562 is offline
Junior Member
 
Posts: 57
Join Date: Jul 2019
Car: N54 335i
Default 05-29-2020, 02:43 AM

Ive attached a new log from today.
today i put a MHD BEF on my car in hopes it could be something with JB4 not having a BEF and nothing.
same thing happened with AFR Lean cuts.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com