N54Tech.com - International Turbo Racing Discussion
(#1)
Old
335ijoe 335ijoe is offline
Junior Member
 
Posts: 179
Join Date: Nov 2014
Car: 335i e92
Default Cyl3 missfire new plugs coils and injectors - 11-23-2016, 04:50 PM

Hi all

As above i seem to be chasing a missfire cylinder 3. Had it for a while and never really noticed it causing any issues and still no solid proof now.

I have changed plugs from cyl3 to cyl2 and the missfire jumped to cyl2 so i replaced all plugs.

Before plugs i swapped coils cyl3 to cyl1 no difference.

And before anything i swapped injector 3 and injector 4 and coded them again with no difference.

I keep getting a lambda post *** bank 2 code sometimes on its own and other times with cyl3 missfire and some 2step codes.

Could this lambda cause missfire on cyl3 or is the missfire triggering the lambda sensor?

Could it be a jb4 setting open fuel loop or somthing?

Hpfp was done not to long ago and its fine in the logs along with the lpfp never dropping under 50.

Im hitting a wall with this any help is appreciated,
Thanks


2007 Uk spec e92 335i Manuel, Full *****.
FBO, RB style cold side turbos with billet wheels.
60/40 water methanol, 4bar T-Map.
MHD race flash. Ran on UK 99RON
412RWHP
Reply With Quote
(#2)
Old
335ijoe 335ijoe is offline
Junior Member
 
Posts: 179
Join Date: Nov 2014
Car: 335i e92
Default 11-24-2016, 11:53 PM

Iv heard resetting the values could help. I hqve just upgraded the flash from pump to race.


2007 Uk spec e92 335i Manuel, Full *****.
FBO, RB style cold side turbos with billet wheels.
60/40 water methanol, 4bar T-Map.
MHD race flash. Ran on UK 99RON
412RWHP
Reply With Quote
(#3)
Old
Aaron Aaron is offline
Junior Member
 
Posts: 107
Join Date: Dec 2015
Car: 335is
Default 11-25-2016, 01:37 AM

When's the last time you fed your intake ports walnuts?
Reply With Quote
(#4)
Old
335ijoe 335ijoe is offline
Junior Member
 
Posts: 179
Join Date: Nov 2014
Car: 335i e92
Default 11-25-2016, 07:22 AM

Quote:
Originally Posted by Aaron
When's the last time you fed your intake ports walnuts?
Walnut blasted about 1500 miles ago along with all the oil feeds and returns chemically flushed.


2007 Uk spec e92 335i Manuel, Full *****.
FBO, RB style cold side turbos with billet wheels.
60/40 water methanol, 4bar T-Map.
MHD race flash. Ran on UK 99RON
412RWHP
Reply With Quote
(#5)
Old
Russell @ BMS's Avatar
Russell @ BMS Russell @ BMS is offline
Tuner
 
Posts: 5,673
Join Date: Nov 2008
Car: 2009 335i AT
Default 11-25-2016, 12:16 PM

What did you set the plug gap at? Should be 0.020 inch.

Misfire will drive Lamda up.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#6)
Old
335ijoe 335ijoe is offline
Junior Member
 
Posts: 179
Join Date: Nov 2014
Car: 335i e92
Default 11-25-2016, 05:37 PM

Quote:
Originally Posted by Russell @ BMS
What did you set the plug gap at? Should be 0.020 inch.

Misfire will drive Lamda up.
I bought the standard bosch replacements Russell.


2007 Uk spec e92 335i Manuel, Full *****.
FBO, RB style cold side turbos with billet wheels.
60/40 water methanol, 4bar T-Map.
MHD race flash. Ran on UK 99RON
412RWHP
Reply With Quote
(#7)
Old
Russell @ BMS's Avatar
Russell @ BMS Russell @ BMS is offline
Tuner
 
Posts: 5,673
Join Date: Nov 2008
Car: 2009 335i AT
Default 11-25-2016, 05:56 PM

Are you running 60% water/40% ethanol mix? What size nozzle?

If you can get a wire feeler gauge try and set the #3 cylinder to 0.020 of an inch.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#8)
Old
335ijoe 335ijoe is offline
Junior Member
 
Posts: 179
Join Date: Nov 2014
Car: 335i e92
Default 11-26-2016, 02:12 AM

Quote:
Originally Posted by Russell @ BMS
Are you running 60% water/40% ethanol mix? What size nozzle?

If you can get a wire feeler gauge try and set the #3 cylinder to 0.020 of an inch.
Im running water 40% methanol 60% ethanol e20 mix.
Using a cm10 nozzle all purchased from BMS as a kit. I used the car last night after doing a 1-7 in dash and had no codes or missfire at all.

It did do somthing strange though after a few pulls and some very fast road it suddenly came up dsc, abs failure start assist failure and the speedo and rev counter froze with no throttle response and it was idleing like a tuned up 4rotor rx7. Turned it off and on and was fine no codes stored. Last time this happend the throttle body sucked in part of the chargepipe O-ring.


2007 Uk spec e92 335i Manuel, Full *****.
FBO, RB style cold side turbos with billet wheels.
60/40 water methanol, 4bar T-Map.
MHD race flash. Ran on UK 99RON
412RWHP
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com