N54Tech.com - International Turbo Racing Discussion
(#1276)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-04-2014, 06:34 PM

Quote:
Originally Posted by GRLPWR
I just came across this thread. This is awesome! I haven't read through all of the posts, but could you tell me what, if any, limitations this has vs the program currently used on a laptop? I have a Sprint/Samsung S4 mini, 4.4.2vs. I also still have a G4 board. Is this compatible?
At this point, the only thing you can't really do is the simulated steering wheel controls (I just simply haven't gotten around to it). It should work with the app as long as you currently use a JB4 interface for your computer.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1277)
Old
dwells dwells is offline
Junior Member
 
Posts: 28
Join Date: Aug 2014
Car: E92 335i
Default 08-04-2014, 06:44 PM

Does the Android app look specifically for that Bluetooth adapter? Or could you build a micro USB male to USB A female adapter and plug the JB4 USB right into the phone and have the app see it?
(#1278)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-04-2014, 06:48 PM

Quote:
Originally Posted by dwells
Does the Android app look specifically for that Bluetooth adapter? Or could you build a micro USB male to USB A female adapter and plug the JB4 USB right into the phone and have the app see it?
The cable you are describing is an OTG cable which works with the android app and you can get off of Amazon for like $3.



To everyone:
The only Bluetooth adapters that will work with my apps are the bluetooth adapters that I make. At this point you can't make your own and you can't buy a generic one. It just won't work.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1279)
Old
ba114's Avatar
ba114 ba114 is offline
Junior Member
 
Posts: 232
Join Date: Jul 2014
Car: 135i 6MT
Default 08-05-2014, 12:18 AM

Installed on Nexus 7 (first gen). Was given the USB connection prompt. All good. Hit Connect in app, all good. Logging worked fine, all features seemed fine.

Next day with no changes to cables, Nexus software or anything else, no longer able to connect. No prompts on OTG connection. Serial port unavailable error within app.

Not sure what's happening here. Will confirm connection with laptop when i get home.
(#1280)
Old
Element's Avatar
Element Element is offline
Senior Member
 
Posts: 582
Join Date: Jun 2013
Car: BMW 135i N54
Default 08-05-2014, 05:28 AM

Quote:
Originally Posted by ba114
Installed on Nexus 7 (first gen). Was given the USB connection prompt. All good. Hit Connect in app, all good. Logging worked fine, all features seemed fine.

Next day with no changes to cables, Nexus software or anything else, no longer able to connect. No prompts on OTG connection. Serial port unavailable error within app.

Not sure what's happening here. Will confirm connection with laptop when i get home.
Precisely what I've experienced with my Nexus 7, except there was a long period between using the tab during which there were multiple updates to the app and to the Android OS.

I assumed it was the app to blame and then the Android updates, but dmac says he has not updated the OTG connection portion and I rolled back to an earlier version of Android. Nothing worked so I'm SOL.

My Galaxy S5 and laptop continue to work without issue.


2016 F22 M240i | 8ZF
(#1281)
Old
Bruce GT3 Bruce GT3 is offline
Junior Member
 
Posts: 35
Join Date: Mar 2013
Car: 2013 M135i
Default 08-05-2014, 07:57 AM

Quote:
Originally Posted by dmacpro91
Calibrate your G Force meter
Come to a complete stop (GPS Speed should read 0)
Brake boost
Launch hard
Go past 70-80 to make sure the reading will go through.
Hi Donnie,

For a complete idiot like me, can you walk me through calibrating the g-force meter please? Do we need to be on the 0-60 screen or the regular dial display?
(#1282)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-05-2014, 10:02 AM

Quote:
Originally Posted by Element
Precisely what I've experienced with my Nexus 7, except there was a long period between using the tab during which there were multiple updates to the app and to the Android OS.

I assumed it was the app to blame and then the Android updates, but dmac says he has not updated the OTG connection portion and I rolled back to an earlier version of Android. Nothing worked so I'm SOL.

My Galaxy S5 and laptop continue to work without issue.
Feel free to read through this topic of Nexus users having issues with OTG. It definitely seems to be an OS issue for some of you all.

https://code.google.com/p/android/is...etail?id=58277


Quote:
Originally Posted by Bruce GT3
Hi Donnie,

For a complete idiot like me, can you walk me through calibrating the g-force meter please? Do we need to be on the 0-60 screen or the regular dial display?
On iOS the instructions are in the help/troubleshooting page. On android the directions are in the app description. No you don't need to be on the 0-60 screen.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1283)
Old
Element's Avatar
Element Element is offline
Senior Member
 
Posts: 582
Join Date: Jun 2013
Car: BMW 135i N54
Default 08-06-2014, 04:55 AM

Quote:
Originally Posted by dmacpro91
Feel free to read through this topic of Nexus users having issues with OTG. It definitely seems to be an OS issue for some of you all.

https://code.google.com/p/android/is...etail?id=58277
Thanks. Had a quick read through that and went home to try a few of the solutions mentioned. I connected the tablet up and it worked first time without having to do anything

Weird sh*t indeed...


2016 F22 M240i | 8ZF
(#1284)
Old
E90Ryan E90Ryan is offline
Junior Member
 
Posts: 198
Join Date: Mar 2014
Car: E90 335i
Default 08-06-2014, 10:05 AM

I had a Galaxy S3 where this app would work properly. Recently I got a LG G2 and transferred the app. It would connect fine in the beginning, but nowadays when I connect the OTG cable up to the phone, it doesn't recognize the cable right away; it may take 20 minutes until I get the little pop-up that says it [JB4] can connect to this device. Any idea why it's acting like this?
(#1285)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-06-2014, 10:10 AM

Quote:
Originally Posted by E90Ryan
I had a Galaxy S3 where this app would work properly. Recently I got a LG G2 and transferred the app. It would connect fine in the beginning, but nowadays when I connect the OTG cable up to the phone, it doesn't recognize the cable right away; it may take 20 minutes until I get the little pop-up that says it [JB4] can connect to this device. Any idea why it's acting like this?
Not really. Is the app still running in the background? I don't even know if that would affect it. Honestly at this point it just seems that some Android devices have weird problems with OTG sometimes. I just know that I use a Galaxy S4 as my development device and have had 0 issues with connectivity. It is definitely going to up to you guys to research OTG on your specific device and determine if it has weird OTG issues. Just google: your_device_here otg issues.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1286)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-06-2014, 04:56 PM

This post only applies to Android users.

Since I keep getting emails about people asking for the Bluetooth kit for Android I have gone ahead and added that option to the order page at jb4connectkit.com. Note that I still have not set a release date for these kits so please don't ask when the Android Bluetooth kits will be ready (it could be 2-4 months for all I know). I will update this thread over time as I have more info. In order to use these kits on Android you will need to make sure your device supports Bluetooth Low Energy and you are on at least OS 4.3. It is up to you to make sure your device meets these requirements. Also, the bluetooth connection seems much more stable when you disable wifi for some reason. So if you want to go ahead and reserve your spot on the Android bluetooth list, the option is now available.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1287)
Old
alexim's Avatar
alexim alexim is offline
Junior Member
 
Posts: 113
Join Date: Feb 2012
Car: 1M
Default 08-07-2014, 07:35 AM

Donnie, I just adapted an iPad in the car, and it's a fixed position. But I opened the app and noticed that it's upside down, and won't turn.. Can you make it work both ways on the next update???

Pic attached!


(#1288)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-07-2014, 10:49 AM

Quote:
Originally Posted by alexim
Donnie, I just adapted an iPad in the car, and it's a fixed position. But I opened the app and noticed that it's upside down, and won't turn.. Can you make it work both ways on the next update???

Pic attached!
Done. That will be in my next iOS build.

Edit:
I'll also be releasing my new Android build (hopefully tonight or tomorrow) which will contain boost shadowing and graphic bug fixes for tablets.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1289)
Old
musc's Avatar
musc musc is offline
 
Posts: 770
Join Date: Jan 2008
Car: 335is DCT
Default 08-07-2014, 12:08 PM

Alexim, did you fabricate any special apparatus for the iPad mini? I have been thinking about doing something like this my car and purchasing an iPad mini just for the purpose of displaying the app. I do want to have it easily removable so I can take it inside for charging, etc.


335is DCT
(#1290)
Old
alexim's Avatar
alexim alexim is offline
Junior Member
 
Posts: 113
Join Date: Feb 2012
Car: 1M
Default 08-07-2014, 12:23 PM

Quote:
Originally Posted by musc
Alexim, did you fabricate any special apparatus for the iPad mini? I have been thinking about doing something like this my car and purchasing an iPad mini just for the purpose of displaying the app. I do want to have it easily removable so I can take it inside for charging, etc.
We did fabricate... We took out the cd changer front and fabricated a wood molding.. Here's a couple of pics on the process... The iPad is still connected to the usb port on the car for charging and music playing and it's removable. What we did was fix a very thin ipad case to the wood mold and I can remove the iPad from there....


(#1291)
Old
Bruce GT3 Bruce GT3 is offline
Junior Member
 
Posts: 35
Join Date: Mar 2013
Car: 2013 M135i
Default 08-08-2014, 02:24 AM

Donnie,

Got the attached codes thrown at me yesterday. The app also locked up during the run too. I've sent the log to Russell but he can't seem to shed any light on the subject. What's really weird is that I can't delete the codes either?

Got any ideas?
(#1292)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-08-2014, 02:34 AM

Quote:
Originally Posted by Bruce GT3
Donnie,

Got the attached codes thrown at me yesterday. The app also locked up during the run too. I've sent the log to Russell but he can't seem to shed any light on the subject. What's really weird is that I can't delete the codes either?

Got any ideas?
Those aren't actually codes. Somehow the app didn't stop the JB4 from outputting logging data when reading codes (so you're looking at raw data from the JB4). I've seen this happen randomly to a few different people, but have yet to figure out where the issue is. Are you able to replicate this or is this a one time thing? Usually simply hitting the read codes button again will show the actual codes (no need to worry as this doesn't harm anything).


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1293)
Old
Bruce GT3 Bruce GT3 is offline
Junior Member
 
Posts: 35
Join Date: Mar 2013
Car: 2013 M135i
Default 08-08-2014, 02:37 AM

Haven't replicated it as such - but hitting delete doesn't do it and neither does reading the codes again.

I'll try a couple more times this morning and see if a good nights sleep has helped!!
(#1294)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-08-2014, 02:39 AM

Quote:
Originally Posted by Bruce GT3
Haven't replicated it as such - but hitting delete doesn't do it and neither does reading the codes again.

I'll try a couple more times this morning and see if a good nights sleep has helped!!
Completely close and then restart the app. Double-tap the home button, swipe JB4 Mobile up, then reopen it.

Edit: Also make sure your app is up-to-date.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1295)
Old
Bullitt1841's Avatar
Bullitt1841 Bullitt1841 is offline
Demigod
 
Posts: 1,500
Join Date: Aug 2011
Car: '07 335i Sedan, Built & Blown '08 Mustang Bullitt
Default 08-08-2014, 09:28 AM

Quote:
Originally Posted by Bruce GT3
Hi Donnie,

For a complete idiot like me, can you walk me through calibrating the g-force meter please? Do we need to be on the 0-60 screen or the regular dial display?
FYI, you also need to have GPS location TURNED ON. This was driving me crazy, as I never have it on with my tablet, just my phone.


2018 Audi RS3 | APR Stage 1 E85 and 91 Flashes | JB4 for Logging

SOLD: 2017 F36 440i Gran Coupe | PS2 | MPPSK | Track Handling Package | JB4

SOLD: 2007 E90 335i | PS2's | JB4 | FBO | 160k+ miles on the car, 120k+ miles on the JB4

Log, log, then log some more...
(#1296)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-08-2014, 02:21 PM

Android build is published.

This is what's included:
Hopefully all graphic issues will be worked out with this update.

Boost shadowing.

Added FP_L adjustment to the settings page.

Bug fix for crashing when rotating the device while launching the app.


Android users, please give it a shot once it goes live and let me know if you run into any issues.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1297)
Old
Bullitt1841's Avatar
Bullitt1841 Bullitt1841 is offline
Demigod
 
Posts: 1,500
Join Date: Aug 2011
Car: '07 335i Sedan, Built & Blown '08 Mustang Bullitt
Default 08-08-2014, 03:06 PM

Quote:
Originally Posted by dmacpro91
Android build is published.

This is what's included:
Hopefully all graphic issues will be worked out with this update.

Boost shadowing.

Added FP_L adjustment to the settings page.

Bug fix for crashing when rotating the device while launching the app.


Android users, please give it a shot once it goes live and let me know if you run into any issues.
What do you mean by FP_L adjustment? You corrected the max display of 100 on the gauge?

Also, how long before the app is live on Google Play? It still is showing A027.


2018 Audi RS3 | APR Stage 1 E85 and 91 Flashes | JB4 for Logging

SOLD: 2017 F36 440i Gran Coupe | PS2 | MPPSK | Track Handling Package | JB4

SOLD: 2007 E90 335i | PS2's | JB4 | FBO | 160k+ miles on the car, 120k+ miles on the JB4

Log, log, then log some more...
(#1298)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-08-2014, 03:16 PM

Quote:
Originally Posted by Feshdogg
What do you mean by FP_L adjustment? You corrected the max display of 100 on the gauge?

Also, how long before the app is live on Google Play? It still is showing A027.
The gauge should show the proper value no matter what now.

You can set the range of the FP_L gauge to 100, 200, or 300 depending on what your car is outputting for that parameter.

Usually it takes a few hours after it is submitted.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
(#1299)
Old
Bullitt1841's Avatar
Bullitt1841 Bullitt1841 is offline
Demigod
 
Posts: 1,500
Join Date: Aug 2011
Car: '07 335i Sedan, Built & Blown '08 Mustang Bullitt
Default 08-08-2014, 03:20 PM

Quote:
Originally Posted by dmacpro91
The gauge should show the proper value no matter what now.

You can set the range of the FP_L gauge to 100, 200, or 300 depending on what your car is outputting for that parameter.

Usually it takes a few hours after it is submitted.
Cool! Thanks for that!

Now, how can you make the app run in the background so it can still auto-log while running other apps?


2018 Audi RS3 | APR Stage 1 E85 and 91 Flashes | JB4 for Logging

SOLD: 2017 F36 440i Gran Coupe | PS2 | MPPSK | Track Handling Package | JB4

SOLD: 2007 E90 335i | PS2's | JB4 | FBO | 160k+ miles on the car, 120k+ miles on the JB4

Log, log, then log some more...
(#1300)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,312
Join Date: Aug 2013
Car: 2008 135i
Default 08-08-2014, 03:25 PM

Quote:
Originally Posted by Feshdogg
Cool! Thanks for that!

Now, how can you make the app run in the background so it can still auto-log while running other apps?
I don't think it can work like that. From what I've seen, Android kills the usb serial connection once it goes to the background.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Closed Thread


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com