N54Tech.com - International Turbo Racing Discussion
(#1)
Old
gianlatm240 gianlatm240 is offline
New Member
 
Posts: 8
Join Date: Oct 2019
Car: 2018 BMW M240i
Default CEL and fault codes - 11-07-2019, 05:16 AM

I have had a jb4 in my m240 for over a month now and recently installed a *** less ********. The install went without any damage to both O2 sensores but for some reason got these fault codes. I decided to revert back to the Oem ******** but still fault Codes are present

12B104 O2 sensor before *** disconnected
12B304 O2 sensor after *** disconnected
12B102 Lambda probe heating before Catalyst Activation: Short Circuit to Ground
Again I removed the O2 sensors before anything and put them in a safe place. The last time i installed a ******** used the car with out anything going wrong untill 2 months later with the same situation. Had to take it to the dealer and ended up in a full DME replacement. That being said the O2 sensor may have been damage du to bumping into things.
Any help Is appreciated.
Reply With Quote
(#2)
Old
Payam @ BMS's Avatar
Payam @ BMS Payam @ BMS is offline
Super Moderator
 
Posts: 6,167
Join Date: Oct 2013
Car: e90 335i
Default 11-07-2019, 10:11 AM

They're both connected up top of the engine for sure? Those codes are very random.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
gianlatm240 gianlatm240 is offline
New Member
 
Posts: 8
Join Date: Oct 2019
Car: 2018 BMW M240i
Default 11-07-2019, 10:48 AM

Yes, have checked a few times. When the car is in ignition mode, it only shows the 12B104 code and the CEL goes away. But if toy stop and re-start the car all codes come back and CEL comes back.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com