N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default JB4 Unresponsive/Stopped Working? - 09-13-2018, 11:37 PM

Installed the JB4 port injection controller and fuel-it ethanol analyzer on my 2009 335i auto coupe car utilizing a JB4 G5.

I powered the key on, loaded up the BEF via MHD, shut the car off once instructed to do so by the MHD software stating the flash was complete, let the vehicle sit with the key out of the ignition for a few minutes, put the key in, hit the start button without attempting to start the car, used the steering wheel controls to set to Map 6 and plugged in my laptop.

Now this is where it goes south.

So when I hit “connect” on my laptop it fails to connect. Close the JB4 software and reopen it and attempt to connect again. Failed. I uninstalled the JB4 software and downloaded the newest version. Now it literally states “JB4 failed to find JB4”.

Now I notice my steering wheel controls have stopped working. Remove the key from the ignition and let the car sit. Put the key back in, hit the start button without starting the car and still no steering wheel controls for the JB4 and no laptop connection.

Unhook my laptop, remove the key, unhook the car battery. Zero change.

Start the car and it fires up and spits and sputters a little and clears right up, but no steering wheel controls accessing the JB4 and laptop isn’t connecting. Car starts to miss and sputter and dies. Start it again, runs fine for a moment, dies.

I physically remove the JB4 unit from the DME. Car comes back to life and runs great. Hook the JB4 back up, no access via laptop, no access via steering wheel controls.

I never ever had com port issues before this, went through multiple threads, tried techniques others shared such as “plug in usb before opening JB4 software” or “restart your laptop” or “reset the battery” and “uninstall JB4, confirm vehicle runs, reinstall jb4” and nothing has worked.




Ive attached a few pictures I took of what I encountered during all of this... well never mind on the pictures. I keep getting this error message when I try to upload the images

“Your submission could not be processed because a security token was missing.

If this occurred unexpectedly, please inform the administrator and describe the action you performed before you received this error.”


2009 335i Automatic Coupe.
Reply With Quote
(#2)
Old
Payam @ BMS's Avatar
Payam @ BMS Payam @ BMS is offline
Super Moderator
 
Posts: 6,167
Join Date: Oct 2013
Car: e90 335i
Default 09-14-2018, 10:08 AM

Sounds like 2580 chip on the board went bad.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 10:38 AM

Quote:
Originally Posted by Payam @ BMS
Sounds like 2580 chip on the board went bad.
Which specific chip is that on the G5 board?

I recently changed out the 23k22 chip for the 24k22 chip since it came with the BMS anti-lag kit. Never got to test it obviously.


2009 335i Automatic Coupe.
Reply With Quote
(#4)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 10:44 AM

I still have the 23k22 chip, should I switch the chips just for testing purposes and see if the car runs?

I’m just looking to not do any further damage.


2009 335i Automatic Coupe.
Reply With Quote
(#5)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,844
Join Date: Jan 2008
Default 09-14-2018, 10:47 AM

Without photos can't offer much advice.

Sounds like something is wrong with the board or the wiring. Replace the board to cover all the bases. Or try swapping the 2580 chip on the board. It's the other one that is removable there that stores the firmware and communications.

Unless the new PI chip was plugged in backwards won't be related to that.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#6)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 10:50 AM

Quote:
Originally Posted by Terry @ BMS
Without photos can't offer much advice.

Sounds like something is wrong with the board or the wiring. Replace the board to cover all the bases. Or try swapping the 2580 chip on the board. It's the other one that is removable there that stores the firmware and communications.

Unless the new PI chip was plugged in backwards won't be related to that.
Trying to get into my old photobucket account and see if I can host photos from there. Stand by.

And I won’t dismiss that I could possibly have put the chip in backwards. At work right now, but I will get pics of the board as is.


2009 335i Automatic Coupe.
Reply With Quote
(#7)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 11:04 AM

Keep getting an error message when I try to upload pics one at a time directly to the forum, saying the files are too large.

I sent the pics in an email to the BMS support address.


2009 335i Automatic Coupe.
Reply With Quote
(#8)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,844
Join Date: Jan 2008
Default 09-14-2018, 11:14 AM

That works, or email to Payam@burgertuning.com

Forum only accepts smaller files 200k or below so you'd have to resize them for example.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#9)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 11:25 AM

Quote:
Originally Posted by Terry @ BMS
That works, or email to Payam@burgertuning.com

Forum only accepts smaller files 200k or below so you'd have to resize them for example.
Thank you. I will forward more pictures of the board as is when I get off work.


2009 335i Automatic Coupe.
Reply With Quote
(#10)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 12:28 PM

Here’s the JB4 as is.
Attached Images
 


2009 335i Automatic Coupe.
Reply With Quote
(#11)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 12:33 PM

Now that I’ve figured out how to resize my photos, here’s the photos from during me trying to troubleshoot the JB4 and any possible problems on my end with the laptop and so on.
Attached Images
     


2009 335i Automatic Coupe.
Reply With Quote
(#12)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,844
Join Date: Jan 2008
Default 09-14-2018, 12:57 PM

That just tells me you have a laptop issue with the data cable. Doesn't help with JB4 not booting up. Photo of JB4 board?


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#13)
Old
Prototype007 Prototype007 is offline
Junior Member
 
Posts: 63
Join Date: Mar 2016
Car: 2009 335i
Default 09-14-2018, 01:33 PM

Quote:
Originally Posted by Terry @ BMS
That just tells me you have a laptop issue with the data cable. Doesn't help with JB4 not booting up. Photo of JB4 board?
Post #10


2009 335i Automatic Coupe.
Reply With Quote
(#14)
Old
rleroy4298 rleroy4298 is offline
Junior Member
 
Posts: 104
Join Date: Feb 2013
Car: 335i
Default 09-29-2018, 01:47 PM

Any resolution to this? I am encountering the exact same issue...

https://www.n54tech.com/forums/showt...328#post610328

Last edited by rleroy4298; 10-07-2018 at 03:14 PM.. Reason: correct link
Reply With Quote
(#15)
Old
rleroy4298 rleroy4298 is offline
Junior Member
 
Posts: 104
Join Date: Feb 2013
Car: 335i
Default 10-07-2018, 03:14 PM

Quote:
Originally Posted by rleroy4298
Any resolution to this? I am encountering the exact same issue...

https://www.n54tech.com/forums/showt...328#post610328
For reference in case you or anyone else is still having this problem, the solution for me is in the thread above.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com