N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Nikica Nikica is offline
Junior Member
 
Posts: 33
Join Date: Apr 2016
Car: 135i
Default JB4 Help Please - 11-06-2017, 07:06 PM

Hey guys I need help with the JB4 install... I installed it today (everything is straight forward and seems to be common sense). But once I finished I received the yellow engine light on the dash. I have an 08 135i with the JB4 G5. I even unplugged everything again and plugged it back in thinking maybe one of the plugs didn't seat properly.

As soon as I give more than 35% gas it starts to bog out. I plugged my computer in also but every time I tried running the computer nothing would come up. Gives me a green light with 0 codes. Car runes and drives fine until I step on the gas.

Not sure what to do? Any help?

Niko
818.645.2400
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,477
Join Date: Oct 2012
Car: 135i
Default 11-06-2017, 11:07 PM

You'll need to get a log or at least a screenshot of your user adjustment screen.

Where'd you get the JB4? Used?



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
Nikica Nikica is offline
Junior Member
 
Posts: 33
Join Date: Apr 2016
Car: 135i
Default 11-06-2017, 11:25 PM

I either bought it used off of someone from here or 1addicts. I can do a log tomorrow (I have the USB plug in for either phone or computer just need to read up on how to use it).

I watched a few videos and set the JB4 to the default settings.
Reply With Quote
(#4)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 8,484
Join Date: Apr 2014
Car: E92 335XI
Default 11-06-2017, 11:30 PM

Quote:
Originally Posted by Nikica
I either bought it used off of someone from here or 1addicts. I can do a log tomorrow (I have the USB plug in for either phone or computer just need to read up on how to use it).

I watched a few videos and set the JB4 to the default settings.
As Steve stated, sceeen shot of user settings & a log will be helpful. Itíd be nice to see what firmware you are running too.

Remember a tune can expose weak components of the car, it isnít uncommon for a car to run perfect stock, but once exposed to a tune, things like misfires arenít uncommon.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#5)
Old
Nikica Nikica is offline
Junior Member
 
Posts: 33
Join Date: Apr 2016
Car: 135i
Default 11-07-2017, 02:06 PM

Ok! Just found out I need to buy the bluetooth rev 3 to connect to my iphone... Originally purchased the usb cable and an adapter from usb to iphone plugin. I also only have mac laptops so I have no way to install the program to do logs... lol

My computer gave me 0 codes though.. I also checked for codes just now using the jb4 & it also showed no codes.
Reply With Quote
(#6)
Old
Nikica Nikica is offline
Junior Member
 
Posts: 33
Join Date: Apr 2016
Car: 135i
Default 11-08-2017, 02:36 PM

Got it figured out! Settings were all out of whack! Previous owner had crazy boost & meth settings probably running a single turbo.

Cant believe how hard it is to find someone with a Microsoft computer or Android phone. lol!
Not a single friend or family member with one....
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com