N54Tech.com - International Turbo Racing Discussion
(#1)
Old
jcy335xi's Avatar
jcy335xi jcy335xi is offline
Junior Member
 
Posts: 60
Join Date: Aug 2014
Car: 335xi
Default Rough idle on cold start and trips SES light - 12-30-2016, 10:15 AM

For the past several mornings, my car has idling very rough at cold start up. If I blimp the throttle or hold the throttle at a higher rpm (above 1500), the slight shuddering goes away.

If I let it idle, it would ultimately trip a SES. Of all the times this occurs, I primarily at a 2A2B and 29E0, fuel mixture control faults. Occasionally, I get a 29CF Cylinder 3 misfire. Once the codes are cleared and the engine is warm, the SES/rough idle won't come back until the next cold start.

I've replaced the ignition coil within the last 9 months, plugs within the last year. Could this be a leaky injector?
Reply With Quote
(#2)
Old
Milan's Avatar
Milan Milan is offline
Senior Member
 
Posts: 824
Join Date: Sep 2014
Car: 08 335xi
Default 12-30-2016, 10:27 AM

Injectors.


09 335 - 6266
07 335i - 6870, E85 - SOLD
08 335xi - 6466, custom direct port meth - SOLD
Reply With Quote
(#3)
Old
Russell @ BMS's Avatar
Russell @ BMS Russell @ BMS is offline
Tuner
 
Posts: 5,673
Join Date: Nov 2008
Car: 2009 335i AT
Default 12-30-2016, 06:34 PM

Are you running any E85?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#4)
Old
jcy335xi's Avatar
jcy335xi jcy335xi is offline
Junior Member
 
Posts: 60
Join Date: Aug 2014
Car: 335xi
Default 01-01-2017, 06:22 PM

Quote:
Originally Posted by Russell @ BMS
Are you running any E85?
No, just pump. I got a 2C27 Lambda probe in front catalytic converter today as well. Maybe a bad O2?
Reply With Quote
(#5)
Old
08 335Ci's Avatar
08 335Ci 08 335Ci is offline
Junior Member
 
Posts: 179
Join Date: Dec 2012
Car: 08 335Ci
Default 01-02-2017, 09:34 AM

It would be nice if people with 'cold start' problems would tell us what temperature this is happening at. Engine requirements are very different from +70 degrees to -20 degrees.

Have you tried starting the car with the JB4 in bypass?


No matter how fast I go there's always someone slower in front of me.

You can lead a horse to water but you can't make him Jet Ski.

'10 E92 335 M Sport, JB-4 G5 ISO, 3" CPE Charge pipe, WMI w/dual CM 5 nozzles, 3.5 Tmap, ARM Relocated Inlets (don't do it), VSRF Outlet, BEF, Front Strut Brace, SS brake lines, Drilled and Slotted Rotors, Anti-lag, OCC. Escort Max 360

Totaled by a careless driver:
'08 E92 335, M sport option
Reply With Quote
(#6)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,487
Join Date: Oct 2012
Car: 135i
Default 01-02-2017, 06:51 PM

N54? N55?

Got a log?

A bad O2 sensor would certainly contribute to that.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#7)
Old
jcy335xi's Avatar
jcy335xi jcy335xi is offline
Junior Member
 
Posts: 60
Join Date: Aug 2014
Car: 335xi
Default 01-04-2017, 08:39 PM

Quote:
Originally Posted by 08 335Ci
It would be nice if people with 'cold start' problems would tell us what temperature this is happening at. Engine requirements are very different from +70 degrees to -20 degrees.

Have you tried starting the car with the JB4 in bypass?
Currently, it's happens in both mid 40 and mid 20 degree temps. JB4 toggled to Map 0 has no impact.
Reply With Quote
(#8)
Old
jcy335xi's Avatar
jcy335xi jcy335xi is offline
Junior Member
 
Posts: 60
Join Date: Aug 2014
Car: 335xi
Default 01-04-2017, 08:40 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
N54? N55?

Got a log?

A bad O2 sensor would certainly contribute to that.
It's a N54. I read my codes again and the following came up:
2A2B Fuel Mixture Control
29E0 Fuel Mixture Control
2C27 Lambda probe in front of ***

Reset the code and connected the laptop to JB4. It took a couple tries to figure out how to log idle, I was able to log an occurrence where the rough idle was very pronounced. In the log, the RPMs dropped below 600 (time stamp 103 - 105). It didn't trip a SES but the idle was definitely rough. If needed, I can log tomorrow morning again before I go to work but this is pretty much what I experienced consistently the past couple of weeks.
Attached Files
File Type: csv 170104_2008.csv (44.9 KB, 104 views)

Last edited by jcy335xi; 01-04-2017 at 09:28 PM..
Reply With Quote
(#9)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,487
Join Date: Oct 2012
Car: 135i
Default 01-05-2017, 08:52 AM

That was an issue with bank 1. Once trims go to closed loop they bottom out and you run very rich.

You'll have to get to the bottom of that to resolve your issue. Maybe a bad injector, O2 sensor, exhaust leak, or ???



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#10)
Old
jcy335xi's Avatar
jcy335xi jcy335xi is offline
Junior Member
 
Posts: 60
Join Date: Aug 2014
Car: 335xi
Default 01-05-2017, 09:38 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
That was an issue with bank 1. Once trims go to closed loop they bottom out and you run very rich.

You'll have to get to the bottom of that to resolve your issue. Maybe a bad injector, O2 sensor, exhaust leak, or ???
Thanks Steve. I'll have my indy shop replace my O2s while they are replacing my oil pan gasket since they are dropping the subframe already.
Reply With Quote
(#11)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,487
Join Date: Oct 2012
Car: 135i
Default 01-05-2017, 09:59 AM




Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#12)
Old
jcy335xi's Avatar
jcy335xi jcy335xi is offline
Junior Member
 
Posts: 60
Join Date: Aug 2014
Car: 335xi
Default 02-07-2017, 06:15 PM

Attachment 59384
Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Replaced the Bank 1 o2 sensor and it seems to have fixed the issue. I'm no longer seeing the trims bottom out. Here is the latest idle log and settings via JB4 Interface. Are my settings acceptable?
Attached Images
 
Attached Files
File Type: csv 170207_1651.csv (90.3 KB, 97 views)
Reply With Quote
(#13)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,487
Join Date: Oct 2012
Car: 135i
Default 02-07-2017, 10:55 PM

Looks good and settings are correct.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#14)
Old
jcy335xi's Avatar
jcy335xi jcy335xi is offline
Junior Member
 
Posts: 60
Join Date: Aug 2014
Car: 335xi
Default 02-08-2017, 10:02 AM

Thanks again!
Reply With Quote
(#15)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,487
Join Date: Oct 2012
Car: 135i
Default 02-08-2017, 06:21 PM




Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com