N54Tech.com - International Turbo Racing Discussion
(#4351)
Old
Genesysguy Genesysguy is offline
Junior Member
 
Posts: 52
Join Date: Nov 2016
Car: 2014 335i
Default 10-16-2017, 11:59 AM

Quote:
Originally Posted by Genesysguy
Latest beta crashes on Android when trying to export logs via email or preview. Using a Pixel XL / Android 8.
Got an update today to A170 and it still crashes.


------------------------------------------
2014 - F30 N55 335i (JB4 / ER Chargepipe)
Reply With Quote
(#4352)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 10-16-2017, 08:11 PM

Quote:
Originally Posted by drj41
Question. Will the app update automatically or do we need to download updates? Noticed Terry's app in his video allows one to change maps by double tapping the gauge. Doesn't work for me.
Depends on if you have auto-update enabled or not in the settings app.

Quote:
Originally Posted by neejay
I updated to the latest version today (beta) and now it won't find my device anymore. Is there a known issue or anything?
I'm toying with some changes on the Android beta related to BTLE. A170 should allow you to connect now. In the process of some larger behind the scenes updates for Android so please post here or email me with any issues. This applies to all of my beta testers. support@jb4connectkit.com

Quote:
Originally Posted by Traf
Hi,
One year has past since i last asked, still limited to 6 gauges ?
Still not bubbled to the top of my priority list.

Quote:
Originally Posted by Genesysguy
Latest beta crashes on Android when trying to export logs via email or preview. Using a Pixel XL / Android 8.
Quote:
Originally Posted by Tmos
Having the same issue since the update.
Any ideas Donnie?

SAMSUNG Galaxy S7
Android 7.0
Quote:
Originally Posted by Genesysguy
Got an update today to A170 and it still crashes.
Looking into it right now. Hopefully I can get a new beta up in a few minutes.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4353)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 10-16-2017, 08:48 PM

Don't have access to my Android device at the moment so if someone wants to test this Android fix right now (crash when emailing logs), shoot me an email (support@jb4connectkit.com).


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4354)
Old
Genesysguy Genesysguy is offline
Junior Member
 
Posts: 52
Join Date: Nov 2016
Car: 2014 335i
Default 10-17-2017, 04:11 AM

Quote:
Originally Posted by Dmac @ BMS/DMD
Don't have access to my Android device at the moment so if someone wants to test this Android fix right now (crash when emailing logs), shoot me an email (support@jb4connectkit.com).
The test APK you sent me fixes the export issue. Thanks Donnie!


------------------------------------------
2014 - F30 N55 335i (JB4 / ER Chargepipe)
Reply With Quote
(#4355)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 10-17-2017, 09:04 AM

Android beta is now live and should have the issues reported fixed. iOS beta is also live. If everything is mostly acceptable for my testers I can go ahead and publicly release. Let me know on here if you're good with the current betas.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4356)
Old
Bullitt1841's Avatar
Bullitt1841 Bullitt1841 is offline
Demigod
 
Posts: 1,509
Join Date: Aug 2011
Car: '07 335i Sedan, Built & Blown '08 Mustang Bullitt
Default 10-17-2017, 10:51 AM

Quote:
Originally Posted by Dmac @ BMS/DMD
Android beta is now live and should have the issues reported fixed. iOS beta is also live. If everything is mostly acceptable for my testers I can go ahead and publicly release. Let me know on here if you're good with the current betas.
Any tangible benefit for a user going from A166 to A171? Looks like stuff behind the scene on your end.


2017 F36 440i Gran Coupe | PS2 | MPPSK | Track Handling Package | JB4 | BMS Meth Kit (Dual CM5) | BMS Intake | BMW 513M Wheels | Dinan Shockware

SOLD: 2007 E90 335i | PS2's | JB4 | FBO | 160k+ miles on the car, 120k+ miles on the JB4

Log, log, then log some more...
Reply With Quote
(#4357)
Old
Blackarrow335i's Avatar
Blackarrow335i Blackarrow335i is offline
Junior Member
 
Posts: 122
Join Date: Jun 2015
Car: 335i
Default 10-19-2017, 07:48 AM

Hello,

I updated my JB4 firmware to 32.9 but how can I read the fuel trims bank 2 now


E92 09' 335i MHD BY V8BAIT
MMP STAGE 3 / MMP PI
XHP s3 / MR.5 AIRINTAKE
VRSF **'s VRSF 7" IC / RB PCV VALVE
VTT 2" INLETS / STETT CP TIAL BOV
M3 F/R CONTROL ARMS / M3 STEERING RACK
MEGAN TOE ARMS / KW V2 SUSPENSION
ST DRILLED/SLOTTED ROTORS
BODY/INTERIOR MODS
N20TMAP NGK 5992s Gapped To 0.018"
PR IGINITION UPGRADE
FUEL-IT STAGE 3 LPFP / MISHMOTO + BMS OCC
SETRAB AT COOLER / PERFORMANCE EXHAUST MOD
Reply With Quote
(#4358)
Old
v8bait's Avatar
v8bait v8bait is offline
Junior Member
 
Posts: 406
Join Date: Oct 2011
Car: E92 335i 6MT
Default 10-19-2017, 08:31 AM

Quote:
Originally Posted by Blackarrow335i
Hello,

I updated my JB4 firmware to 32.9 but how can I read the fuel trims bank 2 now
Same question, can you monitor bank 1 and 2 trims with the app yet?
Reply With Quote
(#4359)
Old
MK717 MK717 is offline
New Member
 
Posts: 1
Join Date: Oct 2017
Car: '17 MK7 GTI
Default 10-19-2017, 02:22 PM

Just received my JB4 Bluetooth kit today. Hooked it up as per the directions. I can see the JB4 in the Bluetooth devices list on all of the devices I've tried but none will connect.

Device List:
LG G6 - Android 7
Nexus 7 - Android 6
Ipad - IOS 10

All get to awaiting handshake and then fail to connect.

I disconnected and reconnected the kit just to make sure all wires were connected properly, I moved the kit around, and tried the devices right next to it.

Any help is greatly appreciated.

Mike
Reply With Quote
(#4360)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 10-19-2017, 03:51 PM

Quote:
Originally Posted by Bullitt1841
Any tangible benefit for a user going from A166 to A171? Looks like stuff behind the scene on your end.
Just some bug fixes and updates to the targeted SDK.

Quote:
Originally Posted by Blackarrow335i
Hello,

I updated my JB4 firmware to 32.9 but how can I read the fuel trims bank 2 now
Quote:
Originally Posted by v8bait
Same question, can you monitor bank 1 and 2 trims with the app yet?
Are you in the beta?

Quote:
Originally Posted by MK717
Just received my JB4 Bluetooth kit today. Hooked it up as per the directions. I can see the JB4 in the Bluetooth devices list on all of the devices I've tried but none will connect.

Device List:
LG G6 - Android 7
Nexus 7 - Android 6
Ipad - IOS 10

All get to awaiting handshake and then fail to connect.

I disconnected and reconnected the kit just to make sure all wires were connected properly, I moved the kit around, and tried the devices right next to it.

Any help is greatly appreciated.

Mike
Ensure you have the proper kit revision selected for the kit you own.

Screenshot the actual error message and email me: support@jb4connectkit.com


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4361)
Old
Blackarrow335i's Avatar
Blackarrow335i Blackarrow335i is offline
Junior Member
 
Posts: 122
Join Date: Jun 2015
Car: 335i
Default 10-19-2017, 07:16 PM

How can we get the beta version?


E92 09' 335i MHD BY V8BAIT
MMP STAGE 3 / MMP PI
XHP s3 / MR.5 AIRINTAKE
VRSF **'s VRSF 7" IC / RB PCV VALVE
VTT 2" INLETS / STETT CP TIAL BOV
M3 F/R CONTROL ARMS / M3 STEERING RACK
MEGAN TOE ARMS / KW V2 SUSPENSION
ST DRILLED/SLOTTED ROTORS
BODY/INTERIOR MODS
N20TMAP NGK 5992s Gapped To 0.018"
PR IGINITION UPGRADE
FUEL-IT STAGE 3 LPFP / MISHMOTO + BMS OCC
SETRAB AT COOLER / PERFORMANCE EXHAUST MOD
Reply With Quote
(#4362)
Old
joeinsd joeinsd is offline
Junior Member
 
Posts: 111
Join Date: Nov 2015
Car: 2010 e92 335i msport
Default 10-19-2017, 09:32 PM

Quote:
Originally Posted by Blackarrow335i
How can we get the beta version?
Donnie has to email you the invite. Not sure if he's allowing more people though. Wouldn't hurt to ask him I guess; Email him.
Reply With Quote
(#4363)
Old
pepper135i pepper135i is offline
Junior Member
 
Posts: 88
Join Date: Mar 2014
Car: 135
Default 10-20-2017, 12:17 AM

Quote:
Originally Posted by Dmac @ BMS/DMD
Just some bug fixes and updates to the targeted SDK.





Are you in the beta?



Ensure you have the proper kit revision selected for the kit you own.

Screenshot the actual error message and email me: support@jb4connectkit.com
Hey dmac I sent you a pm but just figured I’d touch base . Ever since updating my “trims” hasn’t disappeared and only have the option for “trims 2” which constantly shows 0. I also have 2 tabs just labeled meth . Trying to figure out what happened to the regular “ trims “ options... currently using FUD set at 32 which is showing trims under avg ign. Thank again !
Reply With Quote
(#4364)
Old
Blackarrow335i's Avatar
Blackarrow335i Blackarrow335i is offline
Junior Member
 
Posts: 122
Join Date: Jun 2015
Car: 335i
Default 10-20-2017, 11:13 AM

Quote:
Originally Posted by joeinsd
Donnie has to email you the invite. Not sure if he's allowing more people though. Wouldn't hurt to ask him I guess; Email him.
Thank you sir!


E92 09' 335i MHD BY V8BAIT
MMP STAGE 3 / MMP PI
XHP s3 / MR.5 AIRINTAKE
VRSF **'s VRSF 7" IC / RB PCV VALVE
VTT 2" INLETS / STETT CP TIAL BOV
M3 F/R CONTROL ARMS / M3 STEERING RACK
MEGAN TOE ARMS / KW V2 SUSPENSION
ST DRILLED/SLOTTED ROTORS
BODY/INTERIOR MODS
N20TMAP NGK 5992s Gapped To 0.018"
PR IGINITION UPGRADE
FUEL-IT STAGE 3 LPFP / MISHMOTO + BMS OCC
SETRAB AT COOLER / PERFORMANCE EXHAUST MOD
Reply With Quote
(#4365)
Old
MasB00st MasB00st is offline
New Member
 
Posts: 26
Join Date: Oct 2017
Car: 335is
Default Bluetooth - 10-22-2017, 10:15 AM

After connecting my android device to the OBDII and checking out MHD's gauges I attempted to do some logs with my iPad.ive never had connection issues in the past but now it says server error? I have checked the wiring and also tried disconnecting the battery and it has not worked. Any suggestions?
Reply With Quote
(#4366)
Old
VirusbetaX VirusbetaX is offline
Junior Member
 
Posts: 75
Join Date: Jul 2017
Car: Infiniti Q50 SilverSport 3.0T
Default 10-24-2017, 06:48 AM

Could I have access to the beta too? Some new updates for Q50 owners like speedometer based on GPS that I cant access without the beta. I am interested in joining if the beta is still open for testers.
Reply With Quote
(#4367)
Old
JaguarXJ6 JaguarXJ6 is offline
New Member
 
Posts: 1
Join Date: Oct 2017
Car: 2008 535xi
Default 10-24-2017, 08:41 AM

Device: iPad Air 2
OS: 10.3.1 (14E394) (iOS)
Engine type: 2008 N54 E60 Series
App build: 2.3 via App Store
Kit Revision: Rev 3
JB4 Firmware Version: N54 G5 ISO Burger order number BMS57657
Problem experienced: Unable to see Bluetooth connect kit. Will not connect via app launch, cold restarted iPad, still not visible to app. Android tablet works immediately and flawlessly verifying connect kit and JB4 function.

I would like to return the iPad app for refund but directed to post here to record my troubles.
Reply With Quote
(#4368)
Old
Blackarrow335i's Avatar
Blackarrow335i Blackarrow335i is offline
Junior Member
 
Posts: 122
Join Date: Jun 2015
Car: 335i
Default 10-24-2017, 08:34 PM

Quote:
Originally Posted by JaguarXJ6
Device: iPad Air 2
OS: 10.3.1 (14E394) (iOS)
Engine type: 2008 N54 E60 Series
App build: 2.3 via App Store
Kit Revision: Rev 3
JB4 Firmware Version: N54 G5 ISO Burger order number BMS57657
Problem experienced: Unable to see Bluetooth connect kit. Will not connect via app launch, cold restarted iPad, still not visible to app. Android tablet works immediately and flawlessly verifying connect kit and JB4 function.

I would like to return the iPad app for refund but directed to post here to record my troubles.
Pretty much same problem iPhone with old version connects flawlessly android tablet with the beta version won’t connect at all “ no device found “


E92 09' 335i MHD BY V8BAIT
MMP STAGE 3 / MMP PI
XHP s3 / MR.5 AIRINTAKE
VRSF **'s VRSF 7" IC / RB PCV VALVE
VTT 2" INLETS / STETT CP TIAL BOV
M3 F/R CONTROL ARMS / M3 STEERING RACK
MEGAN TOE ARMS / KW V2 SUSPENSION
ST DRILLED/SLOTTED ROTORS
BODY/INTERIOR MODS
N20TMAP NGK 5992s Gapped To 0.018"
PR IGINITION UPGRADE
FUEL-IT STAGE 3 LPFP / MISHMOTO + BMS OCC
SETRAB AT COOLER / PERFORMANCE EXHAUST MOD
Reply With Quote
(#4369)
Old
TTbavarian TTbavarian is offline
New Member
 
Posts: 18
Join Date: Dec 2014
Car: E90 N54 6MT
Default 10-24-2017, 11:38 PM

Trying to connect new rev 3 bt, getting error message "no bt devices for kit revision found". Have engine settings set to E series, rev 3. Using new galaxy S8. Any suggestions?

Also, my bt connector says "rev 4". Is that normal?

Ty!
Reply With Quote
(#4370)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 10-25-2017, 10:59 PM

Quote:
Originally Posted by Blackarrow335i
How can we get the beta version?
iOS: Email me. support@jb4connectkit.com
Android: https://play.google.com/apps/testing...o91.jb4_mobile

Quote:
Originally Posted by pepper135i
Hey dmac I sent you a pm but just figured I’d touch base . Ever since updating my “trims” hasn’t disappeared and only have the option for “trims 2” which constantly shows 0. I also have 2 tabs just labeled meth . Trying to figure out what happened to the regular “ trims “ options... currently using FUD set at 32 which is showing trims under avg ign. Thank again !
Get me the info mentioned in the first post and I'll check it out.

Quote:
Originally Posted by MasB00st
After connecting my android device to the OBDII and checking out MHD's gauges I attempted to do some logs with my iPad.ive never had connection issues in the past but now it says server error? I have checked the wiring and also tried disconnecting the battery and it has not worked. Any suggestions?
Just means you have a faulty internet connection. Double check your signal and try again.

Quote:
Originally Posted by cnm135i
@Donnie

Hi

After the latest update I dont have Trims anymore, but have Trims2 which does not show anything... Colors on the drop down list also changed making them very hard to read.
Possible to roll back an update or can you fix this?
Must be the same issue mentioned above. What build number?

Quote:
Originally Posted by JaguarXJ6
Device: iPad Air 2
OS: 10.3.1 (14E394) (iOS)
Engine type: 2008 N54 E60 Series
App build: 2.3 via App Store
Kit Revision: Rev 3
JB4 Firmware Version: N54 G5 ISO Burger order number BMS57657
Problem experienced: Unable to see Bluetooth connect kit. Will not connect via app launch, cold restarted iPad, still not visible to app. Android tablet works immediately and flawlessly verifying connect kit and JB4 function.

I would like to return the iPad app for refund but directed to post here to record my troubles.
For iOS refunds you need to talk to iTunes Support. Something to try:
Disable BT, disable wifi, restart device, enable BT, try again. If that doesn't work i can help you troubleshoot further, just email me. support@jb4connectkit.com

Quote:
Originally Posted by Blackarrow335i
Pretty much same problem iPhone with old version connects flawlessly android tablet with the beta version won’t connect at all “ no device found “
Yea it seems that Apple introduced some BT bugs in iOS 11 and android introduced some smaller bugs in 8.0. I have iPhones on iOS 11 working fine on my end, but they do sometimes require the reset method mentioned above. Similar situation with 8.0.

Quote:
Originally Posted by TTbavarian
Trying to connect new rev 3 bt, getting error message "no bt devices for kit revision found". Have engine settings set to E series, rev 3. Using new galaxy S8. Any suggestions?

Also, my bt connector says "rev 4". Is that normal?

Ty!
Email me: support@jb4connectkit.com


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4371)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 10-25-2017, 11:03 PM

Regarding my betas:

I really need feedback more regularly on what is working and what isn't working in the betas. The iOS release for example is through approval and ready for release, but I want to ensure there are no app-breaking bugs hidden in the new changes. If you are in the beta channel and things are mostly working, let me know that as well.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4372)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 10-27-2017, 01:08 PM

Made a few new changes to the iOS beta which should improve functionality. Please test and let me know if you have any issues. The Q50 stuff is also in this build. Should be up in the next hour or 2.

Android:
Fixed the bug with the missing trims item in the dropdown. Beta with that fix and Q50 additions will be live later tonight.

If all goes well over the next 24-48 hours I'll release both builds to the public channel.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#4373)
Old
VirusbetaX VirusbetaX is offline
Junior Member
 
Posts: 75
Join Date: Jul 2017
Car: Infiniti Q50 SilverSport 3.0T
Default 10-27-2017, 01:14 PM

Quote:
Originally Posted by Dmac @ BMS/DMD
Made a few new changes to the iOS beta which should improve functionality. Please test and let me know if you have any issues. The Q50 stuff is also in this build. Should be up in the next hour or 2.

Android:
Fixed the bug with the missing trims item in the dropdown. Beta with that fix and Q50 additions will be live later tonight.

If all goes well over the next 24-48 hours I'll release both builds to the public channel.
Sent you an email ready for the Q50 Beta tonight.
Reply With Quote
(#4374)
Old
Connormobley Connormobley is offline
Junior Member
 
Posts: 47
Join Date: Jun 2016
Car: 135i
Default 10-28-2017, 10:00 AM

Ive been using your betas for some time now, I was having some connect issues and random 2abc, and 3100 codes. But with the latest update all is well.
Reply With Quote
(#4375)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Demigod
 
Posts: 1,749
Join Date: Aug 2013
Car: 2008 135i
Default 11-01-2017, 09:38 AM

Quote:
Originally Posted by Connormobley
Ive been using your betas for some time now, I was having some connect issues and random 2abc, and 3100 codes. But with the latest update all is well.
Thanks for the report.

Quote:
Originally Posted by cnm135i
Feedback on A172.

ATM I have the following two things I'd like improved.

1. Hard to read the drop down menu
2. Move the User and WMI settings up top as these are accessed most frequently. Even more awesome if double-tapping the meth gauge would enter the WMI setting OR give a drop-down with 30/40/50....adder
Is anyone else having this issue with the color of the dropdown menu text being black?

The account and basic settings HAVE to be at the top to give new customers the easiest path of starting to use the app. I can definitely look at shortcuts/gestures for some things.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2018, N54tech.com