N54Tech.com - International Turbo Racing Discussion
(#1)
Old
viniebenet3 viniebenet3 is offline
New Member
 
Posts: 4
Join Date: Jul 2020
Car: renualt
Default N55 burning oil, HELP - 09-21-2020, 12:37 AM

Hey everyone, I’ve had quite a few problems with my Bmw in the last 6 months. I have just over 100k miles on it. Currently I am burning oil bad. Whenever I get on the gas initially I get a cloud of dark smoke coming out of the exhaust. I can’t imagine it’s piston rings or something with in the engine. Has anyone has this problem? Could it potentially be turbo seals? I will be getting it up on our lift as soon as the whether is more consistent and nice. Have a TA on there now in storage. Also I have a transmission on the way as second gear has had a problem for some time now. If there is a more serious problem then would like to get it all done at the same time. Let me know what ideas you all have please! Maybe it’s something simple that I don’t know about?? Thanks!https://snaptube.cam/ 9apps

Last edited by viniebenet3; 09-21-2020 at 02:21 AM..
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com