N54Tech.com - International Turbo Racing Discussion
(#1)
Old
lenn lenn is offline
Junior Member
 
Posts: 53
Join Date: Dec 2012
Car: 535xi Wagon
Default Do not use STP oil filters!!!! (S10075) - 03-15-2014, 02:35 PM

If you have this oil filter installed, go replace it NOW.

Just fished this out of my N54. Approximately 4,800 miles. The filter media was collapsed against the oil filter "cage" and took on the shape on the inside. Both rubber end caps separated from the unit and was stuck on the inside of the oil filter cap and oil filter housing.

I recall some older style K&N filters share this design as well with 2 piece rubber end caps, red inner rubber with black outer gasket. I was an idiot, this was the only filter available at the parts store when I bought the "oil change special" combo. Don't take the chance, stick with the OEM MANN filters.

1


2


3


4

Last edited by lenn; 03-15-2014 at 02:36 PM.. Reason: fixed image
Reply With Quote
(#2)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 1,337
Join Date: Jun 2011
Car: 135i N54
Default 03-15-2014, 03:05 PM

Good lord that's bad. Guess it can't handle the N54's high oil temps.
Reply With Quote
(#3)
Old
lenn lenn is offline
Junior Member
 
Posts: 53
Join Date: Dec 2012
Car: 535xi Wagon
Default 03-15-2014, 03:14 PM

Hmm... another guy, similar experience. I really should've known better:

http://www.e90post.com/forums/showthread.php?t=663871
Reply With Quote
(#4)
Old
sfvalley335i sfvalley335i is offline
Junior Member
 
Posts: 65
Join Date: Nov 2008
Car: 335
Default 03-15-2014, 03:30 PM

product of U.S.A.
Reply With Quote
(#5)
Old
hakentt hakentt is offline
Junior Member
 
Posts: 27
Join Date: Sep 2013
Car: E92
Default 03-17-2014, 10:05 AM

anybody who does not use recommended factory filter for BMW should not own BMW.
Reply With Quote
(#6)
Old
lenn lenn is offline
Junior Member
 
Posts: 53
Join Date: Dec 2012
Car: 535xi Wagon
Default 03-21-2014, 05:20 AM

Quote:
Originally Posted by hakentt
anybody who does not use recommended factory filter for BMW should not own BMW.
Thanks for the insightful observation. You've been a true asset to this forum.
Reply With Quote
(#7)
Old
raceyBMW's Avatar
raceyBMW raceyBMW is offline
king of the hills
 
Posts: 41
Join Date: Jan 2008
Car: E92 335i
Default 03-21-2014, 08:16 AM

Wow, that's really terrible! You should send those photos to STP because they should not be selling these filters for use in the the N54. That is just completely not acceptable that they collapsed like that!
Reply With Quote
(#8)
Old
wfo_180 wfo_180 is offline
New Member
 
Posts: 8
Join Date: Nov 2014
Car: 2009 335, sedan, x drive
Default 11-07-2014, 01:10 PM

Has there been issues with the filters Amsoil sells?
look at filters
http://www.amsoil.com/mygarage/vehic...09+BMW+335xi+G
Reply With Quote
(#9)
Old
ucdbiendog ucdbiendog is offline
New Member
 
Posts: 18
Join Date: Apr 2014
Car: 2008 335xi
Default 11-26-2014, 11:12 PM

Quote:
Originally Posted by lenn
Thanks for the insightful observation. You've been a true asset to this forum.
hahaha +1
Reply With Quote
(#10)
Old
lenn lenn is offline
Junior Member
 
Posts: 53
Join Date: Dec 2012
Car: 535xi Wagon
Default 12-07-2014, 07:30 AM

Quote:
Originally Posted by raceyBMW
Wow, that's really terrible! You should send those photos to STP because they should not be selling these filters for use in the the N54. That is just completely not acceptable that they collapsed like that!
I was not able to find any customer support numbers or contact info specific to their line of oil filters on their website. Definitely reflects their lack of commitment to the quality of their filters.

The STP mainly pushes their oil and gas additives. I posted pictures of their failed filters on facebook and tagged them several months ago. They haven't responded.

I don't use their products often, but I will be sure to avoid anything they make in the future.
Reply With Quote
(#11)
Old
TTbavarian TTbavarian is offline
New Member
 
Posts: 18
Join Date: Dec 2014
Car: E90 N54 6MT
Default 12-08-2014, 10:48 AM

OMG...glad you didn't get any damage to your car from it
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com