N54Tech.com - International Turbo Racing Discussion
(#1)
Old
DaKing's Avatar
DaKing DaKing is offline
DaKing Racing
 
Posts: 8
Join Date: Nov 2015
Car: BMW 335i Cabrio N54
Default N54 turbo siren. Driving disabled turbo - 12-09-2017, 06:13 AM

A few days ago my 335i started to make noise. It sounds like turbo siren.
The noise is coming from the back of the engine under the hood.

I disconnected one of the vacuum canister hoses and the siren sound is gone.

I made a video:

https://youtu.be/xLXjud9FOy8

I read in other posts it is possible to disable the turbo's with jb4 map 8. I have jb4 g5 firmware 30-10. But the siren sound stays.

Only with disconnected hose from the vacuum canister I don't hear the sound.

On jb mobile gauge reading wgdc it says 90 and stays on 90 when driving.

Is this save to drive and not bad for the engine and turbo's?

Last edited by DaKing; 12-09-2017 at 02:24 PM..
Reply With Quote
(#2)
Old
limitdown's Avatar
limitdown limitdown is offline
Junior Member
 
Posts: 146
Join Date: Jul 2015
Car: 2007 335i E93
Default 12-10-2017, 07:32 PM

That's the "siren of death" of the turbos
Reply With Quote
(#3)
Old
arhoads335i arhoads335i is offline
Junior Member
 
Posts: 50
Join Date: May 2017
Car: E92 335i
Default 12-11-2017, 05:20 AM

yes you need new turbos! you could also write a map for map 6 that has zero boost
Reply With Quote
(#4)
Old
DaKing's Avatar
DaKing DaKing is offline
DaKing Racing
 
Posts: 8
Join Date: Nov 2015
Car: BMW 335i Cabrio N54
Default 12-11-2017, 01:47 PM

Siren of death.. hope it is something else. What other could make this sound? Cracked airpipe or turbo tube?
Reply With Quote
(#5)
Old
SE7EN 60's Avatar
SE7EN 60 SE7EN 60 is offline
New Member
 
Posts: 1
Join Date: Jun 2017
Car: 335i
Default 12-15-2017, 07:51 PM

Hey bro. Mine always sounded like that. Purchased the car with 90k on it. It came with DCI, Full exhaust (no ***** *********) and JB4 G5. I never guessed it suppose to sound different. Boost is great and on target. I say as long as performance doesn't suck, keep driving. Boost on!


Reply With Quote
(#6)
Old
DaKing's Avatar
DaKing DaKing is offline
DaKing Racing
 
Posts: 8
Join Date: Nov 2015
Car: BMW 335i Cabrio N54
Default 12-16-2017, 06:44 AM

Yes. But if the turbo fails it could bring damage also to the engine.

I bought an endoscope hd cam. Now I can inspect the turbo compressor wheel from the air tube inlet.

https://youtu.be/5ZgRDpQx3f4

I disconnected the hose from one of the vacuum canister. My car does not build boost now.

Last edited by DaKing; 12-16-2017 at 12:17 PM..
Reply With Quote
(#7)
Old
THE BEAST THE BEAST is offline
Senior Member
 
Posts: 636
Join Date: Apr 2016
Car: 2008 E93
Default 12-16-2017, 11:50 AM

Thats the turbo for sure. Also in the compressor video you can see the damage causing the sound.
Reply With Quote
(#8)
Old
THE BEAST THE BEAST is offline
Senior Member
 
Posts: 636
Join Date: Apr 2016
Car: 2008 E93
Default 12-16-2017, 11:52 AM

Bearings are done. Excessive play.
Reply With Quote
(#9)
Old
CMC1980's Avatar
CMC1980 CMC1980 is offline
New Member
 
Posts: 6
Join Date: Jul 2018
Car: 2010 535i xDrive e60
Default 07-12-2018, 12:15 PM

I guess I should get an endoscope since mine's making the same sound now
https://www.youtube.com/watch?v=w37HkySTWIk
and here I thought it was Ric Flair.

So am I safe to disconnect a vacuum canister and drive it while I order the other turbos? Chris from VTT was very helpful so I am looking at those OE ones they sell. I just rolled 100k in my 2010 E60

Last edited by CMC1980; 07-12-2018 at 12:21 PM..
Reply With Quote
(#10)
Old
CMC1980's Avatar
CMC1980 CMC1980 is offline
New Member
 
Posts: 6
Join Date: Jul 2018
Car: 2010 535i xDrive e60
Default 07-12-2018, 03:04 PM

Well I disconnected one of the hoses and it stopped making the noise. I guess Iím buying turbos?
Reply With Quote
(#11)
Old
CMC1980's Avatar
CMC1980 CMC1980 is offline
New Member
 
Posts: 6
Join Date: Jul 2018
Car: 2010 535i xDrive e60
Default 07-12-2018, 07:30 PM

I guess my serious question is, is it ok for me to drive the car with this line disconnected while I wait for the turbos to show up?
Reply With Quote
(#12)
Old
LessIsMore's Avatar
LessIsMore LessIsMore is offline
Inner Circle Member
 
Posts: 1,087
Join Date: Aug 2012
Car: 2009 535i Sport SAT
Default 07-13-2018, 02:01 PM

Yes, you're buying new turbos

Your rolling the dice pretty hot by driving it, man - soon I'd think the turbos will leak significant oil, and are probably already sending oily exhaust down to your catalytic converters which will ruin them. More oil in the exhaust will foul the 02 sensors too. Also if something physically breaks off, it's going to get lodged in the *** and clog it or ruin it.

The disconnected line is not stopping the turbos from spinning or oil flowing through them, just not making positive boost anymore. If you must drive it, keep line disconnected. But still not recommended.


2009 535i Sport - 548whp
Software :
JB4 G5 | MHD | Trebila Tune | XHP Stage 3
Hardware: VTT GC Lites | MFactory Helical LSD | Inlets | Outlet | VRSF 3" D-P's | VRSF 7" FMIC | Fuel-It! S2 LPFP | Fuel-It! TBI | BMS DCI | ER CP | Forge DV's | Koni FSD

Reply With Quote
(#13)
Old
CMC1980's Avatar
CMC1980 CMC1980 is offline
New Member
 
Posts: 6
Join Date: Jul 2018
Car: 2010 535i xDrive e60
Default 07-14-2018, 03:08 PM

Well that answers my question lol. Thank you. I picked up an endoscope just so I can check out the impeller first before I yank everything out. I gotta order the new ones am hopeful I can get them in next weekend.
Reply With Quote
(#14)
Old
CMC1980's Avatar
CMC1980 CMC1980 is offline
New Member
 
Posts: 6
Join Date: Jul 2018
Car: 2010 535i xDrive e60
Default 07-16-2018, 08:57 AM

some endoscope pics from my siren


This is the rear one. The oil is actually from outside. I must have a leak at the valve cover gasket in the rear dripping onto the airduct and getting pulled in(gonna fix that with the replacement obviously) You can see the scratches from the compressor rubbing the edge. I've been emailing Chris@VargasTurboTech about it. Looks like I just missed the July 4th discount.
Reply With Quote
(#15)
Old
CMC1980's Avatar
CMC1980 CMC1980 is offline
New Member
 
Posts: 6
Join Date: Jul 2018
Car: 2010 535i xDrive e60
Default 07-19-2018, 04:56 AM

New Vargas OE replacements are on order. I will post pics during/after the install is finished. Chris told me they would be about 2 weeks out on delivery.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2018, N54tech.com