N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Dr3K0 Dr3K0 is offline
Junior Member
 
Posts: 31
Join Date: Dec 2009
Car: 135i
Default Cant update JB4 firmware, plz help. - 11-20-2016, 01:54 PM

To make story short, i fell of the grid due life things and now have sometime to work on my 135i. Has been on the garage for more than 3 years, total millage is under 18k (2009). I accumulated quite a bit of performance parts thru the years and put most of them on the car when had time available (started 3 months ago). Today I installed a JB4 G5 with diodes on them; removed them and wanted to install the ISO firmware. I followed the instructions to the T but when try to do the upgrade procedure it does not work.

Press the start button 2 times(car on, not running), wait for the dash light to turn on and click connect on the JB4. It fails to connect. ( using the right COM port)

But I can fire up the car and connect to the JB4 no problem.

Firmware on the JB4 is 9/1/12//2 and trying to update to G5_ISO_32_4.

Please Help.



Thanks.
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,440
Join Date: Oct 2012
Car: 135i
Default 11-20-2016, 02:12 PM

That is some old firmware.

If you can't get the firmware to update you may need to send it in to be hard flashed. The information is on the BMS website.

http://www.burgertuning.com/N54_JB4_upgrades.html



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
Dr3K0 Dr3K0 is offline
Junior Member
 
Posts: 31
Join Date: Dec 2009
Car: 135i
Default 11-20-2016, 02:47 PM

Damn it. Seems like all I get on this project are hold backs.... really messing with my time table for get it done.


Thanks for the help. I will send it in unless somebody have an idea.


Can I try to flash with the engine running?
Reply With Quote
(#4)
Old
Dr3K0 Dr3K0 is offline
Junior Member
 
Posts: 31
Join Date: Dec 2009
Car: 135i
Default 11-20-2016, 05:51 PM

Solved the problem. Instructions are wrong on how to put the car "on". The instructions said press 2 times, I had to do only 1. Connected and updated w/o problem.

Thanks Steve for at least trying to help. +1 for you buddy.
Reply With Quote
(#5)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,440
Join Date: Oct 2012
Car: 135i
Default 11-21-2016, 10:46 AM

LOL...



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com