N54Tech.com - International Turbo Racing Discussion
(#1)
Old
F56_MCS's Avatar
F56_MCS F56_MCS is offline
New Member
 
Posts: 15
Join Date: Aug 2020
Car: 2014 F56 MCS
Default I need some help please with Methanol JB4 install - 06-28-2021, 02:02 PM

The below question was sent to Steve@burgertuning.com and answered by Ando with a 1 line reply, please BMS at least read the email and not just the title.

Reply:
Hi,

Update the firmware to the latest version and use map 3 for the methanol injection.


Best,
Burger Motorsports Support
BurgerTuning.com

Original enquiry:
Hi Steve,

I have a late 2014 F56 Mini Cooper S which has had a JB4 unit running on map 2 for about 3 years and has ran just fine.

I wanted to improve my Mini by installing WMI and liked the safety features advertised by the JB4 so I purchased a AEM WMI kit as it was on sale 😉, I dumped the wiring and used the tank, pump, solenoid and V3 nozzle. I then purchased a BMS FSB to control the meth install.

Install as follows:

Tank in trunk with pump, lines ran internally and through fire wall to engine bay connected to solenoid then to V3 nozzle, also in engine bay is the JB4 unit and FSB in a waterproof container.

FSB V2 wiring as follows:

Blue wire to #14 in the JB4 unit
Orange wire to the #3 in the JB4 unit
Green wire to solenoid
Yellow to Red on pump
Red switched 12v power
Black to ground on the strut tower - good ground to base metal.

After the install I used the iPhone app connecting to the JB4 unit with the Bluetooth connector to select Map 3 and used the blue purge button to free the lines of any air. During purge the nozzle was positioned in a container and the 50/50 methanol to water mix was clearly visible and filling the bottle.

The nozzle was screwed into its location and the car was taken for a run to test flow, I changed the gear dial to WMI flow to monitor and during the drive it was registering between 60-100% BUT the pump was not kicking in and the tank level did not drop. 30-minute test drive but no methanol water mix had been used and IAT's increased throughout the test drive.

Wanted to note the Boost Additive is 40 and Signal Scaling is 60.

I returned home to and my 1st thought was to update the firmware from MINI_B38_B48_OBDII_4.hex to the latest MINI_B38_B48_7_T1.hex but this had no effect on the install after a test drive, note the firmware update rendered the WMI flow dial on the app at 0 and did not move so it seems I have taken a step backwards.

I tried reinstalling the old firmware but the WMI flow dial is now pertinently on 0, I purged the system again into a bottle with fluid clearly visible.

Being as it was showing 0 flow on both versions of the firmware I returned to the latest version.

My next port of call was the FSB which I disassembled to check it had the green pulsing LED which it had so I returned it to its waterproof container.

I also checked the fuse for the 12v switched but kind of already new that was OK.

On purge just want to note that the solenoid clicks.

I have enclosed a Log but please excuse my inexperience with this but I thought I should carry the procedure out whilst on the test run as I new the install had problems. The strange thing is even though Map 3 was selected I saw no Methanol indicator on the log?


I am looking for help on what I can do next to test my install and resolve the lack of methanol flow?

Any help would be greatly appreciated,

Thanks
Reply With Quote
(#2)
Old
F56_MCS's Avatar
F56_MCS F56_MCS is offline
New Member
 
Posts: 15
Join Date: Aug 2020
Car: 2014 F56 MCS
Default 07-19-2021, 12:11 AM

So how do you get support for JB4? tried email and Forum. Just amazed how you can part with $$$ and get 0 support as soon as you get too technical
Reply With Quote
(#3)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,048
Join Date: Oct 2012
Car: 135i
Default 07-19-2021, 12:36 PM

You will need to email support@burgertuning.com for assistance with this.

Try and keep it simple and to the point to address one thing at a time. Avoid long emails as they aren't as productive.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#4)
Old
F56_MCS's Avatar
F56_MCS F56_MCS is offline
New Member
 
Posts: 15
Join Date: Aug 2020
Car: 2014 F56 MCS
Default 07-20-2021, 04:26 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
You will need to email support@burgertuning.com for assistance with this.

Try and keep it simple and to the point to address one thing at a time. Avoid long emails as they aren't as productive.
Steve this was sent to you originally and you passed it onto Ando in customer service and all I got was a one line reply saying update firmware and use map 3.

Obviously no one read my message as I have already tried various firmwares and have been on map 3 since installing the WMI kit.

Addressing the "try and keep it simple". I would have thought that to give background info would help otherwise we will end up sending messages back and forth with problem solving that have already been done such as the firmware and map 3 answer I got.
Reply With Quote
(#5)
Old
Jay1312 Jay1312 is offline
Jay1312
 
Posts: 62
Join Date: Jun 2017
Car: BMW 320i and M5
Default 07-20-2021, 10:52 AM

Is meth trigger set to 1 or 0 as 0 didn’t work but 1 does.
Reply With Quote
(#6)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,048
Join Date: Oct 2012
Car: 135i
Default 07-20-2021, 11:06 AM

Ando is the correct person to contact at support@burgertuning.com
...that is why it was forwarded. This is not a fuel system upgrade.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#7)
Old
F56_MCS's Avatar
F56_MCS F56_MCS is offline
New Member
 
Posts: 15
Join Date: Aug 2020
Car: 2014 F56 MCS
Default 07-20-2021, 11:46 AM

Quote:
Originally Posted by Jay1312
Is meth trigger set to 1 or 0 as 0 didnít work but 1 does.
Hi its set to 0 as followed the user instructions for a meth install from BMS dated 2017

I'll try 1 and see what result I get, thanks for you input Jay
Reply With Quote
(#8)
Old
F56_MCS's Avatar
F56_MCS F56_MCS is offline
New Member
 
Posts: 15
Join Date: Aug 2020
Car: 2014 F56 MCS
Default 07-20-2021, 11:56 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Ando is the correct person to contact at support@burgertuning.com
...that is why it was forwarded. This is not a fuel system upgrade.
If Ando is the correct person to contact then I'm in the crapper as the advice "upgrade firmware and set to map 3" was the support I got. If he read the email he'd see that these actions had already been carried out.

Honestly Steve this is not the 1st time customer service has let me down, had problems with app on various occassions and contacted customer support with no replies what so ever so had to roll back to older versions of firmware.

I have used BMS for 3 years and as long as its simple map 1 or 2 and plug and play things are fine but when it comes to anything technical its like pulling teeth with you guys, maybe its because I'm over the pond and you could not give a flying **** about your European customers.

I'm not being a dick mate I'm just telling how it is, it takes weeks and weeks for results from you guys so whats that all about?
Reply With Quote
(#9)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 20,048
Join Date: Oct 2012
Car: 135i
Default 07-21-2021, 05:05 PM

My advice is to reach out to Ando and take it one step at a time. We answer hundreds of emails/threads a day. Reading a long diatribe to try and sort out what has/hasn't been done, responding and then ending up with a confused customer doesn't work very well. Take it a step at a time and be patient, that's what works the best IMO.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#10)
Old
F56_MCS's Avatar
F56_MCS F56_MCS is offline
New Member
 
Posts: 15
Join Date: Aug 2020
Car: 2014 F56 MCS
Default 07-22-2021, 11:53 AM

Quote:
Originally Posted by Jay1312
Is meth trigger set to 1 or 0 as 0 didnít work but 1 does.
Hey Jay I tried trigger 1 but still nothing, used map 2 and 3 with no results so returned to Meth Trigger 0.

Cant work it out as the priming of the system works fine with a really good spray.

Here are my settings in the JB4 Map 3, can you see anything that could be causing a problem?

Have tried Boost addative at 65 and Min Flow Boost as low a 4 but still nothing

Running Firmware MINI_B38_B48_OBDII_5_TEST1.hex from a old methanol thread by johntotah94 as the latest Firmware causes problems with reading and deleting codes.
Attached Images
       
Reply With Quote
(#11)
Old
Jay1312 Jay1312 is offline
Jay1312
 
Posts: 62
Join Date: Jun 2017
Car: BMW 320i and M5
Default 07-23-2021, 04:13 PM

Try latest firmware ver7 please just run map 3 boost with
Minimum boost additive. You need to hit the criteria for meth to flow 9psi and 3-6k rpm but may be try with boost at slightly lesser boost and check/post
Logs here.
Reply With Quote
(#12)
Old
F56_MCS's Avatar
F56_MCS F56_MCS is offline
New Member
 
Posts: 15
Join Date: Aug 2020
Car: 2014 F56 MCS
Default 07-24-2021, 01:51 AM

Quote:
Originally Posted by Jay1312
Try latest firmware ver7 please just run map 3 boost with
Minimum boost additive. You need to hit the criteria for meth to flow 9psi and 3-6k rpm but may be try with boost at slightly lesser boost and check/post
Logs here.
Jay 1st off thank you for your time as really struggling with this at the moment.

I have now updated to the latest firmware and tried various runs with Min Flow Boost set as low as 4 and gradually increasing with runs but still nothing Iím afraid.

I have Boost Addative at 40 and Sig Scale at 60.

I also tried Meth Trigger at 0 and at 1 but still no methanol flow.

Iíll carry out some runs over the weekend with logs and post here ;-)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com