N54Tech.com - International Turbo Racing Discussion
(#1)
Old
itscuzimmaturk itscuzimmaturk is offline
Junior Member
 
Posts: 92
Join Date: Jan 2016
Car: 08 335i e93
Default Jb4 problems - 10-15-2016, 01:49 PM

Hey guys i have an 07 335i and my buddy just bought one too, 8 hooked up my jb4 to his car, everything seems to work, like boost on fuel, shift lights work, but it doesnt seem to pass 8.5 psi, when i re wire it to my car it works perfectly fine, my buddies car has a really bad waste gate rattle i know its a common issue, but this is really noticable and loud, would that have anything to do with it?
Reply With Quote
(#2)
Old
itscuzimmaturk itscuzimmaturk is offline
Junior Member
 
Posts: 92
Join Date: Jan 2016
Car: 08 335i e93
Default 10-15-2016, 02:52 PM

Also he's missing an oil cooler because the cars been hit from the right side, would thatbhage anything to do with it?
Reply With Quote
(#3)
Old
joselarajan87's Avatar
joselarajan87 joselarajan87 is offline
Banned
 
Posts: 493
Join Date: May 2013
Car: 2009 Bmw 335i
Default 10-15-2016, 03:04 PM

Quote:
Originally Posted by itscuzimmaturk
Also he's missing an oil cooler because the cars been hit from the right side, would thatbhage anything to do with it?
log the car. he might have a boost leak . check also what map he has it on. might be on map 4... waiste gate raddle wont cause this.
Reply With Quote
(#4)
Old
itscuzimmaturk itscuzimmaturk is offline
Junior Member
 
Posts: 92
Join Date: Jan 2016
Car: 08 335i e93
Default 10-15-2016, 03:17 PM

Quote:
Originally Posted by joselarajan87
log the car. he might have a boost leak . check also what map he has it on. might be on map 4... waiste gate raddle wont cause this.
Its running 8ish psi which is factory psi though, you think its a boost leak?
Reply With Quote
(#5)
Old
Young_Man Young_Man is offline
Junior Member
 
Posts: 54
Join Date: Jun 2011
Car: E90
Default 10-15-2016, 03:21 PM

Doesn't sound like a jb4 problem. Have him check the 2 vacuum lines running under the engine cover.
Reply With Quote
(#6)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 33,849
Join Date: Jan 2008
Default 10-15-2016, 04:18 PM

Would need a JB4 log to offer any tuning advice. Maybe as simple as a setting like menu4 not being set to 3 in dash.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com