N54Tech.com - International Turbo Racing Discussion
(#1)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default N54 335i logs - 04-25-2019, 01:55 PM

Hello, at the beggining sorry for my english. Today I managed to log my JB4 E91 335i LCI N54 with JB4. The reason was feeling that something stops the car to go on full power. Smth like too low fuel pressure or misfire - it is only sometimes acceleratiing on high rpm. Earlier I have problem with misfire but two days ago I changed all spark plugs for OEM N54 BMW and problem is gone now. Now my problem is this feeling that smth limits my car to accelerate on full power. I also noticed 2AAF fault code, and i hope it can help us solve the problem. I attach my logs and fault codes.
Attached Images
 
Attached Files
File Type: csv log1.csv (36.1 KB, 13 views)
File Type: csv log2.csv (30.5 KB, 10 views)
File Type: csv log3.csv (17.1 KB, 7 views)
Reply With Quote
(#2)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 04-25-2019, 08:37 PM

Quote:
Originally Posted by SebaPL_335i
Hello, at the beggining sorry for my english. Today I managed to log my JB4 E91 335i LCI N54 with JB4. The reason was feeling that something stops the car to go on full power. Smth like too low fuel pressure or misfire - it is only sometimes acceleratiing on high rpm. Earlier I have problem with misfire but two days ago I changed all spark plugs for OEM N54 BMW and problem is gone now. Now my problem is this feeling that smth limits my car to accelerate on full power. I also noticed 2AAF fault code, and i hope it can help us solve the problem. I attach my logs and fault codes.
Hey welcome-

Few things we need to do first.

1) update your JB4 firmware- you are a couple versions behind- firmware can be found in our n54 sticky

2) enable 6cyl logging

3) once firmware is up to date- relog 3rd gear- 2k to redline, wirh traction off

4) your English wasnít too bad



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#3)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-26-2019, 02:11 AM

Ok i will do that and relog my car once again

What is more i noticed very poor mileage (high consumption) - can it be caused by o2 sensor precat that shows the fault? My car consume about 13mpg!!! I am driving it rather slow

Spark plugs and oil changed 2 days ago.
Reply With Quote
(#4)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 04-26-2019, 06:28 AM

Quote:
Originally Posted by SebaPL_335i
Ok i will do that and relog my car once again

What is more i noticed very poor mileage (high consumption) - can it be caused by o2 sensor precat that shows the fault? My car consume about 13mpg!!! I am driving it rather slow

Spark plugs and oil changed 2 days ago.
O2s can cause poor gas mileage for sure.

How old are your current o2 sensors?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#5)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-26-2019, 07:16 AM

I do not know because I bought this car 2 weeks ago and I am trying to restore it the question is which one should I change or maybe both of them? When I relog my car earlier would you be able to figure out which one to change and wheter O2 sensors causes high consumption?
Reply With Quote
(#6)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 04-26-2019, 11:08 AM

Quote:
Originally Posted by SebaPL_335i
I do not know because I bought this car 2 weeks ago and I am trying to restore it the question is which one should I change or maybe both of them? When I relog my car earlier would you be able to figure out which one to change and wheter O2 sensors causes high consumption?
We can look at the banks 1/2 thatíll tell us which are out of whack.

Then the codes correlate as well which need to be changed



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#7)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-26-2019, 01:35 PM

I finnaly updated JB4 and have set the 6 cyl logging (I supose I have done it), and relogged car on maps 4, 2, 1 without traction control (I attach logs).
And I have all the time 2C31 fault code and high consumption.
Attached Files
File Type: csv log1 map4.csv (10.9 KB, 8 views)
File Type: csv log2 map1.csv (13.1 KB, 12 views)
File Type: csv log3 map2.csv (12.1 KB, 4 views)
Reply With Quote
(#8)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 04-26-2019, 06:39 PM

Quote:
Originally Posted by SebaPL_335i
I finnaly updated JB4 and have set the 6 cyl logging (I supose I have done it), and relogged car on maps 4, 2, 1 without traction control (I attach logs).
And I have all the time 2C31 fault code and high consumption.
Yeah you have pretty wide bank to bank AFR variation- id replace at minimum the sensor thatís throwing the 2c31 - personally if in the budget Iíd just do both.



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#9)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-27-2019, 06:03 PM

Today I replaced o2 precat sensor on bank1. 2C31 still coming back I noticed tht at idle AFR1 is eg. 13.8 while AFR2 is 15.1 then. I do not know what to do now? Replace second o2 sensor?
Reply With Quote
(#10)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-29-2019, 12:15 AM

What is more I noticed that car is shaking at idle when warming up. It feels like misfiring.
Reply With Quote
(#11)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 04-29-2019, 12:28 PM

Quote:
Originally Posted by SebaPL_335i
What is more I noticed that car is shaking at idle when warming up. It feels like misfiring.
Pull codes.

Double check all connectors too.

I’d replace both sensors- did you only do the 1?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL

Last edited by Dave @ BMS/Fuel-It!; 04-29-2019 at 12:40 PM..
Reply With Quote
(#12)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-29-2019, 01:44 PM

Yes only bank1 precat o2 sensor - today it shown two faults 2C31 and 2C27 and car works even worse at idle I think
Reply With Quote
(#13)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-29-2019, 02:55 PM

I logged car with INPA to check O2 sensors and rough running and I put photos with results. As you can see lambda on bank1 (which is new) shows even 1,59 while second o2 sensor 2,08 at this time.



Last edited by SebaPL_335i; 04-29-2019 at 03:07 PM..
Reply With Quote
(#14)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 04-29-2019, 08:53 PM

Quote:
Originally Posted by SebaPL_335i
I logged car with INPA to check O2 sensors and rough running and I put photos with results. As you can see lambda on bank1 (which is new) shows even 1,59 while second o2 sensor 2,08 at this time.


You can try an o2 reset- see if that brings them closer.

But Iím Thinking you may just wanna replace



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#15)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 04-30-2019, 04:12 PM

I made injector test like on youtube but it did not leaks visibly. As I told earlier I replaced spark plugs week ago and after putting them out today, 3 of 6 were black at the ends and has oil on it (gasket of the top engine cover is leaking)
Reply With Quote
(#16)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 04-30-2019, 10:58 PM

Quote:
Originally Posted by SebaPL_335i
I made injector test like on youtube but it did not leaks visibly. As I told earlier I replaced spark plugs week ago and after putting them out today, 3 of 6 were black at the ends and has oil on it (gasket of the top engine cover is leaking)
Iím thinking that bank 2 o2 needs to be replaced



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#17)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 05-01-2019, 12:44 PM

I finnaly replaced second o2 sensor - still the same. I even changed injectors from bank1 to bank2 and from bank2 to bank1 and afr on bank1 still indicates rich (13.8 at idle) while on bank2 lean (15 at idle). I can feel the smell of petrol from exhaust
Reply With Quote
(#18)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 05-02-2019, 05:53 AM

Quote:
Originally Posted by SebaPL_335i
I finnaly replaced second o2 sensor - still the same. I even changed injectors from bank1 to bank2 and from bank2 to bank1 and afr on bank1 still indicates rich (13.8 at idle) while on bank2 lean (15 at idle). I can feel the smell of petrol from exhaust
How old / index injectors?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#19)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 05-02-2019, 06:13 AM

09
Reply With Quote
(#20)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 05-02-2019, 01:10 PM

Quote:
Originally Posted by SebaPL_335i
09
Let the car sit overnight/

Pull the plugs- if theyíre wet with gas- theyíre leaking & the injectors need to be Rellsced at least jn that bank

What year is your car? Bmw was reimbursing for 2010 n54s I think...



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#21)
Old
SebaPL_335i SebaPL_335i is offline
New Member
 
Posts: 12
Join Date: Apr 2019
Car: E91 LCI 335i N54 JB4
Default 05-04-2019, 03:32 AM

Yesterday I replaced leaking valve cover gasket and vacum hoses and everything looks good, afr on bank 1 and 2 at idle 14.6-14.7, car works perfect at idle ��
Reply With Quote
(#22)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 4,444
Join Date: Apr 2014
Car: E92 335XI
Default 05-04-2019, 06:56 AM

Quote:
Originally Posted by SebaPL_335i
Yesterday I replaced leaking valve cover gasket and vacum hoses and everything looks good, afr on bank 1 and 2 at idle 14.6-14.7, car works perfect at idle ��
Success!

Letís get some logs & have some fun



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2018, N54tech.com