N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Stephenson234 Stephenson234 is offline
New Member
 
Posts: 0
Join Date: Apr 2019
Car: 2008 Bmw 135i
Unhappy Bmw 135i radio issues - 04-07-2019, 05:22 PM

Hey everyone, Iím new to this forum and Iíve been needing some help figuring out whatís going on with my audio system. Last November I was driving and after I hit a bump my radio went black and the audio in the car would stop working, then after a minute or two it would turn back on. As a few days went on the issue got worse, even the lightest bumps would cause it to turn off and then bam! It went black for good. My radio is blacked out and there is no audio in the car whatsoever, no dings, no chimes, nothing. Itís been about 5 months now and since then Iíve checked fuses and checked for loose wires but I canít pinpoint where the issue is. I even took it to bmw and it took $500+ For them to look for the issue, as I didnít want to spend any more money I told them to stop searching as I couldnít afford it at the time. On other forums Iíve seen, it seems as everyone has no audio OR no sound, no one is experiencing both. So thatís why I came here to see if I can get some help. Feel free to ask questions or put your thoughts down, anything would help at this point. Thanks!
Reply With Quote
(#2)
Old
eligard eligard is offline
New Member
 
Posts: 16
Join Date: Feb 2018
Car: 2007 335i
Default 04-16-2019, 10:04 PM

Sounds like loose connections to me. See if re-siting the wiring contacts and fuse will make a difference.
Reply With Quote
(#3)
Old
Vorsprung_CJB's Avatar
Vorsprung_CJB Vorsprung_CJB is offline
Pessimistic Poster
 
Posts: 1,249
Join Date: Jun 2011
Car: 135i N54
Default 04-17-2019, 05:24 AM

Did you check all of the power and ground distribution blocks? The radio has a pretty beefy power supply. Was the battery cable recall done? Any water events where water may have gotten in anywhere, like under the cowl or in the doors? Check speakers for shorts (esp rear/trunk) that may trigger electrical safety.

Be sure to disconnect the battery if you mess with any hot wiring.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com