N54Tech.com - International Turbo Racing Discussion
(#51)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,430
Join Date: Oct 2012
Car: 135i
Default 02-23-2017, 10:46 PM

You should be fine on map 0 with the N20. We did it, no issues.

The code will be an issue though. That sounds like a bad connection or bad adapter,



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#52)
Old
JUST8AV8's Avatar
JUST8AV8 JUST8AV8 is offline
Junior Member
 
Posts: 54
Join Date: May 2012
Car: 07 e92 335i
Default 02-24-2017, 11:17 AM

Thanks Steve. My tuner thinks it might be a faulty adapter as well.


09 335xi AT, Pure Stage 2 'DD' turbos, JB4 G5 ISO w/anti-lag, MHD Trebila tune, xHP Stage 3, Fuel-It Stage 2 LPFP, NGK 1 step colder plugs, BMS meth kit w/dual cm7, BMS DCI, VTT inlets/outlet, RB PCV valve, BMS OCC, N20 tmap, Cyba Scoops, Lux H8 160, VRSF 7" FMIC, VRSF **, Custom exhaust, VRSF Chargepipe, GFB SV50 BOV, ER Sport Series Oil Cooler, UUC front sway, M3 rear sway w/powerflex bushings, BC Racing coilovers, Hawk HPS 5.0 brake pads
Reply With Quote
(#53)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,430
Join Date: Oct 2012
Car: 135i
Default 02-25-2017, 10:28 AM

No problem!



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#54)
Old
JUST8AV8's Avatar
JUST8AV8 JUST8AV8 is offline
Junior Member
 
Posts: 54
Join Date: May 2012
Car: 07 e92 335i
Default 03-01-2017, 10:36 PM

Just wanted to give everyone an update that might have the same issues I had. Since I'm at high elevation (4,200+ft) My tuner made adjustments(not sure what) to my BEF per Terry's suggestion and now the 3100 & 2ABC codes are gone

If you have a N20 tmap, are at higher elevation, and are getting these two codes, you might just need a little tweak in your BEF.


09 335xi AT, Pure Stage 2 'DD' turbos, JB4 G5 ISO w/anti-lag, MHD Trebila tune, xHP Stage 3, Fuel-It Stage 2 LPFP, NGK 1 step colder plugs, BMS meth kit w/dual cm7, BMS DCI, VTT inlets/outlet, RB PCV valve, BMS OCC, N20 tmap, Cyba Scoops, Lux H8 160, VRSF 7" FMIC, VRSF **, Custom exhaust, VRSF Chargepipe, GFB SV50 BOV, ER Sport Series Oil Cooler, UUC front sway, M3 rear sway w/powerflex bushings, BC Racing coilovers, Hawk HPS 5.0 brake pads
Reply With Quote
(#55)
Old
1FastT2 1FastT2 is offline
Junior Member
 
Posts: 85
Join Date: Feb 2016
Car: 335i
Default 03-02-2017, 06:42 AM

Quote:
Originally Posted by JUST8AV8
Any thoughts? I didn't have the otg cable plugged in at start up and it still pops up with the two codes. I then decided to plug the usb directly to my computer to see if the jb4 app or otg cable was the issue. The 3100 and 2abc still pops up

I don't understand why these codes won't go away. I originally noticed the codes pop up when I first installed the 4 bar sensor a while ago so I got a replacement and still no luck. The 4 bar was also very inconsistent, unresponsive, and jumpy(main reason I got a replacement). I decided to give the n20 3.5 tmap a try and it was much better, however, I still got the two codes. Car drives fine and everything works. It's just these damn codes. I'm stuck.
This sounds like the exact path im going down right now. I already had a 4 bar replaced for it to work for a few days and now the 3100 and 2abc codes are wreaking havoc. I'm at sea level so your fix may not apply to my situation.


2008 e92 335i 6MT - On3 Performance Single Kit w/Precision 6266 Gen 2 | VRSF 7" FMIC | VRSF Chargepipe w/HKS BOV | JB4 w/Bluetooth & 2 step and MHD BEF | BMS Meth Kit 2x CM10's | Fuel It Buckless Stage 2 Pump | ADV Sensors | Trebila Tuned
Reply With Quote
(#56)
Old
JUST8AV8's Avatar
JUST8AV8 JUST8AV8 is offline
Junior Member
 
Posts: 54
Join Date: May 2012
Car: 07 e92 335i
Default 03-02-2017, 03:15 PM

Do you use the jb4 app? With otg cable & usb cable or with bluetooth?

Quote:
Originally Posted by 1FastT2
This sounds like the exact path im going down right now. I already had a 4 bar replaced for it to work for a few days and now the 3100 and 2abc codes are wreaking havoc. I'm at sea level so your fix may not apply to my situation.


09 335xi AT, Pure Stage 2 'DD' turbos, JB4 G5 ISO w/anti-lag, MHD Trebila tune, xHP Stage 3, Fuel-It Stage 2 LPFP, NGK 1 step colder plugs, BMS meth kit w/dual cm7, BMS DCI, VTT inlets/outlet, RB PCV valve, BMS OCC, N20 tmap, Cyba Scoops, Lux H8 160, VRSF 7" FMIC, VRSF **, Custom exhaust, VRSF Chargepipe, GFB SV50 BOV, ER Sport Series Oil Cooler, UUC front sway, M3 rear sway w/powerflex bushings, BC Racing coilovers, Hawk HPS 5.0 brake pads
Reply With Quote
(#57)
Old
1FastT2 1FastT2 is offline
Junior Member
 
Posts: 85
Join Date: Feb 2016
Car: 335i
Default 03-02-2017, 03:27 PM

Quote:
Originally Posted by JUST8AV8
Do you use the jb4 app? With otg cable & usb cable or with bluetooth?
I'm using the app via bluetooth. The last time I drove the car it was reading a constant 19+psi even at idle. I had to limp it home because the car was just dumping fuel.


2008 e92 335i 6MT - On3 Performance Single Kit w/Precision 6266 Gen 2 | VRSF 7" FMIC | VRSF Chargepipe w/HKS BOV | JB4 w/Bluetooth & 2 step and MHD BEF | BMS Meth Kit 2x CM10's | Fuel It Buckless Stage 2 Pump | ADV Sensors | Trebila Tuned
Reply With Quote
(#58)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,080
Join Date: Jan 2008
Default 03-02-2017, 04:00 PM

JB4 log?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#59)
Old
1FastT2 1FastT2 is offline
Junior Member
 
Posts: 85
Join Date: Feb 2016
Car: 335i
Default 03-02-2017, 04:12 PM

This is really the only one that shows the issue. All the other logs are all over the place. You can see boost never comes down after this run. Boost was set at 17psi
Attached Files
File Type: csv 2017-02-25 12_25_11.csv (5.5 KB, 53 views)


2008 e92 335i 6MT - On3 Performance Single Kit w/Precision 6266 Gen 2 | VRSF 7" FMIC | VRSF Chargepipe w/HKS BOV | JB4 w/Bluetooth & 2 step and MHD BEF | BMS Meth Kit 2x CM10's | Fuel It Buckless Stage 2 Pump | ADV Sensors | Trebila Tuned
Reply With Quote
(#60)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,430
Join Date: Oct 2012
Car: 135i
Default 03-02-2017, 11:11 PM

Set FF to zero and do a few adaption runs.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#61)
Old
1FastT2 1FastT2 is offline
Junior Member
 
Posts: 85
Join Date: Feb 2016
Car: 335i
Default 03-05-2017, 05:04 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Set FF to zero and do a few adaption runs.
Unfortunately this had no effect. In addition to setting the FF at 0 I also reflashed the BEF and reset the adaptions.

While this did rezero the TMAP back to 0 PSI at idle it didn't last long. At ldle I now see about 2.7 psi of boost.

I would imagine the TMAP is close to the most important sensor that needs to be full proof I really need to get this squared away.

Any thoughts???

Keep in mind this is my 2nd 4 bar TMAP sensor. The 1st one worked appropriately for about 200 miles and this last one hasn't seen 50.

EDIT: I'm now having a 2ABD code


2008 e92 335i 6MT - On3 Performance Single Kit w/Precision 6266 Gen 2 | VRSF 7" FMIC | VRSF Chargepipe w/HKS BOV | JB4 w/Bluetooth & 2 step and MHD BEF | BMS Meth Kit 2x CM10's | Fuel It Buckless Stage 2 Pump | ADV Sensors | Trebila Tuned

Last edited by 1FastT2; 03-05-2017 at 05:18 PM.. Reason: Added CEL code.
Reply With Quote
(#62)
Old
1FastT2 1FastT2 is offline
Junior Member
 
Posts: 85
Join Date: Feb 2016
Car: 335i
Default 03-06-2017, 06:52 PM

Quote:
Originally Posted by 1FastT2
Unfortunately this had no effect. In addition to setting the FF at 0 I also reflashed the BEF and reset the adaptions.

While this did rezero the TMAP back to 0 PSI at idle it didn't last long. At ldle I now see about 2.7 psi of boost.

I would imagine the TMAP is close to the most important sensor that needs to be full proof I really need to get this squared away.

Any thoughts???

Keep in mind this is my 2nd 4 bar TMAP sensor. The 1st one worked appropriately for about 200 miles and this last one hasn't seen 50.

EDIT: I'm now having a 2ABD code
BUMP FOR HELP!!!


2008 e92 335i 6MT - On3 Performance Single Kit w/Precision 6266 Gen 2 | VRSF 7" FMIC | VRSF Chargepipe w/HKS BOV | JB4 w/Bluetooth & 2 step and MHD BEF | BMS Meth Kit 2x CM10's | Fuel It Buckless Stage 2 Pump | ADV Sensors | Trebila Tuned
Reply With Quote
(#63)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,430
Join Date: Oct 2012
Car: 135i
Default 03-06-2017, 10:55 PM

Did you take a log with the new setting? Were you overboosting as bad?

2abd can be caused by a boost leak.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#64)
Old
1FastT2 1FastT2 is offline
Junior Member
 
Posts: 85
Join Date: Feb 2016
Car: 335i
Default 03-07-2017, 04:21 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Did you take a log with the new setting? Were you overboosting as bad?

2abd can be caused by a boost leak.
I have a log at idle I will post up later today showing boost while sitting stationary. Obviously not correct.

The thing is, its not over boosting. Its caused from a false reading from the sensor. Whether its the sensor or the jb4/bef or a combination of both somethings not right.

Thanks for your help.

EDIT: I feel this issue is different from the other an may need its own thread.


2008 e92 335i 6MT - On3 Performance Single Kit w/Precision 6266 Gen 2 | VRSF 7" FMIC | VRSF Chargepipe w/HKS BOV | JB4 w/Bluetooth & 2 step and MHD BEF | BMS Meth Kit 2x CM10's | Fuel It Buckless Stage 2 Pump | ADV Sensors | Trebila Tuned

Last edited by 1FastT2; 03-07-2017 at 07:35 AM..
Reply With Quote
(#65)
Old
Rushan's Avatar
Rushan Rushan is offline
Legend
 
Posts: 1,188
Join Date: May 2014
Car: 335i E92 2009
Default 09-22-2017, 09:11 AM

Started to have the same codes at start up in the last few days, no change done to the car,

I switch off and delete error and turn on again and all back to normal.

I have the Bluetooth connected and powers via separate fused power and always on when ignition on.

Noticed if I have the jb4 mobile app were running perior to shutdown even if i disconnect the app this error popup next day morning, if I wasn't using the jb4 mobile app then I don't get the error next day.... strange


09 E92 335i - Hot-Climate Middle East package, M Sports suspension, 19" Rims, 6AT fully built internals, bushings, raybestos clutches and sonnax with xHP stage 3, Differential lockdown, New RB Turbo CHRA, JB4 - Map 3 70 adder with N20 TMAP - MHD BMS Race Flash with Tuned Duty Bais and PID - BMS Oil Cooler Valve - RB PCV - K&N DCI - AFE Air Scoops - 98 Super Fuel - WAGNER FMIC - 3" down's, RB Inlets- BMS charge pipe With Tial BOV - BMS Meth Kit with FSB, 30/70 Water/Meth on CM12 nozzle
Reply With Quote
(#66)
Old
Dmac @ BMS/DMD's Avatar
Dmac @ BMS/DMD Dmac @ BMS/DMD is offline
Legend
 
Posts: 1,270
Join Date: Aug 2013
Car: 2008 135i
Default 09-23-2017, 10:46 AM

Quote:
Originally Posted by Rushan
Started to have the same codes at start up in the last few days, no change done to the car,

I switch off and delete error and turn on again and all back to normal.

I have the Bluetooth connected and powers via separate fused power and always on when ignition on.

Noticed if I have the jb4 mobile app were running perior to shutdown even if i disconnect the app this error popup next day morning, if I wasn't using the jb4 mobile app then I don't get the error next day.... strange
Which TMAP are you using?

For anyone else with this issue:
Please send an email to support@jb4connectkit.com with the title (2ABC and 3100). In the body of the message include your engine type, JB4 firmware version, your device type (iOS or Android), and if you're using a Connect Kit or BMS USB cable.


2008 135i 4L80E Swap - 807 WHP
VM 6466 Single Turbo Kit | JB4 | BMS Flash via MHD | Fuel-It Stage 3 | BMS Port Injection | E85


For all JB4 Mobile/Connect Kit requests, email me at: support@jb4connectkit.com

For JB4 Mobile feedback (bug reports, minor annoyances, etc.), email me at: feedback@jb4connectkit.com
Reply With Quote
(#67)
Old
Rushan's Avatar
Rushan Rushan is offline
Legend
 
Posts: 1,188
Join Date: May 2014
Car: 335i E92 2009
Default 09-23-2017, 10:51 AM

The stock TMAP

Using IOS latest on testflight, my Bluetooth connected via USB power adapter directly from the fuse box as power on with ignition.

Rev 2 Bluetooth
JB4 32_6b
N54


09 E92 335i - Hot-Climate Middle East package, M Sports suspension, 19" Rims, 6AT fully built internals, bushings, raybestos clutches and sonnax with xHP stage 3, Differential lockdown, New RB Turbo CHRA, JB4 - Map 3 70 adder with N20 TMAP - MHD BMS Race Flash with Tuned Duty Bais and PID - BMS Oil Cooler Valve - RB PCV - K&N DCI - AFE Air Scoops - 98 Super Fuel - WAGNER FMIC - 3" down's, RB Inlets- BMS charge pipe With Tial BOV - BMS Meth Kit with FSB, 30/70 Water/Meth on CM12 nozzle

Last edited by Rushan; 09-23-2017 at 10:56 AM..
Reply With Quote
(#68)
Old
qwik_ss qwik_ss is offline
New Member
 
Posts: 17
Join Date: Dec 2013
Car: 335xi
Default 10-31-2017, 08:20 AM

I'm getting the same codes after installing the n20 map sensor. My car is an 09 and I have the rev 3 bluetooth kit. A buddy of mine has this issues too on his 09. Has there been any solution
Reply With Quote
(#69)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,080
Join Date: Jan 2008
Default 10-31-2017, 08:55 AM

2ABC just means your TMAP signal is wrong. Doesn't tell you why it's wrong.

Sometimes it's a JB4 setting, sometimes a flash setting, sometimes the wrong sensor is installed.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#70)
Old
Patmcl135 Patmcl135 is offline
New Member
 
Posts: 1
Join Date: Apr 2019
Car: 135i
Default 04-16-2019, 05:31 PM

Any update on this? Have been getting these codes since last year and now need an inspection sticker.
Any update would be helpful.
Thanks
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com