N54Tech.com - International Turbo Racing Discussion
(#1)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default Engine Malfunction after JB4 Install - 06-29-2016, 09:44 AM

Yesterday I Installed a JB4 and Rev 3 kit in my 2010 535i. The only other mod I have is a DCI. I put it in map 1 after I installed it and took it for a spin. Well my first 4 pulls were amazing! But that 5th pull is where I got the Engine Malfunction/Reduced Power message on the iDrive. Here are the codes I got:
2ACC
2E8E
30FE
3100
Before I read the codes I tried driving in map 0 and at WOT it still gave me the Engine Malfunction message. However after I read and cleared the codes I ran Map 0 and at WOT I didn't get any messages. But as soon as I switched to Map 1 and went WOT I got the message.

Where should I start my investigation? I've already checked my JB4 wires and made sure everything was connected properly. Are all 4 codes related to eachother? I know 30FE and 3100 are related to eachother and 2ACC and 2E8E can possibly be related to eachother. Any help would be great guys.
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,041
Join Date: Jan 2008
Default 06-29-2016, 09:56 AM

Could be a simple setting. Make sure menu 4 in dash is set to 3. If the problem continues do a JB4 log.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default 06-29-2016, 10:52 AM

Just want to double check, to set menu 4 to 3 the Speedo should be at 40 and the Tach should be at 3 right?
Reply With Quote
(#4)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default 06-30-2016, 02:41 AM

If the previous owner of the JB4 had a 2-Step connected to it would that effect any of my settings? Like is there anything I should change because I'm not using the 2-step? Or do the settings automatically reset? I'm going to post a log later today.
Reply With Quote
(#5)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default 06-30-2016, 09:44 AM

Update on the codes. Before I read them with the speedo, and this time I read with the Jb4 app.
30FE - Boost Over Target
3100 - low boost mode engaged
2D2E - Angle of throttle Valve - intake pipe underpressure, correlation
30FF - Boost Under Target - Possible boost leak.

I drove with the car in Map 1 and did some pulls and the engine malfunction light did not come on. Is it possible the problem has corrected itself? Attached are two logs I did this morning.
Attached Files
File Type: csv 2016-06-30 04_58_08.csv (18.4 KB, 59 views)
File Type: csv 2016-06-30 05_01_08.csv (9.4 KB, 58 views)
Reply With Quote
(#6)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,041
Join Date: Jan 2008
Default 06-30-2016, 09:47 AM

Everything looks good here. Although the gas pedal is only going to 90%, make sure nothing is blocking it.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#7)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default 07-02-2016, 03:37 PM

I was finally able to log when my car gives me the Engine Malfunction message. Attached is a log of me running Map 1(Malfunction.csv) and another log running Map 5(the other attached log). I'm no longer getting the 3100 code but I'm getting 2D2E and 30FF. How can I solve this problem?
Attached Files
File Type: csv Malfunction.csv (14.7 KB, 57 views)
File Type: csv 2016-07-02 03_19_52.csv (10.5 KB, 51 views)
Reply With Quote
(#8)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default 07-02-2016, 03:43 PM

Also I went in through the JB4 Mobile app and changed all of the JB4 setting back to there default settings. When I first installed it the settings were modified a little bit. I changed the settings before my log in Map 1. Running Map 5 everything was fine. I'm only getting the malfunction message when running Map 1 or Map 0 and only at WOT.
Reply With Quote
(#9)
Old
Stoolz Stoolz is offline
Senior Member
 
Posts: 878
Join Date: Jan 2015
Car: 11 135i
Default 07-02-2016, 03:49 PM

Check your charge pipe is not broken?
Reply With Quote
(#10)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default 07-02-2016, 04:16 PM

Just checked it, it's not broken.
Reply With Quote
(#11)
Old
Stoolz Stoolz is offline
Senior Member
 
Posts: 878
Join Date: Jan 2015
Car: 11 135i
Default 07-02-2016, 04:27 PM

I kinda think its a boost leak somewhere, can you get the car smoke tested?
Reply With Quote
(#12)
Old
DoobiieDripp's Avatar
DoobiieDripp DoobiieDripp is offline
Junior Member
 
Posts: 71
Join Date: Nov 2015
Car: 2010 BMW 535i
Default 07-02-2016, 04:56 PM

I won't be able to get it smoke tested for 2 weeks because of my schedule. Is there anything else I can do in the mean time?
Reply With Quote
(#13)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,430
Join Date: Oct 2012
Car: 135i
Default 07-04-2016, 10:17 PM

A lot of timing corrections and your FF had to learn up which it did in the next log.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com