N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Manjot Manjot is offline
New Member
 
Posts: 4
Join Date: Sep 2019
Car: 2008 535i 6speed
Default 535i wonít read boost correctly - 09-20-2019, 06:37 PM

Late this March I picked up a 08í 535i Msport and have slowly worked out all the issues the car had. But I have one last issue I just canít figure out. Looking at the logs the car wonít recognize boost as my Aem gauge shows around 18 psi but the car fails to read anything above 11psi. Iíve replaced the boost pressure sensor and the map sensor. Also put in a vtto upgraded pcv valve. The car does have Bms dual cones with vrsf ********* and charge pipe with a synapse bov and stage 2 mhd map
Reply With Quote
(#2)
Old
Manjot Manjot is offline
New Member
 
Posts: 4
Join Date: Sep 2019
Car: 2008 535i 6speed
Default 09-21-2019, 02:48 PM

The car does have wastegate rattle but why would the boost gauge be reading 18psi and I’ve tried multiple gauges
Reply With Quote
(#3)
Old
Payam @ BMS's Avatar
Payam @ BMS Payam @ BMS is offline
Super Moderator
 
Posts: 5,275
Join Date: Oct 2013
Car: e90 335i
Default 09-23-2019, 11:16 AM

Logs?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#4)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,706
Join Date: Apr 2014
Car: E92 335XI
Default 09-23-2019, 02:05 PM

Quote:
Originally Posted by Manjot
Late this March I picked up a 08í 535i Msport and have slowly worked out all the issues the car had. But I have one last issue I just canít figure out. Looking at the logs the car wonít recognize boost as my Aem gauge shows around 18 psi but the car fails to read anything above 11psi. Iíve replaced the boost pressure sensor and the map sensor. Also put in a vtto upgraded pcv valve. The car does have Bms dual cones with vrsf ********* and charge pipe with a synapse bov and stage 2 mhd map
You'd need some JB4 logs for us to evaluate.

Are you using JB4, or MHD / flash only?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#5)
Old
Manjot Manjot is offline
New Member
 
Posts: 4
Join Date: Sep 2019
Car: 2008 535i 6speed
Default 09-23-2019, 08:06 PM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
You'd need some JB4 logs for us to evaluate.

Are you using JB4, or MHD / flash only?
I did buy a jb4 have not installed it as was waiting till the car was 100%. Iím guessing Mhd logs wonít help. But the simplest way for me to explain is the cars hitting and much boost the wastegates can hold proven by the boost gauge and how the car starts to lean out. But the dme does not see the boost. The car isnít throwing any check engine lights and I have replaced both sensors
Reply With Quote
(#6)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,706
Join Date: Apr 2014
Car: E92 335XI
Default 09-23-2019, 10:53 PM

Could be hardware or tube related

When you get the JB4 installed - if there’s still a problem we’d be happy to assist



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#7)
Old
Manjot Manjot is offline
New Member
 
Posts: 4
Join Date: Sep 2019
Car: 2008 535i 6speed
Default 09-23-2019, 10:59 PM

Quote:
Originally Posted by Dave @ BMS/Fuel-It!
Could be hardware or tube related

When you get the JB4 installed - if thereís still a problem weíd be happy to assist
Alrighty I will update you
Reply With Quote
(#8)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,706
Join Date: Apr 2014
Car: E92 335XI
Default 09-24-2019, 07:37 AM

Quote:
Originally Posted by Manjot
Alrighty I will update you



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com