N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Jasmeleg's Avatar
Jasmeleg Jasmeleg is offline
New Member
 
Posts: 14
Join Date: Mar 2015
Car: '07 E90 335i Arktis Metallic 6MT
Default E82 N55 E20-30 Misfires now Super Knock Codes - 05-30-2021, 07:04 PM

I have been chasing some issues at higher boost levels.

Car setup:
E82 135i N55 6mt 102Kmi (06/2012 build with Bosch style HPFP)
AFE Intake
Aluminum Chargepipe
VRSF Offroad DP
(Genuine, not Ebay knockoff) NGK 97506 Plugs gapped at 0.022"
Delphi GN10571 Coils
93 octane fuel with 3gal of E85 (E20-25) was at 1/4 tank at time of logs
MHD BEF
N55_ISO_5_17_T5 firmware

I installed the JB4 and was running map 5 for a little bit of time without issue. I don't drive this car that often with working from home and it not being my daily.

I decided to do a BEF and try a little ethanol and that's when I first started having a misfire code. Anytime I would go WOT and get > 14-15psi of boost I would hit a wall and all kinds of misfires. I had records of the plugs being done 40K miles ago and but they were stock replacements and stock gap. Replaced the plugs with one step cooler plugs and new coils because those looked original to the car.

On the drive to test out the new coils and plugs to see if the misfires went away, I got a code 2F7C and 2F7A. I guess the good thing is I am not getting a misfire anymore but the knock codes are concerning!

Here is a link to the most recent logs from a drive earlier today. The events at the very end of the drive are when it was hitting a wall. Basically will pull great up to 5K rpm then will hit a wall. From looking at the logs myself it does not look like I am running out of fuel :/

Any and all help is appreciated!! This is the second car I've owned with a JB4 and definitely love the platform and product.
Attached Files
File Type: csv P5_M5_R15_210530_1543.csv (70.3 KB, 55 views)

Last edited by Jasmeleg; 05-30-2021 at 07:06 PM.. Reason: Can Not Post Datazap
Reply With Quote
(#2)
Old
435gc 435gc is offline
Junior Member
 
Posts: 277
Join Date: May 2019
Car: 2015 435i xdrive gran coupe
Default 05-31-2021, 01:20 PM

Really need a better log. You are on and off the pedal too much in the the log you posted.

Put it in 3rd gear. Floor it 2krpms to 6500 shift to 4th for a few seconds and you're done.

Post that log.
Reply With Quote
(#3)
Old
Jasmeleg's Avatar
Jasmeleg Jasmeleg is offline
New Member
 
Posts: 14
Join Date: Mar 2015
Car: '07 E90 335i Arktis Metallic 6MT
Default 05-31-2021, 05:21 PM

Quote:
Originally Posted by 435gc
Really need a better log. You are on and off the pedal too much in the the log you posted.

Put it in 3rd gear. Floor it 2krpms to 6500 shift to 4th for a few seconds and you're done.

Post that log.

I am a bit hesitant to go do a full 3-4 pull because I am not sure it will make a full clean pass and the knocking event scares me.

In the log I posted, from timestamp 750 on I was WOT 2-3 and I hit a hesitation at ~5500 in 2nd and hit a wall at 6000 in 3rd. I did another pull after that (850) in 3rd but pull out at 5,800 because again just something wasn't right.

Do you have any suggestion on what could cause this knock event? Do the AFR's look good? It seems like Boost has tapered off quite a bit by the point where it is getting these hesitations?

The only thing I did see that looked off to me on the JB4 is the FOL value is set to 0? I am not sure if this is just normal when you have a BEF?
Reply With Quote
(#4)
Old
435gc 435gc is offline
Junior Member
 
Posts: 277
Join Date: May 2019
Car: 2015 435i xdrive gran coupe
Default 05-31-2021, 08:09 PM

There is a dip in your fuel pressure..

Set fol to 50. Set all duty bias values to 50.

Do a standard log in map 1.

Better to start with lower boost while trying to fix your issue. Need a full log to really see what is going on.

Are you sure you have menu 4/2 set for bef mode?

Also don't combine multiple pulls in a single log. Do separate logs for separate pulls. Its really challenging to view them when all mixed together.

Last edited by 435gc; 06-01-2021 at 08:23 AM..
Reply With Quote
(#5)
Old
Jasmeleg's Avatar
Jasmeleg Jasmeleg is offline
New Member
 
Posts: 14
Join Date: Mar 2015
Car: '07 E90 335i Arktis Metallic 6MT
Default 06-01-2021, 05:47 AM

Quote:
Originally Posted by 435gc
Are you sure you have menu 4/2 set for bef mode?

Also don't combine multiple pulls in a single log. Do separate logs for separate pulls. Its really challenging to view them when all mixed together.
I did enable menu 4/2 but I will confirm it is still the case.

Also the log merging is default for the JB4 app, It says in the description it is "Required by BMS" so I assumed it was correct for this forum.
Reply With Quote
(#6)
Old
Jasmeleg's Avatar
Jasmeleg Jasmeleg is offline
New Member
 
Posts: 14
Join Date: Mar 2015
Car: '07 E90 335i Arktis Metallic 6MT
Default 06-04-2021, 05:15 PM

Okay the weather finally cleared up and I was able to do a full pull. Please see log attached.

This was with FOL set to 50 and all duty bias at 50. The car did not break up but previous to this run I did have a break up event in 2nd.
Attached Files
File Type: csv P5_M1_R1_210604_190601.csv (17.2 KB, 54 views)
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2020, N54tech.com