N54Tech.com - International Turbo Racing Discussion
(#1)
Old
dysh.78 dysh.78 is offline
New Member
 
Posts: 12
Join Date: Dec 2018
Car: BMW 440i xdrive
Default Check engine vs Down p1pe - 03-20-2019, 06:41 AM

Hi everyone!
I've got jb4 on my 440i and I installed *** less down p1pe. Then I see drivetrain error light. So how can I avoid drivetrain error caused by my adds?
Reply With Quote
(#2)
Old
dRDiesel's Avatar
dRDiesel dRDiesel is offline
Junior Member
 
Posts: 235
Join Date: Apr 2018
Car: BMW
Default 03-20-2019, 08:40 AM

What map are you running?


| 2018 BMW 340i | M-Sport | Track Handling Package |
| Pure Stage 1 | MPE + ER down-pipe | BMS Intake | JB4 + MHD | BMS Meth Kit |
Reply With Quote
(#3)
Old
dysh.78 dysh.78 is offline
New Member
 
Posts: 12
Join Date: Dec 2018
Car: BMW 440i xdrive
Default 03-20-2019, 10:28 AM

Quote:
Originally Posted by dRDiesel
What map are you running?
Map 3
Reply With Quote
(#4)
Old
dysh.78 dysh.78 is offline
New Member
 
Posts: 12
Join Date: Dec 2018
Car: BMW 440i xdrive
Default 03-20-2019, 11:38 AM

This is my logs
Attached Files
File Type: csv 2019-03-20 21_29_15_Map-3.csv (10.4 KB, 23 views)
File Type: csv 2019-03-20 21_27_56_Map-3.csv (8.8 KB, 21 views)
Reply With Quote
(#5)
Old
MasterYous MasterYous is offline
BMW After BMW
 
Posts: 308
Join Date: Aug 2017
Car: BMW M240i
Default 03-21-2019, 02:51 PM

Quote:
Originally Posted by dysh.78
Hi everyone!
I've got jb4 on my 440i and I installed *** less down p1pe. Then I see drivetrain error light. So how can I avoid drivetrain error caused by my adds?
Flash your DME with an appropriate map. I don’t see how you’re going to avoid stuff like this since a JB4 can’t override o2 sensor programming. You can also ask BMS if the forthcoming B58 BEF will solve this - it depends on what terry puts into it.

You can probably live with the CEL.

Edit:just realized you’re talking about drivetrain errors. That should not related to the p1p3. Did you install the EWG connector? What happens when the error occurs? Do you go limp and lose boost?


2017 F23/M240i Convertible (B58) / 6MT / FF Wires / EWG Wires / BMS Air Intake / Stock Exhaust / BMS Meth (100%) / 93 Octane

Last edited by MasterYous; 03-21-2019 at 02:54 PM.. Reason: Made correction
Reply With Quote
(#6)
Old
dysh.78 dysh.78 is offline
New Member
 
Posts: 12
Join Date: Dec 2018
Car: BMW 440i xdrive
Default 03-21-2019, 03:31 PM

Quote:
Originally Posted by MasterYous
Flash your DME with an appropriate map. I don’t see how you’re going to avoid stuff like this since a JB4 can’t override o2 sensor programming. You can also ask BMS if the forthcoming B58 BEF will solve this - it depends on what terry puts into it.

You can probably live with the CEL.

Edit:just realized you’re talking about drivetrain errors. That should not related to the p1p3. Did you install the EWG connector? What happens when the error occurs? Do you go limp and lose boost?
I didn’t install EWG connector, because there is no ewg connector for b58 engine, if I’m not mistaken. I used JB4 app to indicate the error, it said smth like “downp1pe is detected”. Nothing happens except the light on dashboard.
Reply With Quote
(#7)
Old
MasterYous MasterYous is offline
BMW After BMW
 
Posts: 308
Join Date: Aug 2017
Car: BMW M240i
Default 03-21-2019, 03:40 PM

That doesn’t sound like a “true” drivetrain error, and yes there is an EWG connector for the B58; I run one and so does almost everyone else using meth.

Look around, most drivetrain errors occur because you crash the fuel pressure system or due to extreme overboost. A bad EWG connector can do it too (this one won’t be your issue).

Because you cross posted I got confused about your error. It’s common for CEL to occur with p1pes but a drivetrain error is odd. If you’re sure it’s csusing no side effects to boost, acceleration, etc, why not just ignore it?


2017 F23/M240i Convertible (B58) / 6MT / FF Wires / EWG Wires / BMS Air Intake / Stock Exhaust / BMS Meth (100%) / 93 Octane
Reply With Quote
(#8)
Old
dysh.78 dysh.78 is offline
New Member
 
Posts: 12
Join Date: Dec 2018
Car: BMW 440i xdrive
Default 03-21-2019, 03:51 PM

Quote:
Originally Posted by MasterYous
That doesn’t sound like a “true” drivetrain error, and yes there is an EWG connector for the B58; I run one and so does almost everyone else using meth.

Look around, most drivetrain errors occur because you crash the fuel pressure system or due to extreme overboost. A bad EWG connector can do it too (this one won’t be your issue).

Because you cross posted I got confused about your error. It’s common for CEL to occur with p1pes but a drivetrain error is odd. If you’re sure it’s csusing no side effects to boost, acceleration, etc, why not just ignore it?
Oh, yeah, maybe you’re right. So how can I solve overboost problem?
Edit: I got it, I have CEL because of downp1pe, and I had twice drivetrain error caused by overboost

Last edited by dysh.78; 03-21-2019 at 04:00 PM..
Reply With Quote
(#9)
Old
MasterYous MasterYous is offline
BMW After BMW
 
Posts: 308
Join Date: Aug 2017
Car: BMW M240i
Default 03-21-2019, 03:59 PM

I looked at your first log and don't see overboost. In fact, your boost is a little low for Map 3, but the log is pretty clean.


2017 F23/M240i Convertible (B58) / 6MT / FF Wires / EWG Wires / BMS Air Intake / Stock Exhaust / BMS Meth (100%) / 93 Octane
Reply With Quote
(#10)
Old
dysh.78 dysh.78 is offline
New Member
 
Posts: 12
Join Date: Dec 2018
Car: BMW 440i xdrive
Default 03-21-2019, 04:14 PM

Quote:
Originally Posted by MasterYous
I looked at your first log and don't see overboost. In fact, your boost is a little low for Map 3, but the log is pretty clean.
Do I need to install ewg connector to control overboot?
It's my first experience with jb4 and I want to configure it correctly
Reply With Quote
(#11)
Old
MasterYous MasterYous is offline
BMW After BMW
 
Posts: 308
Join Date: Aug 2017
Car: BMW M240i
Default 03-21-2019, 04:28 PM

Please just dig around on the b58 forum. There are varying levels of opinion on the EWG connector.


2017 F23/M240i Convertible (B58) / 6MT / FF Wires / EWG Wires / BMS Air Intake / Stock Exhaust / BMS Meth (100%) / 93 Octane
Reply With Quote
(#12)
Old
dysh.78 dysh.78 is offline
New Member
 
Posts: 12
Join Date: Dec 2018
Car: BMW 440i xdrive
Default 03-21-2019, 04:30 PM

Quote:
Originally Posted by MasterYous
Please just dig around on the b58 forum. There are varying levels of opinion on the EWG connector.
Thank you!
Reply With Quote
(#13)
Old
JBoe JBoe is offline
Junior Member
 
Posts: 263
Join Date: May 2018
Car: M240i
Default 03-24-2019, 09:33 PM

Map 3 is pretty aggressive for the M240i without higher Octane. Your trims are high and you have FOL at 60. (Assuming you have FF wires) This puts you in the zone for maxing out the fuel and hitting it's limiters. Generally, most have to stick with map 2 unless running race gas, octane booster or WMI.

The drivetrain errors are likely from 1st and 2nd gear given the boost levels. Try limiting boost in 1st to 12psi and 2nd to 14psi. If the errors go away, you can try raising one at a time until you get the error. Then lower it back down to just under the error. Most of us have had to do that, plus the car is pretty wild in 1st/2nd at higher levels. Makes more sense to keep control and be fast than to spin the tires and be slow. Unless you're into that sorta thing. lol.

For now, I think you need to be on Map 2 and provide some logs. You'll likely see trims come back into a better range and be able to lower FOL. This will make the car much more consistent. Also, what Octane fuel are you using and do you have the FF wires?
Attached Images
 
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2018, N54tech.com