N54Tech.com - International Turbo Racing Discussion
(#1)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default Half engine light but no codes - 12-03-2014, 09:18 PM

I've been getting half engine light at the end of my WOT pulls in 3rd gear.
It goes away after about 5 seconds and no codes are stored. I don't actually get reduced power, just the light that comes on and goes away after a few seconds. Does anyone have any idea why it is doing that? I've never had this issue before.

Mods are Jb4 and dci with 45-50% e85.

I know map 7 isn't recommended, but I was trying it out to see if I get the light on this map. Map 5 with less e85 gives me the half engine light as well.


Attached Images
 
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is online now
Tuner
 
Posts: 29,345
Join Date: Jan 2008
Default 12-03-2014, 09:23 PM

Sure auto clear is off?


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 12-03-2014, 09:25 PM

Yeah I made sure it was off.
Reply With Quote
(#4)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 12-04-2014, 02:32 PM

Just ordered the Fuel-it Stage 1 kit.
Putting the e85 flash on this weekend so I will also check for codes using the BT cable and see if anything pops up.
Reply With Quote
(#5)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 12-25-2014, 03:31 AM

Put the e85 backend flash on and installed Steveaz's stage 1 lpfp kit.
Still getting the half engine light at gear shift :/

Jb4 doesn't show any codes and neither does my BT cable software.
Attached Images
 
Reply With Quote
(#6)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 12-26-2014, 04:02 AM

Anyone..?
I can't be the only person experiencing this right?
Reply With Quote
(#7)
Old
Russell @ BMS's Avatar
Russell @ BMS Russell @ BMS is offline
Tuner
 
Posts: 5,673
Join Date: Nov 2008
Car: 2009 335i AT
Default 12-26-2014, 10:36 AM

Log looks good. Without a code.... no idea what the DME does not like.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#8)
Old
Levan-i's Avatar
Levan-i Levan-i is offline
Senior Member
 
Posts: 642
Join Date: Sep 2014
Car: 2007 BMW 335i E92
Default 12-27-2014, 11:02 PM

look at shadow codes with inpa?


2007 E92 335
ST - GTW3684
JB4 G5, ST Pump Flash, Fuel-It Stage 1, Meth
MT (after swap),
MFactory LSD
Reply With Quote
(#9)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 12-28-2014, 11:54 AM

I've checked the shadow codes as well. Nothing was stored.

Since it happens right after a shift, maybe its transmission related?
I do have the transmission flash done, but I've had it for over a year and this issue recently started happening.
Reply With Quote
(#10)
Old
mattjustus317 mattjustus317 is offline
New Member
 
Posts: 3
Join Date: Mar 2015
Car: 2008 bmw 135i
Default 03-25-2015, 02:34 PM

bump on this i know its been A while but I'm having the same thing only throws code when i shift from 3rd to 4th at like 5,500 rpm i have the juice box and a macbook so i haven't been able to log anything but it goes into limp mode, i plugged in obd2 and shows no code them when i turn the car on and off the engine light clears... help i can do it every single time without fail.
Reply With Quote
(#11)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 03-26-2015, 11:07 AM

Quote:
Originally Posted by mattjustus317
bump on this i know its been A while but I'm having the same thing only throws code when i shift from 3rd to 4th at like 5,500 rpm i have the juice box and a macbook so i haven't been able to log anything but it goes into limp mode, i plugged in obd2 and shows no code them when i turn the car on and off the engine light clears... help i can do it every single time without fail.
My issue only occurred when I was using the e85 backend flash.
As soon as I flashed to a custom flash it went away.

FYI, there is a 3rd party Jb4 program for macs.
Reply With Quote
(#12)
Old
mattjustus317 mattjustus317 is offline
New Member
 
Posts: 3
Join Date: Mar 2015
Car: 2008 bmw 135i
Default 03-26-2015, 04:00 PM

Quote:
Originally Posted by MasterWang
My issue only occurred when I was using the e85 backend flash.
As soon as I flashed to a custom flash it went away.

FYI, there is a 3rd party Jb4 program for macs.
i haven't been able to find the third party firmware could you help out?

and if i have a boost leak could that trigger it because it first happened when i blew off a front mount coupler but i thought i had it fixed but it just started happening again
Reply With Quote
(#13)
Old
AWSAWS's Avatar
AWSAWS AWSAWS is offline
Demigod
 
Posts: 1,524
Join Date: Aug 2014
Car: 335i MSport DCT
Default 03-27-2015, 09:51 AM

could try lowering the boost on gear changes...
Reply With Quote
(#14)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 05-20-2015, 01:49 PM

I put on Terry's latest e85 Backend flash yesterday and this issue came back immediately :/

Here are my logs from yesterday.
Latest Backend flash and Jb4 firmware ISO_29.
Jb4 G5 ISO, DCI, 255 inline, e70-e75, e85 backend flash, map 7.
Attached Files
File Type: csv 2015-05-19 20_37_46golfvd.csv (49.9 KB, 99 views)
File Type: csv 2015-05-19 20_38_21vd.csv (16.0 KB, 94 views)
File Type: csv 2015-05-19 20_40_50vd.csv (12.5 KB, 94 views)
File Type: csv 2015-05-19 20_42_13vd.csv (17.5 KB, 95 views)
Reply With Quote
(#15)
Old
CHECKERED's Avatar
CHECKERED CHECKERED is offline
ex deus machina
 
Posts: 3,411
Join Date: Sep 2013
Car: E92 N54 335i
Default 05-20-2015, 01:58 PM

set boost fail safe to 21, since there is some overboost post shift


Garage Queen: Audi S4 4.2L V8, Vortech Supercharger, Bilstein PSS9 Coilovers, Sway-bars, RS4 brakes and rear BBK, Fast Intentions - Full Exhaust, 505AWTQ 0-60: 3.8s
Daily Driver: E92 335i N54: complete part out - let me know of any parts you need:

https://www.n54tech.com/forums/showthread.php?t=55650
Reply With Quote
(#16)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 05-20-2015, 04:48 PM

Tried boost fail safe @ 21 today, didn't work.
Reply With Quote
(#17)
Old
CHECKERED's Avatar
CHECKERED CHECKERED is offline
ex deus machina
 
Posts: 3,411
Join Date: Sep 2013
Car: E92 N54 335i
Default 05-20-2015, 05:03 PM

I think the DV you have are sticking and not venting sufficient boost,


Garage Queen: Audi S4 4.2L V8, Vortech Supercharger, Bilstein PSS9 Coilovers, Sway-bars, RS4 brakes and rear BBK, Fast Intentions - Full Exhaust, 505AWTQ 0-60: 3.8s
Daily Driver: E92 335i N54: complete part out - let me know of any parts you need:

https://www.n54tech.com/forums/showthread.php?t=55650
Reply With Quote
(#18)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,440
Join Date: Oct 2012
Car: 135i
Default 05-20-2015, 06:16 PM

Turn off code clearing and see what the code is.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#19)
Old
MasterWang MasterWang is offline
Junior Member
 
Posts: 78
Join Date: May 2013
Car: 2007 335i e92
Default 05-20-2015, 09:32 PM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
Turn off code clearing and see what the code is.
Code clearing is off.
Here is a video I took today. Can't really see the screen I guess, but the only code I had was the golf tee mod one.

Reply With Quote
(#20)
Old
bmartynowicz bmartynowicz is offline
New Member
 
Posts: 1
Join Date: Apr 2017
Car: 335ix
Default 04-27-2017, 02:22 PM

I know this post is old, but I am having the same thing happen to me AND I have almost the same configuration. I have a COBB charge pipe, and JB4 w/ DCI. About to put some exhaust on but the car is behaving weird.
Reply With Quote
(#21)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,440
Join Date: Oct 2012
Car: 135i
Default 04-27-2017, 09:14 PM

I'd suggest starting your own support thread and posting logs.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com