N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Nicky92's Avatar
Nicky92 Nicky92 is offline
Junior Member
 
Posts: 278
Join Date: Jul 2014
Car: 2008 335i
Default Water pump constantly running..just replaced it too - 04-19-2016, 09:51 PM

Had this problem where the water pump was running when the car was cold. Had 60k on the pump so I replaced it and the t-stat.

Did the job. Plugged the battery back in......... anddddd

ITS DOING THE SAME THING.

The pump is just running non stop. I can hear the coolant circulating. This is ridiculous.

and no one around has had this problem so I'm not getting anywhere with it lol. Looks like im off to bmw?

WONDERFUL


335- stock
Reply With Quote
(#2)
Old
veee8's Avatar
veee8 veee8 is offline
Junior Member
 
Posts: 37
Join Date: Apr 2015
Car: BMW
Default 04-20-2016, 08:34 AM

Did you check to see if any codes were stored that need to be cleared?
Reply With Quote
(#3)
Old
Nicky92's Avatar
Nicky92 Nicky92 is offline
Junior Member
 
Posts: 278
Join Date: Jul 2014
Car: 2008 335i
Default 04-20-2016, 12:21 PM

Quote:
Originally Posted by veee8
Did you check to see if any codes were stored that need to be cleared?
Yes. No codes. Cleared shadow codes on BT as well. No water pump codes before or after replacement


335- stock
Reply With Quote
(#4)
Old
speedhunter93 speedhunter93 is offline
New Member
 
Posts: 18
Join Date: Oct 2015
Car: 335i Coupe
Default 08-03-2016, 01:32 PM

Did you ever solve the problem?
Reply With Quote
(#5)
Old
Nicky92's Avatar
Nicky92 Nicky92 is offline
Junior Member
 
Posts: 278
Join Date: Jul 2014
Car: 2008 335i
Default 08-03-2016, 01:42 PM

Nope, it's crazy.


335- stock
Reply With Quote
(#6)
Old
Nitrousbird Nitrousbird is offline
Junior Member
 
Posts: 116
Join Date: Jun 2015
Car: '07 335i 6MT
Default 08-03-2016, 04:29 PM

My water pump failed by running all the time, regardless of if the car was on or off. Has to disconnect the battery to stop it.

I have heard of a new one out of the box doing the same thing.
Reply With Quote
(#7)
Old
Milan's Avatar
Milan Milan is offline
Senior Member
 
Posts: 785
Join Date: Sep 2014
Car: 08 335xi
Default 08-03-2016, 07:01 PM

I think it's a DME issue when this happens. Search the other forum there is some info on it


09 335 - 6266
07 335i - 6870, E85 - SOLD
08 335xi - 6466, custom direct port meth - SOLD
Reply With Quote
(#8)
Old
Jsr1256 Jsr1256 is offline
Junior Member
 
Posts: 322
Join Date: Apr 2016
Car: 08 335i Sport Package
Default 08-05-2016, 02:16 PM

Do u have the max cool mode on in the jb4? Or does it run 24/7


08 E92 335i AT 20k Miles | Wedge E60 Flash| E85 | VRSF FMIC | VRSF Lower Charge Pipe | ER Charge Pipe|Tial Bov| Vrsf *** | DCI | IC Sprayer | Scoops | NGK 1 Range Colder Plugs | Fuel It LPFP | E60 | [12.2 @ 118with e85 flash] [ My E60 flash 1/4 = 11.8 @ 120
|
Reply With Quote
(#9)
Old
InsipidMonkey InsipidMonkey is offline
New Member
 
Posts: 10
Join Date: Nov 2014
Car: 08 E61
Default 08-05-2016, 02:42 PM

Did you purge the cooling system properly after replacing the T-stat? There is a special procedure for bleeding the cooling system with the electric water pump. Something about holding the pedal down with the system set to full heat in ACC mode (engine off)? I can dig it up if you can't find it with a search.
Reply With Quote
(#10)
Old
N54luvr N54luvr is offline
Junior Member
 
Posts: 51
Join Date: Jun 2015
Car: 2010 335i xdrive
Default 08-06-2016, 03:40 PM

Your max cool is set on your JB4, turn it off and back to normal voila.
Reply With Quote
(#11)
Old
Nicky92's Avatar
Nicky92 Nicky92 is offline
Junior Member
 
Posts: 278
Join Date: Jul 2014
Car: 2008 335i
Default 08-13-2016, 07:47 PM

It's not mad cool. And yes I bled the system.
It's something with the DME


335- stock
Reply With Quote
(#12)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 18,440
Join Date: Oct 2012
Car: 135i
Default 08-15-2016, 08:43 AM

If your DME sees an issue with your AFR's, fueling is stuck in open loop, or something similar, your fan and pump will run 100%.



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2018, N54tech.com