N54Tech.com - International Turbo Racing Discussion
(#1)
Old
Evo8urcar Evo8urcar is offline
New Member
 
Posts: 14
Join Date: Jan 2016
Car: 335i 6MT 6466 / Evo 8 2.4LR 6266
Default Opinons on HPFP or LPFP issue / log inside - 01-11-2016, 07:16 PM

Hey guys,

Just picked up a 335i 6MT 6466 FFtech kit w/ 255 inline and JB4 (index 12 injectors and coils are newer as well) from a buddy of mine and the car decided to go into limp mode and shoot the 29DC code. It was on ST map 2. So I restarted the car and logged it on map 1 (WG pressure). It is obvious that the HPFP is dying off as RPMS increase. I read that the low pressure should be at 50psi or better and I am not sure if it would be less having the inline 255 in it as the pump is down around 25psi up top before I let off.

I am completely new to the N54 platfrom and I am still learning how the software and these motors like to operate and I am looking for some advice from some seasoned n54 guys. This is my daily so hoping to fix this issue soon.

Thanks,

Doug
Attached Images
 
Attached Files
File Type: csv 3rd gear pull.csv (5.3 KB, 128 views)
Reply With Quote
(#2)
Old
Evo8urcar Evo8urcar is offline
New Member
 
Posts: 14
Join Date: Jan 2016
Car: 335i 6MT 6466 / Evo 8 2.4LR 6266
Default 01-11-2016, 07:28 PM

Mods please move to technical forum if that is where it should be....still learning to navigate this forum.

Thanks,
Reply With Quote
(#3)
Old
Evo8urcar Evo8urcar is offline
New Member
 
Posts: 14
Join Date: Jan 2016
Car: 335i 6MT 6466 / Evo 8 2.4LR 6266
Default 01-12-2016, 09:22 AM

So i did some viewing on my way to work of the AFR and AFR2 and noticed that at idle the AFR fluctuates pretty normally in the 14 range where AFR2 sites at 20. Then while driving the AFR2 remains intermittent as sometimes while cruising or giving it gas it will leave the 20 and head back down to 15-16 then back to 20 an other times it just stays at 20. Now in my experience when a wideband sensor fails it will usually just read 20 and not fluctuate but I am leaning toward the AFR2 sensor being bad as I did pull the 2C78 code once last night when I got the 29DC.

Also the HPFP is @ 5 and LPFP is @ 45 at idle and cruise and if I give it a bit of gas to get to 0 or positive pressure the HPFP does start ramping up to 11 on the logger. This also makes me suspect the HPFP may be fine and I may need the LPFP and a wideband.

Any opinions??

Thanks,
Reply With Quote
(#4)
Old
AWSAWS's Avatar
AWSAWS AWSAWS is offline
Demigod
 
Posts: 1,525
Join Date: Aug 2014
Car: 335i MSport DCT
Default 01-12-2016, 09:39 AM

Log does look like lpf is too low and AFRs appear to be too rich, probably as a result.
Also boost is well below target for a good while. Also probably due to fuelling but I don't know what effect a 255 inline pump has on logs, due to voltage being read.


UK FBO 335i, GCs, JB4, PI meth, BMS CP, OCC, Braided brake lines. Diff Lockdown. TMAP sensor, custom bucketless stage2

11.79@119mph on stockers, CP meth (UK, Santa Pod)
11.74@129mph on GCs, custom port meth injection.
Reply With Quote
(#5)
Old
Evo8urcar Evo8urcar is offline
New Member
 
Posts: 14
Join Date: Jan 2016
Car: 335i 6MT 6466 / Evo 8 2.4LR 6266
Default 01-12-2016, 09:42 AM

Thanks for the response. The trims do not look off unless I am reading it wrong because my first thought to your response is that if it looks rich it could be that the rear wideband is reading lean due to failing causing the ecu to think it needs more fuel.

I saw the target is off early in the rev but I do not see the 6466 reaching that target boost so early and can only assume the map is set that way to allow the quickest spool possible. But I could be wrong. I come from the Evo and Rx7 world and those are completely different animals when it comes to tuning than a 335i.

Thanks again.
Reply With Quote
(#6)
Old
AWSAWS's Avatar
AWSAWS AWSAWS is offline
Demigod
 
Posts: 1,525
Join Date: Aug 2014
Car: 335i MSport DCT
Default 01-12-2016, 09:44 AM

Sorry my mistake. I meant too much air. Too little fueling.

It's lean. I got distracted.

That's why trims are 30's


UK FBO 335i, GCs, JB4, PI meth, BMS CP, OCC, Braided brake lines. Diff Lockdown. TMAP sensor, custom bucketless stage2

11.79@119mph on stockers, CP meth (UK, Santa Pod)
11.74@129mph on GCs, custom port meth injection.
Reply With Quote
(#7)
Old
Evo8urcar Evo8urcar is offline
New Member
 
Posts: 14
Join Date: Jan 2016
Car: 335i 6MT 6466 / Evo 8 2.4LR 6266
Default 01-12-2016, 09:47 AM

lol...I had to double take the log again as it didn't make sense. You can see the LPFP is never over 50psi and the HPFP is fine at first and then tanks when the LPFP start tanking. I am leaning towards a LPFP. I have a 450 walbro I took out of my Evo I a may give it a shot and put it in the tank. I will wait for some more feed back as I think the AFR2 is bad as well. The log doesn't show it looking bad but regular driving it is intermittent.

This map is map 1 and only on wastegate pressure, more boost faster spool so I am not too concerned that it isn't hitting boost target before 3k. hit seems perfect once it hits full boost though.

Thanks again.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com