JB4tech.com - International Turbo Tuning Discussion
(#1)
Old
Pheret Pheret is offline
Junior Member
 
Posts: 43
Join Date: Feb 2015
Car: 2007 e92 6mt
Default 2007 e92 n54 battery drain, fuse 58 - 08-08-2021, 04:01 PM

Hello all,
Been struggling with a battery drain on my 2007 e92 n54 FBO. I've traced it down to fuse 58. I'm drawing 1.45a with the 7.5a fuse in and 0.01ish with it out. The fuse, based on the diagrams I've found, is for instrument cluster and obd port. I have nothing plugged into the port and I'm not really sure what to check other than that. Everything still works as intended but something is causing it to draw a lot of amperage well after the car is in sleep mode.

A little direction on where to check would be appreciated, I haven't been able to find much on f58 other than people having the fuse blow.

Car mods should be in signature.


2007 SGM E92 335i 6MT | 107k | DCI | Charge Pipe/ BOV | C@TL3SS DP | ETS 7" IC | Walbro 255 Inline LPFP| JB4 G5 ISO | E85 BEF |
Reply With Quote
(#2)
Old
Steve @ BMS/Fuel-It!'s Avatar
Steve @ BMS/Fuel-It! Steve @ BMS/Fuel-It! is offline
Tuner
 
Posts: 21,115
Join Date: Oct 2012
Car: 135i
Default 08-09-2021, 09:24 AM

I doubt it's the JB4 but have you confirmed you're running the latest JB4 firmware?



Click on our banner to visit our website!
Video of our Stage 2 LPFP upgrade installation.

BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways.
Reply With Quote
(#3)
Old
Pheret Pheret is offline
Junior Member
 
Posts: 43
Join Date: Feb 2015
Car: 2007 e92 6mt
Default 08-09-2021, 09:31 AM

Quote:
Originally Posted by Steve @ BMS/Fuel-It!
I doubt it's the JB4 but have you confirmed you're running the latest JB4 firmware?
According to my jb4 app, which isn't currently connected to the car, it's 32/14//2. I'll double check and update when I get home.


2007 SGM E92 335i 6MT | 107k | DCI | Charge Pipe/ BOV | C@TL3SS DP | ETS 7" IC | Walbro 255 Inline LPFP| JB4 G5 ISO | E85 BEF |
Reply With Quote
(#4)
Old
Pheret Pheret is offline
Junior Member
 
Posts: 43
Join Date: Feb 2015
Car: 2007 e92 6mt
Default 08-24-2021, 03:03 PM

Updated jb4 just in case.
Turns out it was my gauge cluster. I found another at a pull n pay but obviously it's not meat for my car. I'll have to code the mpg to oil temp (I swapped the faces) and then find a way to deal with the eeprom to get rid of the mileage tampering dot.


2007 SGM E92 335i 6MT | 107k | DCI | Charge Pipe/ BOV | C@TL3SS DP | ETS 7" IC | Walbro 255 Inline LPFP| JB4 G5 ISO | E85 BEF |
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2022, JB4tech.com