N54Tech.com - International Turbo Racing Discussion
(#1)
Old
ToolMaker335xi ToolMaker335xi is offline
Junior Member
 
Posts: 33
Join Date: May 2018
Car: E92 335xi manual
Default A Few rookie questions - 04-17-2019, 12:17 AM

Hi everyone, just a few questions before I go full throttle in the car.

First off, mods done: set of RB 2ís, RB inlets, BMS DCI, 7.5Ē FMIC, CP ( both Phoenix. Full 3Ē from IC to intake manifold)TIAL BOV, VRSF DPís, Borla straight back the rest of the way, BMS OCC, and JB4.

After getting everything back together, got it fired up. Everything seems all good, except now Iím smoking! Iíve ran the car for about 200 miles, couldnít tell if it smoked right off the bat since it was still cold out the first time running the car. It only smokes when coming to a stop at idle for about 3-7 secs, or if I rev it up over 2500 and it comes back to idle, it will smoke for a few sec. Brand new turbos, so I doubt itís seals, I did fill lines as much as I could with oil when putting on and started and shut off the car immediately the first time firing up before running. Is this smoke normal with brand new turbos? It doesnít appear to be blue but white. Could this be from the car not having a tune and itís excess fuel being dumped? Pcv valve seemed ok, flapper was free. Smoke is from both sides of exhaust and very moderately thick.

What settings should I have Jb4 set to for my first log with this setup? Is it safe to go WOT with it smoking like this? The three conclusions I could find are: put cats back on, get used to it, or buy new turbos.

Last time I checked codes, the only ones were for no cats, not sure off the top of my head what they were. I only have Bavarian technic cable for diagnosing. Is there anything I can look for with this?

Thanks In advance
Reply With Quote
(#2)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 522
Join Date: Jun 2017
Car: 07 E90 335i
Default 04-17-2019, 08:04 AM

Did you prime the turbos before starting the car?

Did you replace your oil drain lines?

Is your pcv system refreshed? PCV valve, Flapper valve, Valve cover....

Could have excessive pressure in you crankcase which may prevent adequate oil drain


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#3)
Old
ToolMaker335xi ToolMaker335xi is offline
Junior Member
 
Posts: 33
Join Date: May 2018
Car: E92 335xi manual
Default 04-17-2019, 11:44 PM

Did not prime was my mistake. Read multiple times that it wasnít necessary. PCV wasnít replaced, flapper was free. Valve cover gasket needs done. Planned on doing VCG, OFHG, and walnut blasting over the holiday weekend.

Been having trouble getting B.B. Flash to recognize the car to do the BEF. I couldnít tell the last few times the car ran if it was definitely oil burning cause it still had wierd smells from brand new exhaust. Was cold out and had a lot of condensation so couldnít tell if it was blue or not. Started the car today in nice weather. No smoke while cold. Let it warm up, held rpms around 1300 started to very lightly smoke. Gets moderate a sec after idling down for a couple secs.

Just going to let it go for now. I wasnít sure what the smoke was at first and was curious if it could be from the car not being tuned. Iím just going to assume for now that I damaged the turbo seals on startup and just hope they hold up for a year or so, till Iím ready to take it all apart again. Iíll update if VCG has any effect after being changed. It is leaking pretty bad on the exhaust side and smoking under the hood from it.

Used old return lines. Cleaned 3 separate times. Even tossed them in an ultra sonic cleaner at work, I made sure they were 100% clear since I was reusing.

Last edited by ToolMaker335xi; 04-17-2019 at 11:48 PM.. Reason: Oil lines
Reply With Quote
(#4)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 522
Join Date: Jun 2017
Car: 07 E90 335i
Default 04-18-2019, 10:24 PM

Is there oil in your catch can?


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#5)
Old
ToolMaker335xi ToolMaker335xi is offline
Junior Member
 
Posts: 33
Join Date: May 2018
Car: E92 335xi manual
Default 04-19-2019, 09:14 AM

No, it wasnít even installed till the other day. Wouldnít it only smoke from one side if that was the issue?

Iím going to run a camera thru the exhaust and see if I can see if itís turbos before I take them off. I knew I should have cranked the motor over without starting. But I read, specifically about PS2ís not needing primed because how fast these motors bring oil pressure up, and because oil is left in them from balancing itís not necessary. Just a really dumb mistake on my part. When I first posted I was not able to tell whether it was oil or something else burning.
Reply With Quote
(#6)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 522
Join Date: Jun 2017
Car: 07 E90 335i
Default 04-19-2019, 02:56 PM

probably to much pressure in your crankcase. oil can't drain against the pressure. need to find the cause. or maybe run an external PCV system


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#7)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,723
Join Date: Apr 2014
Car: E92 335XI
Default 04-20-2019, 05:35 PM

Are you losing any oil?



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#8)
Old
JuniorB JuniorB is offline
Junior Member
 
Posts: 342
Join Date: Mar 2016
Car: 2007 e60 5 series
Default 04-21-2019, 01:43 PM

You stated new turbos, were the old ones leaking oil, does it smell like oil or fuel, without cats, the exhaust will be full of contamination from lack of CaTs. Depending how the install went, clogged drains will back oil into turbos, so that seems unlikely. If you haven’t done a pvc, replace or do the cc to eliminate this.
Reply With Quote
(#9)
Old
ToolMaker335xi ToolMaker335xi is offline
Junior Member
 
Posts: 33
Join Date: May 2018
Car: E92 335xi manual
Default 04-22-2019, 02:58 AM

I have lost some oil. Only drove the car about 300 miles and itís dropped one bar on the display already.

Thanks for the input, Iíll start looking into replacing or deleting pcv when I do the valve cover gasket.
Reply With Quote
(#10)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is offline
Super Moderator
 
Posts: 5,723
Join Date: Apr 2014
Car: E92 335XI
Default 04-23-2019, 12:33 AM

Quote:
Originally Posted by ToolMaker335xi
I have lost some oil. Only drove the car about 300 miles and itís dropped one bar on the display already.

Thanks for the input, Iíll start looking into replacing or deleting pcv when I do the valve cover gasket.
May be worth shooting Rb an e-mail as well.



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2019, N54tech.com