N54Tech.com - International Turbo Racing Discussion
(#1)
Old
paulkane paulkane is offline
New Member
 
Posts: 4
Join Date: May 2017
Car: 2010 N54 135i E82
Default Terry: N54 Advice needed Code 2D2E - 07-13-2017, 01:23 AM

2009 E82 135i N54

I'm no tuner - so please be patient with me.

Mods done: -
  • down-pip-es done (keeps rejecting that word?)
  • BMC Air Filter in OEM intake
  • Boostpipe with Tial Blowoff valve - plumbed back into front turbo air intake.
  • Latest JB4 with bluetooth adapter and app from BMS

General Notes: -
  • has 6 brand new series 12 injectors installed and coded
  • Brand new Plugs and Coils
  • Brand New Battery
  • ECU is a stock standard OEM flash (no back-end flash)

Whats been happening (under map 0): -
  • throttle / boost was very jumpy especially around midrange (3000 rpm)
  • Under smooth / mild acceleration it was like all of a sudden you would get a surge of acceleration as if you had pressed your foot down suddenly (this seems to happen around 2500-3000 rpm
  • Cruising in top gear using Cruise Control at around 120kph (75-80mph) - when you hit an uphill the intervention of the cruise control is jumpy with jerky throttle/boost.
  • Car (intermittently) shows the code 2D2E at that midrange and has shown that code at cold start once.
  • Everything feels ok at full throttle?

I need some help to problem solve this issue and any advice would be appreciated. I suspected that maybe someone previously might have fiddled with the ECU coding and I had it flashed back to stock to be sure it wasn't an underlying ECU coding issue.

If you want me to upload a log - please if you could give me some advice in that regard.
Reply With Quote
(#2)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 29,730
Join Date: Jan 2008
Default 07-13-2017, 02:20 PM

2D2E is just a tuner plausibility fault, from having menu10 and/or menu12 cranked a little too high, which causes extra boost in front of the partially closed throttle, improving response, but can trigger that shadow fault.

You may need to lower those menus. I'd start by lowering menu10 to 2000rpm.


Burger Motorsports
Home of the Worlds fastest N20s, N54s, N55s, S55s, N63s, and S63s!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3)
Old
paulkane paulkane is offline
New Member
 
Posts: 4
Join Date: May 2017
Car: 2010 N54 135i E82
Default 07-14-2017, 12:10 AM

Thanks. From reading your reply and the JB4 Menu summary - it certainly points to Menu 12 - the description of "oscillation and strange behaviour" is a good description of what I am experiencing with the car under low throttle.

My Menu 10 was set to 3000 - i took it down to 2000.
My Menu 12 was set to 2700.

Ok - so a couple of questions:-
  • Are these menu's influencing the wastegates for all menu's including Menu 0?
  • Menu 10 range (0-5000rpm) - can you tell me what the operation is? i.e. what is happening with the wastegates if set to zero rpm vs 5000rpm. or what is different between the 3000 setting and the 2000 setting?
  • Menu 12 range - suggested is 2400-2800 - which is quite a narrow range. If I am experiencing oscillation under low throttle at 2700 setting - do i work up or down and whats the difference?
Reply With Quote
(#4)
Old
paulkane paulkane is offline
New Member
 
Posts: 4
Join Date: May 2017
Car: 2010 N54 135i E82
Default 07-14-2017, 12:57 AM

One last question - the 2D2E code - described as "Angle of Throttle valve - intake pipe underpressure, correlation". The word "underpressure" implies that the code relates to the intake pressure being below the expected pressure relative to the throttle position.

Q: Does this code throw when the intake pressure is BOTH above or below its expected pressure level for a given throttle position?
Q: Would this code also throw if you had a boost leak?
Reply With Quote
(#5)
Old
pepper135i pepper135i is offline
Junior Member
 
Posts: 89
Join Date: Mar 2014
Car: 135
Default 07-14-2017, 03:37 AM

Quote:
Originally Posted by paulkane
Thanks. From reading your reply and the JB4 Menu summary - it certainly points to Menu 12 - the description of "oscillation and strange behaviour" is a good description of what I am experiencing with the car under low throttle.

My Menu 10 was set to 3000 - i took it down to 2000.
My Menu 12 was set to 2700.

Ok - so a couple of questions:-
  • Are these menu's influencing the wastegates for all menu's including Menu 0?
  • Menu 10 range (0-5000rpm) - can you tell me what the operation is? i.e. what is happening with the wastegates if set to zero rpm vs 5000rpm. or what is different between the 3000 setting and the 2000 setting?
  • Menu 12 range - suggested is 2400-2800 - which is quite a narrow range. If I am experiencing oscillation under low throttle at 2700 setting - do i work up or down and whats the difference?

I also had the same issue , hoping to get some more info . I backed menu 12 down a bit but same issue . I'll adjust menu 10 and give it a shot
Reply With Quote
(#6)
Old
jk308 jk308 is offline
New Member
 
Posts: 1
Join Date: Nov 2017
Car: 2008 335xi e92
Default 02-21-2018, 11:00 AM

I am having the exact same issues at the same engine speeds. I have backed menus 10 and 12 down to 2000 with no resolution. I'll play with these menus a bit more and see if it makes a difference.
Reply With Quote
(#7)
Old
z4s4 z4s4 is offline
New Member
 
Posts: 1
Join Date: Jun 2014
Car: 2011 Z4 35is
Default 04-21-2018, 07:56 AM

Having the same problems listed above on JB4 or stock, has anyone found a solution or other checks to try?
Tried the JB4 adjustments above but no luck. Resetting the ECU fixes but slowly returns. Was able to still get it smogged in this condition. Replaced many parts/sensors, getting expensive
Reply With Quote
(#8)
Old
Paddy Paddy is offline
New Member
 
Posts: 24
Join Date: Nov 2016
Car: E91 335i
Default 07-01-2018, 01:36 PM

Sorry for the thread revival here, like the op I'm totally new to tuning, and am also getting the 2D2E code. My question is, how or where do I find the menu 10 and menu 12 to make the adjustments?
Reply With Quote
(#9)
Old
Haynpunch's Avatar
Haynpunch Haynpunch is offline
Senior Member
 
Posts: 522
Join Date: Jun 2017
Car: 07 E90 335i
Default 07-01-2018, 02:21 PM

Quote:
Originally Posted by Paddy
Sorry for the thread revival here, like the op I'm totally new to tuning, and am also getting the 2D2E code. My question is, how or where do I find the menu 10 and menu 12 to make the adjustments?


http://www.n54tech.com/forums/showthread.php?t=10605
Wheel Control Guide in Post #3

https://www.youtube.com/watch?v=HDjD4OcDIGU


07 E90 AT - xHP
JB4 G5 - Trebila BEF
FBO
Hybrids
Reply With Quote
(#10)
Old
Dave @ BMS/Fuel-It!'s Avatar
Dave @ BMS/Fuel-It! Dave @ BMS/Fuel-It! is online now
Super Moderator
 
Posts: 5,743
Join Date: Apr 2014
Car: E92 335XI
Default 07-01-2018, 09:17 PM

Quote:
Originally Posted by Haynpunch
Thank you for the assistance



http://www.fuel-it.biz/

e92 AT 335xi 2.0
Doc Race Kit 6062
Fuel-It!Platinum DIY PI Kit + Stage 2BL
Reply With Quote
(#11)
Old
mr68gts mr68gts is offline
New Member
 
Posts: 1
Join Date: Dec 2018
Car: 09 335i
Default 12-22-2018, 10:31 AM

Was this resolved by playing with menu 10 and 12 at all? I just installed a brand new jb4 last week and the same 2d2e code popped up on the way to Vegas from Phoenix. Part throttle on cruise at 65 was jerky as described above. (Holiday weekend so speed limit was word of the day) Turn cruise off and it's fine.
I'm going to play with 10 and 12 menus and see if that solves it.
I did clear the code and it didn't come back.
Paul
Reply With Quote
(#12)
Old
Chunky Osiris's Avatar
Chunky Osiris Chunky Osiris is offline
1Lover
 
Posts: 29
Join Date: Jun 2017
Car: 2008 135i MSport PPK - FBO - MHD Tune
Send a message via Skype™ to Chunky Osiris
Default 05-14-2019, 06:04 AM

When adjusting these settings on menus 10 and 12, do the changes take affect immediately or do I need to exit that menu or restart the car or something?
Reply With Quote
(#13)
Old
james008 james008 is offline
New Member
 
Posts: 7
Join Date: Feb 2013
Car: 09 335i M-Sport
Default 05-15-2019, 07:34 PM

Having throttle position problems. Jumps from about 9% up to 12% AFRs jump and Boost fluctuates while Accelerator pedal stays constant. Running MHD but does it flashed back to stock too. Only showed up in the last 2 weeks and gradually getting worse. Been running MHD for 2 years.

Cleaned throttle body and all sensors. Only code is 2D2E. Frustrating as the car has been running great besides this hiccup.

Resetting adaptations doesn't do anything, sometimes it's worse than others. Starting off in 1st from a standstill will provoke it. Cruising at any speed while throttle is around 9% might cause it other times it doesn't.

I have no experience tweaking tables just run MHD's maps.
Reply With Quote
(#14)
Old
Littlet_23 Littlet_23 is offline
New Member
 
Posts: 16
Join Date: Dec 2018
Car: E92 BMW 335I 2006
Default 06-10-2019, 09:35 AM

Did anyone solve this problem. How do you get did of code 2d2e?
Reply With Quote
(#15)
Old
jokers_greg jokers_greg is offline
New Member
 
Posts: 18
Join Date: May 2019
Car: 2007 E90 335i
Default 07-23-2019, 01:02 PM

little thread revival, feeling these symptoms some times and getting the code on occasion
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright 2007 - 2019, N54tech.com