N54Tech.com - International Turbo Racing Discussion
(#3051)
Old
Rs400newbie Rs400newbie is offline
Junior Member
 
Posts: 164
Join Date: Jul 2017
Car: Infiniti Q50 RS400
Default 10-03-2018, 05:11 PM

Quote:
Originally Posted by Terry @ BMS
Hopefully will have time this weekend to test fit these bad boys.
That looks good! We canít wait...any ballpark price?
Reply With Quote
(#3052)
Old
GSORS400 GSORS400 is offline
Junior Member
 
Posts: 36
Join Date: Sep 2017
Car: Q50 Red Sport
Default 10-03-2018, 07:04 PM

Quote:
Originally Posted by Nate0490
Hey Terry did you get a chance to look at my logs above?

Is there a good tutorial or YouTube video on what we should be looking for in reviewing them on our own? It would be nice if BMS could create a YT video if there isnt one already. Thanks.
check this out for some detail on parameters: https://www.n54tech.com/forums/showthread.php?t=21269
Reply With Quote
(#3053)
Old
LsRamAir LsRamAir is offline
New Member
 
Posts: 18
Join Date: Apr 2018
Car: '18 Q50 RS AWD
Default 10-03-2018, 08:33 PM

Quote:
Originally Posted by Nate0490
Cool. What do you look at to determine that more octane would help? Do any off the shelf octane boosters do any good? Trying to learn here so I dont have to bother you every time!

Torco has worked well for me for the past 7 years. Half can to a full tank helps to get octane from 91 to about 94 here in crap gas California. Really helps minimize the timing dips.

Can get 6 cans, so 12 tanks worth, for about $120 shipped on Amazon. Cheapest worthwhile fix I've found.

Although the cans aren't pour friendly... Dunno what the manufacturers deal is with that. I have to keep a lil funnel and pour spout bottle handy.


2018 Q50 RS400 AWD (w/Sport Mufflers)

Loving the ride...
Reply With Quote
(#3054)
Old
g0t2bmiirii's Avatar
g0t2bmiirii g0t2bmiirii is offline
Junior Member
 
Posts: 383
Join Date: Jun 2017
Car: 2017 Q50 3.0t (300hp) AWD
Default 10-03-2018, 11:26 PM

Quote:
Originally Posted by Terry @ BMS
Hopefully will have time this weekend to test fit these bad boys.
What is this for? And what are the benefits??


2017 Q50 3.0t Silver Sport (AWD)
Reply With Quote
(#3055)
Old
EsTee EsTee is offline
New Member
 
Posts: 18
Join Date: Oct 2018
Car: Q
Default 10-04-2018, 01:02 AM

Quote:
Originally Posted by Boxy
At the time I noticed those issues I was actually running higher boost, around 20 psi lol. I don't push that high anymore but that's what I was getting at.

Still don't understand why my AFR shoots to 21+ while ECU is in lean spool mode though... Terry mentioned above it's supposed to be near stoich but also said my logs look fine.
What are your settings? you might want to back off of boost during lean spool range then, if you are not comfortable.
Reply With Quote
(#3056)
Old
EsTee EsTee is offline
New Member
 
Posts: 18
Join Date: Oct 2018
Car: Q
Default 10-04-2018, 01:09 AM

Here are a couple of 0-60 JB times courtesy of Dragy on my 18' Q50 RS AWD:

- Stock : 4.79
- +4.5 : 4.43

Note: this is 0-60mph with NO brake torqueing

Mods : FBO (Intake + Exhaust + Gutted LDP)

I am actually currently tuned, but have been playing with the JB1 experimenting with it. Very impressed so far and a great bang for the buck!
Reply With Quote
(#3057)
Old
QFitty's Avatar
QFitty QFitty is offline
Junior Member
 
Posts: 108
Join Date: Dec 2017
Car: 2016 Q50 Red Sport
Default 10-04-2018, 03:26 AM

Quote:
Originally Posted by Terry @ BMS
Hopefully will have time this weekend to test fit these bad boys.
I assume these will compliment the intakes you have. The dyno will help prove their ability.


2016 Q50 Red Sport
Ecutek tuned
Infiniti Sport Mufflers
Reply With Quote
(#3058)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,560
Join Date: Jan 2008
Default 10-04-2018, 07:46 AM

Quote:
Originally Posted by EsTee
Here are a couple of 0-60 JB times courtesy of Dragy on my 18' Q50 RS AWD:

- Stock : 4.79
- +4.5 : 4.43

Note: this is 0-60mph with NO brake torqueing

Mods : FBO (Intake + Exhaust + Gutted LDP)

I am actually currently tuned, but have been playing with the JB1 experimenting with it. Very impressed so far and a great bang for the buck!
Wow nice gains!! Brake torque the crap out of it next time to see if it helps!


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3059)
Old
5oh_mo 5oh_mo is offline
New Member
 
Posts: 21
Join Date: Dec 2017
Car: Q50
Default 10-04-2018, 09:15 AM

@Terry

Can you explain the benefits of the post MAF silicone hose prototype for us? I have an idea, but I bet you will explain it better.


17' Q50 RS
Reply With Quote
(#3060)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,560
Join Date: Jan 2008
Default 10-04-2018, 09:58 AM

We'll have to see how fitment and testing goes as we haven't really tested them ourselves. In theory may improve spool and low boost response.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3061)
Old
EsTee EsTee is offline
New Member
 
Posts: 18
Join Date: Oct 2018
Car: Q
Default 10-04-2018, 01:44 PM

Quote:
Originally Posted by Terry @ BMS
We'll have to see how fitment and testing goes as we haven't really tested them ourselves. In theory may improve spool and low boost response.
yup, as well as hold higher boost for the same given turbo speed! Win, win, win...

(this is a similar post maf turbo hose compared against the stock accordion hose).
Attached Images
 
Reply With Quote
(#3062)
Old
Swamp801 Swamp801 is offline
New Member
 
Posts: 11
Join Date: Sep 2018
Car: 2018 Infiniti Q50 Luxe 3.0t
Default 10-06-2018, 12:39 AM

@Terry

Can you check these logs and see how they look.
Attached Files
File Type: csv 2018-10-06 01_24_38Map_6.csv (8.6 KB, 117 views)
File Type: csv 2018-10-06 01_26_30Map_5.csv (7.5 KB, 118 views)
Reply With Quote
(#3063)
Old
Terry @ BMS's Avatar
Terry @ BMS Terry @ BMS is offline
Tuner
 
Posts: 32,560
Join Date: Jan 2008
Default 10-06-2018, 11:52 AM

Looks clean to me. I tend to like map5.


Burger Motorsports
Home of the JB4 the worlds most popular turbocharged tuning system!

It is the sole responsibility of the purchaser and installer of any BMS part to employ the correct installation techniques required to ensure the proper operation of BMS parts, and BMS disclaims any and all liability for any part failure due to improper installation or use. It is the sole responsibility of the customer to verify that the use of their vehicle and items purchased comply with federal, state and local regulations. BMS claims no legal federal, state or local certification concerning pollution controlled motor vehicles or mandated emissions requirements. BMS products labeled for use only in competition racing vehicles may only be used on competition racing vehicles operated exclusively on a closed course in conjunction with a sanctioned racing event, in accordance with all federal and state laws, and may never be operated on public roads/highways. Please click here for more information on legal requirements related to use of BMS parts.
Reply With Quote
(#3064)
Old
Q50GotSauce Q50GotSauce is offline
New Member
 
Posts: 2
Join Date: Oct 2018
Car: Q50
Default 10-06-2018, 12:32 PM

https://www.youtube.com/watch?v=Ap2PHFKED-s

https://www.youtube.com/watch?v=qDToHr2DUBQ



More mexico runs to come, Subscribe & like!
Reply With Quote
(#3065)
Old
g0t2bmiirii's Avatar
g0t2bmiirii g0t2bmiirii is offline
Junior Member
 
Posts: 383
Join Date: Jun 2017
Car: 2017 Q50 3.0t (300hp) AWD
Default 10-06-2018, 01:50 PM

Quote:
Originally Posted by Q50GotSauce
Nice videos man, what map is your car on? Also i assume full downpi3s?


2017 Q50 3.0t Silver Sport (AWD)
Reply With Quote
(#3066)
Old
Nate0490 Nate0490 is offline
New Member
 
Posts: 13
Join Date: Sep 2018
Car: '18 Q50 Red Sport 400
Default 10-08-2018, 02:26 PM

What is the highest folks have done on their Red Sports map wise with E30?? I just did E30 last night and am going to try MAP 5 today, I've been on MAP 2 no issues with 93 pump gas.

Great site for calculating E85 and pump gas mixtures:
http://www.georgebelton.com/E85Calculator.php
Reply With Quote
(#3067)
Old
BlackQ50 BlackQ50 is offline
New Member
 
Posts: 3
Join Date: Oct 2018
Car: q50
Default 10-10-2018, 07:56 AM

Just got a brand new JB1 for my 2016 Q50 (non-sport). Getting the similar problem with P0106,P0240,P0241 after the unit was installed. Checked the pins - AOK, none are bent.

Removed the unit, unplugged the battery overnight. Drove for a day without it, but CEL was still on.

Plugged back in and started getting System Malfunction message and the car stalled. Started the car again, and System Malfunction message disappeared, but CEL is still on and the car feels underpowered.



Quote:
Originally Posted by VirusbetaX
Pics too big but codes are as listed.

P0106 manifold absolute pressure/barometric pressure circuit range/ performance

P0240 turbocharger/supercharger boost sensor B circuit range/ performance

P0101 MASS OR VOLUME air flow a circuit range/ performance

P010B MASS OR VOLUME air flow b circuit range/performance
Reply With Quote
(#3068)
Old
jrobohm's Avatar
jrobohm jrobohm is offline
Junior Member
 
Posts: 430
Join Date: Jul 2017
Car: 2017 Q50 3.0T Premium RWD
Default 10-10-2018, 08:10 AM

Quote:
Originally Posted by BlackQ50
Just got a brand new JB1 for my 2016 Q50 (non-sport). Getting the similar problem with P0106,P0240,P0241 after the unit was installed. Checked the pins - AOK, none are bent.

Removed the unit, unplugged the battery overnight. Drove for a day without it, but CEL was still on.

Plugged back in and started getting System Malfunction message and the car stalled. Started the car again, and System Malfunction message disappeared, but CEL is still on and the car feels underpowered.
Short of a faulty cable harness and/or a bad JB1 board - I would suggest the harness connectors could be still not making a good connection. I have had good luck for well over a year with my JB1/JB4 connections using silicone dielectric grease. As you might expect, your mileage may vary.
Reply With Quote
(#3069)
Old
Nate0490 Nate0490 is offline
New Member
 
Posts: 13
Join Date: Sep 2018
Car: '18 Q50 Red Sport 400
Lightbulb Latest FW? - 10-10-2018, 08:33 AM

After reading several times, its not clear to me where we get the latest fw for our JB4s? Is it the 2nd post in the thread (by Ando) with the "JB4_Q50_OBDII_4_1.hex (46.4 KB)"?
Reply With Quote
(#3070)
Old
BlackQ50 BlackQ50 is offline
New Member
 
Posts: 3
Join Date: Oct 2018
Car: q50
Default 10-10-2018, 08:34 AM

I did try to re-seat the contacts a few times.
Any chance to see if that's the issue w/ board?
Not feeling comfortable putting silicone on connectors yet.

Quote:
Originally Posted by jrobohm
Short of a faulty cable harness and/or a bad JB1 board - I would suggest the harness connectors could be still not making a good connection. I have had good luck for well over a year with my JB1/JB4 connections using silicone dielectric grease. As you might expect, your mileage may vary.
Reply With Quote
(#3071)
Old
jrobohm's Avatar
jrobohm jrobohm is offline
Junior Member
 
Posts: 430
Join Date: Jul 2017
Car: 2017 Q50 3.0T Premium RWD
Default 10-10-2018, 08:48 AM

Quote:
Originally Posted by Nate0490
After reading several times, its not clear to me where we get the latest fw for our JB4s? Is it the 2nd post in the thread (by Ando) with the "JB4_Q50_OBDII_4_1.hex (46.4 KB)"?
For JB4 owners - yes.
Reply With Quote
(#3072)
Old
JayStern85 JayStern85 is offline
New Member
 
Posts: 23
Join Date: Sep 2018
Car: Infiniti Q50 RS400
Default 10-10-2018, 03:18 PM

Quote:
Originally Posted by Nate0490
What is the highest folks have done on their Red Sports map wise with E30?? I just did E30 last night and am going to try MAP 5 today, I've been on MAP 2 no issues with 93 pump gas.

Great site for calculating E85 and pump gas mixtures:
http://www.georgebelton.com/E85Calculator.php
I've done map5 with no issues. Now i run a custom map 6 with +6 @ 4k and 4.5k only. Feels better for daily driving. No bogging down
Reply With Quote
(#3073)
Old
Nate0490 Nate0490 is offline
New Member
 
Posts: 13
Join Date: Sep 2018
Car: '18 Q50 Red Sport 400
Default 10-10-2018, 03:26 PM

Quote:
Originally Posted by JayStern85
I've done map5 with no issues. Now i run a custom map 6 with +6 @ 4k and 4.5k only. Feels better for daily driving. No bogging down
On E30? Do you know what octane your E85 is? Trying to find the best E85 station in D.C.

Also, can you tell me how you have your custom MAP setup so I can try it? (Never done a MAP 3 custom before)

Do you have any bolt-on mods (intakes, downp1pes, etc)? Thanks!
Reply With Quote
(#3074)
Old
JayStern85 JayStern85 is offline
New Member
 
Posts: 23
Join Date: Sep 2018
Car: Infiniti Q50 RS400
Default 10-10-2018, 04:31 PM

Quote:
Originally Posted by Nate0490
On E30? Do you know what octane your E85 is? Trying to find the best E85 station in D.C.

Also, can you tell me how you have your custom MAP setup so I can try it? (Never done a MAP 3 custom before)

Do you have any bolt-on mods (intakes, downp1pes, etc)? Thanks!
You can buy an E85 test tube on ebay for like $20. Summer is the highest grade (ethanol is seasonal), I tested 85% ethanol which is roughly 105 octane. Mixed with 93 you can obtain 96 octane = E30. Custom map is actually map6. I experimented with many custom maps, too much boost in low rpms can cause you to bog down and you dont nornally hit your target boost. Higher rpms tend to hit the requested boost more consistently. (Only mod is AMS HE) Try this out..

1500 3.0 psi
2000 3.5 psi
2500 4.0 psi
3000 4.5 psi
3500 5.0 psi
4000 6.0 psi
4500 6.0 psi
5000 5.0 psi
5500 3.0 psi
6000 2.0 psi
6500 1.0 psi
7000 0 psi

Last edited by JayStern85; 10-10-2018 at 04:51 PM.. Reason: Missed key point
Reply With Quote
(#3075)
Old
rocky2478 rocky2478 is offline
New Member
 
Posts: 1
Join Date: Oct 2018
Car: q60rs
Default 10-10-2018, 04:34 PM

Quote:
Originally Posted by VirusbetaX
Terry i just started noticing a high pitched whistling noise on acceleration. Here only during hard acceleration, AC is shut off and so is the audio. JB4 has not been installed yet been busy, still on JB1. There are no warning codes or MIL lights so i dont understand what could be causing this whine on acceleration? is it the turbos spooling? never heard it before. Also Performance doesnt seem to be effected either.

im having the same issue. for some reason could not recreate it at the dealer. so they did the throttle reset well types of re learning.
did u ever find out wt it was
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 8 (0 members and 8 guests)
 
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump




vBulletin Skin developed by: vBStyles.com
Copyright © 2007 - 2020, N54tech.com